rFlow Collector with MYSQL 5.0

Discussion in 'DD-WRT Firmware' started by craigbolland, Feb 12, 2007.

  1. craigbolland

    craigbolland LI Guru Member

    Here's a tip if you're using mysql 5.0 or higher with rflow collector.

    I was having problems with writing to the database, and after much trial and error this fixed it.

    Download the MYSQL gui tools (notably MYSQL ADministrator)

    Log in to mysql administrator and make sure you add a user with the username and password specified in rflow collector. Give it full access to the rflow schema.

    Go to Startup Variables > security

    Make sure Use Old Passwords is checked.

    Stop and restart the mysql service.


    Craig Bolland.
  2. lengo lad

    lengo lad LI Guru Member

    I tried to follow the instructions here: using rflow with mySQL
    Looked fairly simple, on the face of it. Couldn't get it to work. Found your solution! Still can't get it to work . . . Here are some pictures of my settings:




    Can you help me sort out what's wrong? I have two different ports: 2055 and 3306. Is that the problem? (Yes, complete novice here; just looking for a way to track per IP usage for a number of machines. Should it be this difficult?!)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice