Riddle me this, Batman! Why is only ONE laptop unable to connect ONLY to my router?

Discussion in 'Tomato Firmware' started by RogueJediX, Jul 23, 2009.

  1. RogueJediX

    RogueJediX Addicted to LI Member

    I'm really confused here. I have a Linksys WRT54GL v1.1 router with Tomato 1.25 installed and here's the problem:

    I have a wireless encryption set up so two laptops may access the net through WiFi. A short time ago, however, one laptop, HP/Compaq 8510p, to be specific, was unable to connect to my router. The kicker is that:

    a) The same laptop is able to connect to any other router (the user travels around a lot, he tried) without a problem, so I guess its wlan hardware must be okay.
    b) I've considered the possibility the OS (Vista) might be busted, so I've tried booting a linux LiveCD on it, only to get the same result.
    c) The other laptop connects to my router just fine, so I guess my router is fine, too.

    So, what gives? Why is only that specific laptop unable to connect only to my router?
  2. mstombs

    mstombs Network Guru Member

  3. TVTV

    TVTV LI Guru Member

    That's my bet also.

    Also, one of my neighbours has a weird problem with his wireless router and one of his wireless cards. Asus router, Asus wireless NIC; WNIC cannot connect to his router, but connects fine to mine. I have tried managing it with the Asus WLAN utility, tried using Windows' one, but to no avail. So yours could simply be a good ole case of the Twilight Zone too.
  4. RogueJediX

    RogueJediX Addicted to LI Member

    Sorry, for the late reply, I'm at work. Anyway, his wireless chipset is Intel's, as you predicted:

    - Intel(R) Wireless WiFi Link 4965AGN

    Will look into the link you posted when I get home, thanks!
  5. gawd0wns

    gawd0wns Network Guru Member

    Maybe the Joker enabled wireless filtering and blocked the MAC, without you knowing!!

  6. sigma

    sigma Addicted to LI Member

    3 things, first of all is kind a weard this behavior and may be the wifi controler itself, do you use the Original 1.25 Jhon Zarate build? I ask you this because i never used that version, insted i did use the ND RAF Victek's mod 1.25 (and i forgot to tell you i have a toshiba satellite that have the same 4965 AGN Chipset) and as a matter a fact i didnt have any issue regardless from the 1.23 Original to my latest 1.25 Thor Mod (the last i use actually). The connection was always clean. The second thing i suggest you is to install either Victek mod or Thor mod to your router obviously erasing nvram after loading the firmware, the third will be upgrade your wifi controler card driver (the latest is here is a direct link from intel site...


    And finally i would like to know what does Linux log tells you about the connection error? Cause if nothing of these solves your trouble, would be wise read to locate where the problem is originating.

    Well i hope this may be useful to you. Greetings :biggrin:!
  7. RogueJediX

    RogueJediX Addicted to LI Member


    Hello, all. Just wanted to let you know, I managed to fix it. After screwing around with the settings for a few minutes and upgrading the wifi drivers (that never hurts), I remembered that a while ago, I was fiddling around in Advanced -> Wireless and changed some settings. I figured it wouldn't hurt to put them all back to default and sure enough, that did the trick!

    Thank you all for your help!
  8. Toastman

    Toastman Super Moderator Staff Member Member

    Just a tip for anyone that has problems with an Intel card suddenly refusing to work one day for no apparent reason. Backup your config. Do a full NVRAM erase. Now restore your config. Post the result if it worked for you! Anyone who can tell me why, gets a packet of biscuits...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice