Rosewill L600N - possible tomato support?

Discussion in 'Tomato Firmware' started by lefty, Nov 29, 2012.

  1. lefty

    lefty Addicted to LI Member

    I have been seeing this unit around and it is fairly cheap, around $35 and basically is a linksys E2500 with external antennas and a USB port, all other hardware specs are the same cept the CPU on this unit is clocked @ 500 instead of 300, would it possible to get this unit supported or anyone have any interest in doing the port? If so, i am not afraid to provide a serial log for investigating or possibly even donate a unit. tvlz..? shibby..?
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Interesting ... if the hardware is the same then it may not need a new version. The processor was presumably previously set low in speed but now has been raised? Anyone want to try it?
    Tom emmanuel likes this.
  3. lefty

    lefty Addicted to LI Member

    Yes, the CPU is the same as i have in my E1550 as well, BCM5358, my E1550 (as well as the E2500) come clocked @ 300, i been running mine @ 400 with no problem, can't run it @ 500 though, it doesn't survive the reboot after the commit and can only be revived via 30-30-30.

    And to clarify, i haven't ordered one of these yet, but should someone show interest in getting it ported, i would then purchase and/or donate a unit if need be. I personally cannot provide a port patch, don't have the skills myself, but am fully capable of using serial or jtag if needed. :)
  4. Python46

    Python46 Networkin' Nut Member

    I have ordered a Rosewill L600N and would be interested in Tomato firmware for it. I plan to try it with OEM firmware first, but all my other routers have some form of Tomato or Gargoyle/OpenWRT in them. I've used DD-WRT, but not at the moment. It looks like E2500 is the closest match to it, but I haven't found how much NVRAM it has.
  5. tvlz

    tvlz LI Guru Member

    I can try to make a version if you will test?
    First few builds might brick the router!

    Need to get copy of the CFE, Nvram & dmesg listings
  6. avrakin

    avrakin Serious Server Member

    Is there a way I can pull that info from the router? I am guessing over telnet. I got one over Black Friday. It's an awesome router for the price but ddwrt/gargoyle/tomato would make it awesomer.
  7. lefty

    lefty Addicted to LI Member

    I actually was going to order one of these when they were $35, the next day newegg decided to put it up to $45, so that was a deal breaker for me. Guess they been reading the forums to and decided if someone was interested in a 3rd party port, they would sell more. But they should have waited till someone ported it first... because i can get an E2500 for around $28, which is almost the same router.

    Anyhow, you'll need a serial connection to the router to get the info needed for the port. Its not something you can do with just a software connection, you'll have to actually open the unit up and hook a serial cable (ca-42 clone or some other USB serial TTL that can do 3.3v level shifting) up to the serial port and capture what it outputs.
  8. Cynsick

    Cynsick Addicted to LI Member

  9. tvlz

    tvlz LI Guru Member

    You could try this:

    the rest you can get with Putty
    You'll still need a serial connection to unbrick the test firmware if it bricks when it bricks
  10. Cynsick

    Cynsick Addicted to LI Member

  11. Tom emmanuel

    Tom emmanuel Reformed Router Member

    I tired but not working. Tried renaming file .trx to .img. But receiving error "update failed".Can someone help???Should I try "tftp" for flashing???
  12. shibby20

    shibby20 Network Guru Member

    yes, try via tftp. In changelog we can read: Rosewill L600N - Untested but in Tomatanon
  13. Cynsick

    Cynsick Addicted to LI Member

    Let us know what happened.
  14. damionhh

    damionhh Networkin' Nut Member

    i have the rosewill L600n and i have tried flashing via the GUI and also through tftp but the GUI aborts with a page reset and the TFTP never actually transfers the file, it times out. i followed the instructions with the dual terminal windows, one pinging and one with the tftp command. has anyone made this work?

    @Tom emmanuel did you get further?
  15. Tom emmanuel

    Tom emmanuel Reformed Router Member

    @damionhh Same here.Unable to update using both methods.Can some senior members help?????
  16. sonumb

    sonumb Reformed Router Member

    My goal here is get a third-party firmware working on the router and to assist in anyway that I can without bricking the router since I have neither the tools nor experience to use jtag or serial at this time to restore it.

    Unable to flash this firmware, extensive details provided below:

    Trying to flash using the web GUI it gives an "Invalid flash image!" error message, changing the name and the extention to .img which is what the stock firmware uses gives the error "Unable to update!". When the router is placed in recovery mode by holding down the reset button and pluging it in there is a special firmware page that is available even though the router can not be pinged which does not requie a password and appears as follows:

    Update Software

    Step 1: Obtain an updated software image file from your ISP.

    Step 2: Enter the path to the image file location in the box below or click the "Browse" button to locate the image file.

    Step 3: Click the 'Update Software'button once to upload the new image file.

    NOTE: The update process takes about 3 minutes to complete, and your DSL Router will reboot.

    Using that page regardless of naming convention yeilds the error message: "Checksum validation failed! You should translate image again!"

    There does not appear to be a running tftpd server on the router though the binary is there.

    There is telnet access available after the router is booted into normal run mode. The user name is root and the password is root. It has a working tftp client available and I presume that I could flash by using that to put the image in /tmp, I am not comfortable doing so with the checksum failing unless I can be assured by you that it doesn't matter and is not a sign that it is incompatible in some way as I am currently assuming.

    localhost login: root

    BusyBox v1.6.1 (2013-05-06 15:43:50 HKT) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    # tftp
    BusyBox v1.6.1 (2013-05-06 15:43:50 HKT) multi-call binary

    Usage: tftp [OPTION]... HOST [PORT]
    The latest stock firmware is here:

    The 2.6.30 source code is here:

    Information from the telnet session:

    # cat /proc/cpuinfo
    system type : Broadcom BCM5357 chip rev 2
    processor : 0
    cpu model : MIPS 74K V4.9
    BogoMIPS : 249.85
    wait instruction : no
    microsecond timers : yes
    tlb_entries : 64
    extra interrupt vector : no
    hardware watchpoint : yes
    ASEs implemented : mips16 dsp
    VCED exceptions : not available
    VCEI exceptions : not available

    unaligned_instructions : 15
    dcache hits : 2147483648
    dcache misses : 805299613
    icache hits : 2147483648
    icache misses : 3724505022
    instructions : 2147483648

    # cat /proc/meminfo
    MemTotal: 60072 kB
    MemFree: 41540 kB
    Buffers: 684 kB
    Cached: 4412 kB
    SwapCached: 0 kB
    Active: 5336 kB
    Inactive: 2908 kB
    HighTotal: 0 kB
    HighFree: 0 kB
    LowTotal: 60072 kB
    LowFree: 41540 kB
    SwapTotal: 0 kB
    SwapFree: 0 kB
    Dirty: 0 kB
    Writeback: 0 kB
    AnonPages: 3164 kB
    Mapped: 3392 kB
    Slab: 6208 kB
    SReclaimable: 884 kB
    SUnreclaim: 5324 kB
    PageTables: 288 kB
    NFS_Unstable: 0 kB
    Bounce: 0 kB
    CommitLimit: 30036 kB
    Committed_AS: 6800 kB
    VmallocTotal: 1015800 kB
    VmallocUsed: 3576 kB
    VmallocChunk: 1009968 kB

    # cat /proc/version
    Linux version 2.6.22 (zhengmingming@localhost.localdomain) (gcc version 4.2.3) #1 PREEMPT Mon May 6 15:42:41 HKT 2013

    # ps
    PID Uid VSZ Stat Command
    1 root 1440 SW init
    2 root SW< [kthreadd]
    3 root SWN [ksoftirqd/0]
    4 root SW< [events/0]
    5 root SW< [khelper]
    24 root SW< [kblockd/0]
    25 root SW< [ksuspend_usbd]
    28 root SW< [khubd]
    51 root SW [pdflush]
    52 root SW [pdflush]
    53 root SW< [kswapd0]
    54 root SW< [aio/0]
    607 root SW< [mtdblockd]
    677 root 2680 SW /usr/sbin/mini_httpd -d /usr/www -c /cgi-bin/* -u roo
    680 root 2584 SW /usr/bin/pc
    681 root 4904 SW /usr/bin/logic
    685 root 1448 SW /usr/sbin/inetd
    686 root 1440 SW -sh
    1791 root 1732 SW /usr/sbin/eapd
    1798 root 2124 SW /usr/sbin/nas
    1806 root 3204 SW /usr/sbin/wps_monitor
    1828 root 2296 SW /sbin/dproxy -c /etc/resolv.conf -d
    1829 root 1216 SW /sbin/udhcpd /var/udhcpd.conf
    2232 root 1156 SW /usr/sbin/mcpd
    2260 root 6356 SW /sbin/smbd -D -s /var/smb.conf -l=/tmp/smbvar/ --lock
    2264 root 3688 SW /sbin/nmbd -D -s /var/smb.conf -l=/tmp/smbvar/ --lock
    2265 root 6356 SW /sbin/smbd -D -s /var/smb.conf -l=/tmp/smbvar/ --lock
    2491 root 1440 SW telnetd
    2492 root 1448 SW -sh
    2533 root 1440 RW telnetd
    2534 root 1440 SW -sh
    2538 root 1440 RW ps

    # lsmod
    Module Size Used by Tainted: PF
    wl_high 1114288 0 - Live 0xc04a0000 (P)
    ehci_hcd 44192 0 - Live 0xc00be000
    wl 1835360 0 - Live 0xc02de000 (P)
    et 66160 0 - Live 0xc00ac000 (P)
    igs 21744 2 wl_high,wl, Live 0xc008e000 (P)
    emf 24896 3 wl_high,wl,igs, Live 0xc0086000 (P)
    ctf 17600 0 - Live 0xc0070000 (P)
    led 12432 0 - Live 0xc0077000 (F)
    btn 6384 1 - Live 0xc006d000 (F)
    product 1280 2 led,btn, Live 0xc0067000

    # ls /sys/module/
    8250 igs nf_nat_ftp tcp_cubic
    bcm947xx_flash iptable_filter ppp_async usb_storage
    btn led printk usbcore
    ctf loop product usblp
    ehci_hcd nf_conntrack rcupdate wl
    emf nf_conntrack_ftp rd wl_high
    et nf_conntrack_tftp scsi_mod

    # cat /proc/mtd
    dev: size erasesize name
    mtd0: 00030000 00010000 "boot"
    mtd1: 001420a4 00010000 "linux"
    mtd2: 0068df5c 00010000 "rootfs"

    # cat /proc/mounts
    rootfs / rootfs rw 0 0
    /dev/root / squashfs ro 0 0
    null /proc proc rw 0 0
    tmpfs /var tmpfs rw 0 0
    none /sys sysfs rw 0 0
    devpts /dev/pts devpts rw 0 0
    tmpfs /mnt tmpfs rw 0 0
    none /proc/bus/usb usbfs rw 0 0
    tmpfs /dev/usb tmpfs rw 0 0

    # cat /proc/interrupts
    3: 151278 MIPS wl0
    4: 14519 MIPS bcmsw
    5: 132135 MIPS ehci_hcd:usb1
    7: 277942 MIPS timer
    8: 3386 IRQ2 serial

    ERR: 0

    # cat /etc/services
    ftp-data 20/tcp
    ftp 21/tcp
    telnet 23/tcp
    tftp 69/udp
    netbios-ssn 139/tcp
    netbios-ns 137/udp
    syslog 514/udp

    Software Version: AP699E5N3.AU81L-5-dualband-TW-TBS-R1B001D51252
    Compile Date: Mon May 6 15:53:57 HKT 2013
    Compile Author: zhengmingming
    Flash : KH25L3205DM2C-12G

    # ls /usr/bin/
    [ dumpcfg fuser killall mesg tftp
    [[ ebtables getpagemap logger pc tftpd
    arping flash_test getsmaps logic protest traceroute
    cut free inadyn logmonitor test upgrader

    Looks like we could enable the tftpd server for an update as well, possibly.

    Submitted as a bug on Shibby's site.
    Last edited: Jan 3, 2014
  17. sonumb

    sonumb Reformed Router Member


    CHIPSET: BCM5358U+BCM432


    STANDARDS: IEEE 802.3u IEEE 802.11a/b/g/n


    INTERFACE: 1x 10/100M WAN port 4x 10/100 LAN ports

    FREQUENCY BAND*: 2.4Ghz / 5 Ghz

    RADIO DATA RATE: 2.4Ghz - 300 / 5Ghz - 300

    MODULATION: Support 256/64/16/8-QAM, QPSK, BPSK. MCS0 - MCS15

    SECURITY: 64/128 bits, WEP, WPA-PSK (TKIP), and WPA2-PSK (AES) wireless encryption

    ANTENNA: 2x 5dBI Dual Band Antenna

    TEMPERATURE: Operating. (32°F - 104°F)


    Probably already known.

    Why does the router itself say it's the 5357 Rev 2? Is that supposed to be the same CPU as the 5358U?

    @shibby20 & @Toastman You have any ideal why shibby fails the checksum? That makes me nervous about trying another method.

    @damionhh & @Tom emmanuel Do either of you have jtag or serial to restore? May be able to flash through telnet using the tftp client on the router and placing the file in the right place with the appropriate name. Have you been able to access a tftp server and start erasing or uploading? If so how did you do it?
    Last edited: Jan 3, 2014
  18. mdburkey

    mdburkey Network Guru Member

    A few more things of note...

    I've been poking around in the /usr/www folder and there are a lot of references to Netgear in the scripts. Whether that means this is derived from a Netgear router or they simply used some of Netgears (hopefully) opensource code is a completely different issue.

    Also, you all do realize that there is a USB port on the unit and that it is already automounted under /mnt/usb1_1??

    I was able to do a full tar of the rootfs to my USB stick for easier perusal.
    It also may be possible to do an update to Tomato from USB as well.

    Also, there are actually 6 mtd's on the unit, but only the first three appear to be used for the default config (bootloader, kernel, rootfs).

    I'm thinking it may be possible to actually manually derive the upgrade sequence from the current filesystem and web server information.
  19. thesofine

    thesofine Network Newbie Member

    I am having the same issues trying to flash this router. How would I go about doing it through the USB?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice