route modem ip option

Discussion in 'Tomato Firmware' started by trpted, Jan 19, 2012.

  1. trpted

    trpted Network Guru Member

  2. Toastman

    Toastman Super Moderator Staff Member Member

    It can be done, of course. But we've been having trouble understanding exactly why these guys are trying to do, what their configuration is. Their point seems to have got lost in the mist. Just curious, can you explain?
  3. Nitro

    Nitro Networkin' Nut Member

    I thought the route ip option was so that you could still access your modems HTTP gui interface, I use a netgear ADSL router that allows for low SNR values to increase my connection speed, In modem mode the router purely acts as a modem but I can still access the HTTP gui to control a few settings, now with tomato setup i can no longer access the modems HTTP gui.
  4. Toastman

    Toastman Super Moderator Staff Member Member

    For your application, ADSL, then it should work, as that is why it is there. It's the guys that were linked to that are confusing. So, let's address your problem. What is the modem and type of connection, presumably it is in bridged mode (the router handles PPPOE login) and so on. Doesn't the GUI give you the option or is it not PPPOE? What is the modem's IP address? Is it in a different subnet to your LAN clients, all the usual stuff ?
  5. Nitro

    Nitro Networkin' Nut Member

    First off I am not the OP, I just have the same/similar issue.

    My modem IP:
    My Tomato Router IP:

    I am using PPPoE mode which allows me to insert the route modem ip, but I cannot get my modems HTTP interface.

    come to think about it I am using the VLAN build and it may be the source of my problem.
  6. Toastman

    Toastman Super Moderator Staff Member Member

    In your case, the modem IP is in the same subnet as your router/clients. That is why it isn't working. Set the modem's IP to say instead and stick that IP in the box, and you should find it'll work.

    Linked from "Common Tomato Topics" :-

    I'm going to add a warning in the GUI that the modem IP must be in a different subnet to the router.
  7. Nitro

    Nitro Networkin' Nut Member

    thanks toastman that worked for me, Sorry I should have looked/searched first, I will get better at this :p
  8. trpted

    trpted Network Guru Member

    #1 Since you asked, I will answer.

    LAN IP of modem combo in bridge mode =

    Modem is a Westell F with only one LAN port.

    I know that the LAN IP of RJ-45 WAN port router running tomato should be a different subnet then - but I see only the route modem ip if I select DHCP or PPPoE. It is of no use to me to change the LAN IP of the router to other subnet, at this time.

    WAN IP of RJ-45 WAN port router running tomato WAN IP starts with 71.242 (type of connection Static)

    #2 Do you suggest that I use Toastman tomato firmware instead of the tomato firmware from developed by shibby ( )?

    If so, please recommend which one has the route modem ip option (not limited to only DHCP or PPPoE), supports IPv6 by GUI - for my Linksys E4200v1.


    [EDIT] Never mind my question 2. Your firmware does not have that option either. I posted in the thread that you linked to.
  9. teaman

    teaman LI Guru Member

    Yeah... the VLAN GUI version of the basic-network.asp page is missing that warning/check (non-VLAN GUI builds do check for this 'same IP range' issue and throw an error if the modem IP address overlaps the LAN IP address space). My bad! (although, this is on my TODO list).

  10. Porter

    Porter LI Guru Member

    I've tried this feature and it didn't work right out of the box (K24 build).

    I needed to add this line under Administration/Scripts/Init:

  11. Toastman

    Toastman Super Moderator Staff Member Member

    trpted, I will enable this in the next version, give it a try.
  12. Porter

    Porter LI Guru Member

    I'll have to correct myself, somehow this line doesn't stick.

    I'm using a WRT54GL with a Toastman K24 build and now I added this line under Administration/Scripts/WAN Up:

    This enables the ARP Proxy feature for br0, without it local clients won't get the hardware address of the modem and can't connect to it.
  13. trpted

    trpted Network Guru Member

    I will try soon...

    I now see that option for DHCP, PPPoE and for Static IP. :)

    What about other users who are on PPPTP OR L2TP?


    [EDIT] I tried it, and it works. :)
  14. Cyntil8ing

    Cyntil8ing Serious Server Member

    I'm having the same issue. I'm trying to access my router's GUI. I'm currently using a WRT310n v2 with a 1.28.0000 MIPSR2-123 K26 Mini build. The modem's a Zyxel P660R-D1 with a custom firmware.

    If I connect to my modem directly, I have to create a static ip to access the modem's UI via this method.

    Pertinent info:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice