Router does not reauthenticate PPPoE connection

Discussion in 'Tomato Firmware' started by Jeff65, Dec 14, 2010.

  1. Jeff65

    Jeff65 Addicted to LI Member

    Router does not reauthenticate PPPoE connection - but only sometimes. This afternoon I've come home and while I have an ADSL sync on the modem, the router is just repeating this for hours:
    Dec 14 16:30:14 ? redial[26987]: WAN down. Reconnecting...
    Dec 14 16:30:14 ? dnsmasq[26985]: exiting on receipt of SIGTERM
    Dec 14 16:30:14 ? dnsmasq[26993]: started, version 2.55 cachesize 150
    Dec 14 16:30:14 ? dnsmasq[26993]: compile time options: no-IPv6 GNU-getopt no-RTC no-DBus no-I18N DHCP no-scripts TFTP
    Dec 14 16:30:14 ? dnsmasq-dhcp[26993]: DHCP, IP range --, lease time 1d
    Dec 14 16:30:14 ? daemon.warn dnsmasq[26993]: no servers found in /etc/resolv.dnsmasq, will retry
    Dec 14 16:30:14 ? dnsmasq[26993]: read /etc/hosts - 0 addresses
    Dec 14 16:30:14 ? dnsmasq[26993]: read /etc/hosts.dnsmasq - 9 addresses
    Dec 14 16:30:21 ? pppoe[26996]: Starting
    Dec 14 16:30:21 ? pppoe[26996]: Sending PADI.
    Dec 14 16:30:21 ? redial[26995]: Started. Time: 30
    Dec 14 16:30:31 ? pppoe[26996]: Resending...
    Dec 14 16:30:41 ? pppoe[26996]: Resending...
    Dec 14 16:30:49 ? pppoe[26996]: Resending...
    Dec 14 16:30:57 ? pppoe[26996]: Resending...
    Dec 14 16:31:01 ? redial[26995]: WAN down. Reconnecting...
    Again this doesn't happen every time the modem loses sync, only once in a while.

    Power cycling the modem fixes the problem.
    Resyncing or rebooting the modem does not fix the problem.
    Power cycling the router does not fix the problem.

    The interesting thing is it happens with two different modems, but never with a third, older modem which is of course the one I don't want to use for unrelated reasons.

    The router is this model:
    Linksys WRT54GL v1.1

    The fault happens with all three of the following firmware versions:
    Tomato 1.19
    Tomato 1.27
    Tomato RAF 1.28.8515

    The fault happens with either of these used as modem in bridge mode:
    Alcatel SpeedTouch 536
    TP-Link TP8810

    The fault does not happen with this used as modem in bridge mode:
    Netgear DG834 v1 (very old)

    Any ideas?
  2. mstombs

    mstombs Network Guru Member

    Not sure if it is significant - but I think problem modems are both Broadcom ADSL chipset, the 3rd Ti AR7.
  3. Toastman

    Toastman Super Moderator Staff Member Member

  4. Jeff65

    Jeff65 Addicted to LI Member

    Hi Toastman,

    Thanks for the recommendation. It's too bad the models you list aren't common (none on eBay right now). I'd give them a try.

    Reading the rest of the thread for the post you provided, yours does not sound like the exact problem that I have.

    I have ADSL sync when this problem occurs. I can pull up the modem configuration page or use DMT and see that it is synced. The problem is that the router can't authenticate PPPoE until the modem is power cycled.

    It could, however, have something to do with ADSL2+ as you say. Now that I think about it, I had the Alcatel set to connect using ADSL1 for a time trying to troubleshoot my line drop out issues and I don't recall having this problem while it was set this way. I'd rather not be stuck with ADSL1 though.

    Any other recommendations? I can't keep using this old Netgear. It drops sync much more often than the other modems and it generally syncs slower.
  5. Jeff65

    Jeff65 Addicted to LI Member

    Thanks mstombs,

    I bought those modems because the Broadcom chip set is known to work well with my ISP's DSLAM hardware. I guess I'm the lucky exception.

    The Broadcom modems seem faster and more stable than the Netgear, but it isn't acceptable to come home from work and find the internet has been down for 10 hours because the router can't authenticate PPPoE.

    What other chip sets might I try?
  6. mstombs

    mstombs Network Guru Member

    I'm not sure if pppoe problems are just down to chipset, I suspect the hardware support package is related, there's a dsp and multifunction cpu chip and drivers with an OS built around. There are 3rd party firmwares to the netgear - DGTeam I recall, but there may also be updates for the Speedtouch (possibly public beta),

    there are also 3rd party diagnostic tools for older versions of Speedtouch only.
  7. Jeff65

    Jeff65 Addicted to LI Member

    Thanks for the reply mstombs.

    Don't forget that it happens with two different Broadcom chip set modems. I'm not sure how much more the two modems have in common.

    Another point: I've found at least report of someone experiencing the exact same issue and a few others reporting issues that could be the same. They were all using Tomato of one flavour or another.
  8. occamsrazor

    occamsrazor Network Guru Member

    I've been having similar problems with a Dlink DSL - 2520U adsl modem, used in bridging mode, and WHR-G54S Tomato doing the PPPoE.
    I thought it was a problem with the exchange, but maybe it's not. Power-cycling the modem or router doesn't help. The Dlink DOES have ADSL sync, but there's no successful PPPoE connection.
    Unfortunately my main WL-500GPv2 router may be bricked (unrelated), so am having to use my backup WHR-G54S....
  9. mstombs

    mstombs Network Guru Member

    The 2520U also Broadcom ... but only failure mode I can imagine is they hang on to the DSL line when they should drop and resync.

    Quite common to see reports of issues with pppoe, there was a Tomato mod with rp-ppoe 3+ I recall - tomato uses pppoecd (which dates back to Linksys origin) - don't use pppoe myself!
  10. occamsrazor

    occamsrazor Network Guru Member

    I think my problem may be different than others on this thread, as power-cycling the modem seems to work for them, whereas each time it happens I need something fixed at the other end i.e. exchange.
    Would it be better to let the 2520U do the PPPoE also? But then I'd have to deal with a double-NAT situation, right?
    Is this problem related to this "Firewall_blocks_DHCP_renewal_responses" problem at all do you think?
  11. mstombs

    mstombs Network Guru Member

    I wouldn't recommend double-nat (+dmz essential for upnp and port forwards to work), double the chances of nat tables to fill, and defeats all those conntrack helper related fixes in tomato... Don't think the dhcpc wan issue is relevant, when using bridge mode the ppp endpoint interface is created inside the Tomato router.

    I think it needs someone with a working pppoe client on a PC to see if problem is the bridge modem or not. If it can be made to work with a Linux PC, then Tomato could be made to work also!

    The modem has to use something called br2684ctl and libatm with kernel support to do the bridging, ancient bit of code likely to have vendor specific versions in use in modems
  12. Toastman

    Toastman Super Moderator Staff Member Member

    jeff65, yes, I had two distinct problems with modems. The first problem was what you have, the modem would be synced but the router couldn't use it. It seemed that there was a "session" number involved with the connection, and that since that "session" no longer related to the one Tomato was trying to initiate, nothing would connect until the original session was destroyed by rebooting the router. However, that issue was fixed by a change in the firmware by Teddy Bear, I believe, leaving me with the second problem - which was described in the post I linked to. Thanks to the lousy search facility on the forum, I can't seem to find the original thread.

    But as mstombs says, this issue seems to keep popping up. Whatever the reason, the fact is, some modems do have a problem and some don't. In my case I found some that worked using the exact same chipset as another which didn't work - but those were a different manufacturer or model number. So they would be running different firmware. Also, different DSLAMs may have different responses. In this country we mainly seem to have Huawei DSLAMs. Perhaps other DSLAMS time out unused connection ID's. Or maybe I'm talking nonsense ...

    I tried to buy something with Broadcom chipset, because google told me they were reliable, but couldn't find anything in the shops here. However, I found many people who did have Broadcom complaining in different forums. Not just tomato, but other setups too.

    If I find the original thread, I'll post it. It might have a clue for you. Here are some threads that related to the problem, but I know there was another thread where the "session" number was discussed. This reference popped up in one of the logs, something about an unrecognized session or connection "ID".

    You can turn up articles back to 2007 by an advanced search for "ADSL2" in the Tomato thread.
  13. Jeff65

    Jeff65 Addicted to LI Member

    Hi Toastman,

    Thanks for the help.

    You say you rebooted the router above. I never have to do this. It doesn't fix the problem. I have to reboot the modem.

    The problem was fixed by Teddy Bear - somewhere I thought I read that Tomato RAF incorporates Teddy Bear mods. Should I try Teddy Bear?

    I find the searches troublesome on this issue too. When I was looking into the issue a few months ago I found someone on a forum with the exact same issue. I can't find it now. In the end I think they switched to using half bridge mode which I don't really want to do.


  14. occamsrazor

    occamsrazor Network Guru Member

    I think it may have been the MLPPP mod, this old post seems to talk about it.
  15. Toastman

    Toastman Super Moderator Staff Member Member

    Jeff65, yes, recent Victek mods use Teddy Bear's code as a base, (as do we all nowadays) so it *should* be the same. However, there's no harm in trying different builds, of course. Good luck!
  16. Toastman

    Toastman Super Moderator Staff Member Member

    >jan  1 07:00:07 pppoe[386]: received pads. sid: 0xc30b 

    This is the ID I was talking about I believe.
  17. Jeff65

    Jeff65 Addicted to LI Member

    From reading it looks like I can't use Tomato/MLPPP firmware unless my ISP supports MLPPP. Is that right? I'd be willing to give it a try.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice