Router not working...Bricked router?

Discussion in 'Cisco/Linksys Wireless Routers' started by OmegaChrono, Apr 22, 2006.

  1. OmegaChrono

    OmegaChrono LI Guru Member

    For awhile it seemed like my router slowed my connection down, it said it was under a firewall or something. I wasn't really sure what to do. I tried installing the DD-WRT Standard firmware (I didnt really think it would solve anything but I just didnt know what to do.) Well it still didnt make difference to the speed of my connnection. But then a week later my router stopped working all together, now the only way I'm able to use my cable modem is by directly connecting it to my computer.
    I'm using a WRT54G v4 if that has anything to do with it. I've tried hard resetting it, but that doesnt seem to work. Does anyone know how I might fix this?
  2. Toxic

    Toxic Administrator Staff Member

    are you able to ping the router at all?
  3. OmegaChrono

    OmegaChrono LI Guru Member

    I'm not sure how to do that, but I'm guessing no because it doesn't seem like the connection is working at all.
  4. howardp6

    howardp6 Network Guru Member

    Go to Programs then leftclick Accessories, then command prompt. Type in ping
  5. OmegaChrono

    OmegaChrono LI Guru Member

    nope im not getting anything from pinging the router (100% Loss)

    Any other ideas that may help?
  6. FaQso

    FaQso Network Guru Member

    Did you try holding down the reset button for 30 sec? That sets factory defaults.
    If that still doesn't work, try this:
    go to start->run...
    type cmd and hit enter
    unplug power supply from the router
    type ping -t
    hit enter
    now, while pinging, plug the router back in.

    If you get any response to ping, the router is still alive, and you can still fix it. Usualy you get 2 responses and then silence again. Thats good.
    In other case, there is a manual to unbrick a bricked router, but it WILL void your warranty.
  7. step-hen

    step-hen Network Guru Member

    addition to faqso's instructions: if you can get hold of one, put a hub/switch in between your pinging PC and the router. This will keep the eth interface up and you're less likely to miss a response
  8. OmegaChrono

    OmegaChrono LI Guru Member

    I voided my warranty, but I somehow got my router to ping again...but now I'm having problems with putting the firmware on. whenever i try that
    tftp -i "asdgadfga.bin".bin
    command i seem to get an error or something.
  9. svg1

    svg1 Network Guru Member

    Your tftp command is incorrect . Should be tftp -i put "asdgadfga.bin"

    You also dont need the extra .bin at the end .

    Set a static ip of , subnet mask of , default gateway of on the pc thats sending the tftp command .

    If using a software firewall make sure its either disabled or set to allow outbound access to the tftp app .

    Plug in the router & immediatly hit enter . It may take a few tries before you catch the bootloader so dont give up after a few failed attempts .

    First time i ever recovered a router via tftp i think it took about 8 or so attempts .

  10. OmegaChrono

    OmegaChrono LI Guru Member

    When I try that I seem to get the this:
    tftp: don't know host '-'
    Did I type something wrong? or did I not do it fast enough?
    another time when I did it i got this:
    Transfers files to and from a remote computer running the TFTP service
    TFTP [-i] host [GET : PUT] source [destination]
    and then a whole bunch of other stuff...
    I dont really know what to do with that if I'm even supposed to get that.
  11. svg1

    svg1 Network Guru Member

    Try tftp put "asdgadfga.bin"

    Also the file name & its location should be in between the quotation marks .

    Example : tftp put "C:\Documents and Settings \Guest\Desktop\WRT54GV3.1_4.01.1_fw.bin"

    When you tftp a file the app needs to know the path or location of the file not just the filename .

    What i usually do is drag the bin file to my desktop then type the command of tftp 192,168.1.1 put , then drag the bin file from the location on my desktop into the command prompt window & the filename & its path are automatically entered .
  12. FaQso

    FaQso Network Guru Member

    You may try to lower your ethernet card speed too.
    Set it to 10Mb half duplex

    And if you have any chance, get a linux machine. It's much simpler.
    I don't know the commands exactly. I'll update this post.
  13. OmegaChrono

    OmegaChrono LI Guru Member

    I'd like to try linux, but it seems many of the programs I use are windows-only.

    After trying it again I got a different error...
    I forgot what it said but I"ll post it next time I try again.
  14. FaQso

    FaQso Network Guru Member

    If you do get a linux machine (ask a friend) try:
    # tftp
    # tftp> verbose
    # tftp> binary
    # tftp> open
    # tftp> put nameOfTheImage.bin

    and then quickly plug in the power cord of the router.

    Don't mind the # and tftp>. Don't write that in console.
    I'm not sure if its "open IP" or "connect IP", but you'll figure it out.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice