Routers (used as switches/aps) cannot access the internet, while connected clients can

Discussion in 'Tomato Firmware' started by edwinvdb, Nov 8, 2017.

  1. edwinvdb

    edwinvdb New Member Member

    I have a setup consisting of a main router (connected to the router of the ISP), and connected to it are 3 other routers used as switch/ap. I enabled VLAN's and virtual wireless, primarily to allow a guest wifi network on all routers.

    For some reason, all clients connected to any of the routers can access the internet without problems and can also access the routers (ping), but the routers that I use as switch/ap cannot access the internet.

    I *think* it worked some time ago (because I didn't notice the switches/aps NOT getting a time from the internet time server), but now not anymore.

    Anyone any ideas what could cause the switches/aps being unable to access the internet, while all clients connected to it can?


  2. ruggerof

    ruggerof Network Guru Member

    A few questions:
    - are the routers used as switch/AP running Tomato?
    - is "NOT getting a time from the internet time server" the only indication you have that they cannot access the internet?
  3. edwinvdb

    edwinvdb New Member Member

    - Yes, all routers are running Tomato. The ones used as switch/ap are still on v120, the main router is on v140. But I think it has worked in the past with v120 and I don't know what changed

    - No, also SSHing to the router and pinging the main router or a public address like fails.
  4. ruggerof

    ruggerof Network Guru Member

    It means that the VLAN bridged to br0 is not correctly set either in the main router or in the APs (or both). I remember someone mentioning that in the past it wasn't necessary to tag for br0 but now it is required so check if the port that connects the main router to the AP's are tagged for all LAN's (brX)

    Attached Files:

  5. edwinvdb

    edwinvdb New Member Member

    Thanks for the suggestions, but I have the ports correctly tagged, so that's not the issue. I bought a new router, because the old one wasn't fast enough anymore, so I'll test with that one to see if maybe something went wrong in the NVRAM...
  6. Sean B.

    Sean B. LI Guru Member

    Are the switches/AP's using a LAN port to connect to the main router? If so, verify you have the main router's IP set as the default gateway in the switches/AP's ( clients on the switches/AP's will get the gateway via DHCP however the switches/AP's will not when connected via LAN port ). I assume br0 on the switches/AP's has a VID corresponding to an existing VID on the main router, and has an IP within the same range as said VLAN?
    Last edited: Nov 11, 2017
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice