Routing problem with WRV54G <==> Other Router tunnel

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by sachafournier, Jan 5, 2006.

  1. sachafournier

    sachafournier Network Guru Member

    Hi all,

    At my office we have a WRV54G and configured it to acces the internet over ADSL modem. Everything works fine yet. Now we need to configure our WRV54G to establish a tunnel with our partner's router to acces their ressources. I've followed their instructions to configure our WRV54G and made some tests with their technician. Phase 1 works fine, phase 2 as well. But we can't ping any of our partner remote PCs. Using TRACEROUTE with an remote IP does not go throught the tunnel. Instead it goes throught internet.

    Internet using PPPOE

    IPSEC passthrought "enabled"
    PPTP passthrought "enabled"
    L2TP passthrought "enabled"
    VPN Tunnel "enabled"
    VPN Gateway "disabled"
    Local Secure Group:
    Remote Secure Group:`"Host"
    Remote Secure Gateway:

    Encryption, Authentication and pre-sharedkey is OK.

    Any idea why our lan PCs traffic distinated to our partner tunnel is not routed throught the tunnel but the internet ?
  2. TazUk

    TazUk Network Guru Member

    Re: Routing problem with WRV54G <==> Other Router tunn

    That should be the remote subnet rather than Host ;) Having it set to host means the VPN tunnel will only be used for that specific IP address rather than any in that subnet/range :)
  3. sachafournier

    sachafournier Network Guru Member

    I see, but I've tried to set my remote secure group to before and had the same result.

    I'm wondering, is the WRV54G suppose to add some routing table entries when connecting a tunnel ? I'm asking cause I don't see any added entries in routing table related to the tunnel. It may be trhe reason why all my packets destinated to 10.*.*.* is routed to the internet and get lost....
  4. DocLarge

    DocLarge Super Moderator Staff Member Member

    Most of the problem is with your configuration (as Taz pointed out) and probably your preshared key. Use something like this with an "x" in it: testlanx1234

    Try this PPTP configuration on your side of the tunnel:

    Local Secure Group:

    Remote Secure Group: Subnet (Enter remote LAN & subnet mask)

    Remote Secure Gateway: IP Address (Use remote WAN IP for this)

    NOTE: Set your timeouts in Phase I and II for 3600; also check "Netbios broadcast" and leave everything else blank.

  5. sachafournier

    sachafournier Network Guru Member

    Is there any reason why I should put an "x" in my pre-sharedkey ?
  6. DocLarge

    DocLarge Super Moderator Staff Member Member

    I've noticed with some of the units that using an "x" help (hey, I just use what works). For example, on the WAG54G, you could use a key of linksyvpn1234 and it won't connect (could be also due to firmware). But, if you did linksysvpnx1234, the tunnel instantly connects.

    This is just a suggestion I'm making because of having to tinker with setup formats to get things to work. :)

  7. sachafournier

    sachafournier Network Guru Member

    Great. It's working now. There was some differences between our configuration and their configuration. Sorry for about that. And thank you for the help.

    Actually, I have an other question. But I'll post it in a new thread since it's not related.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice