RT-N12/B1: 3 LAN Ports not functioning?

Discussion in 'Tomato Firmware' started by joe_k, Aug 2, 2013.

  1. joe_k

    joe_k Reformed Router Member

    I recently bought an Asus RT-N1/B1 router. I pretty much immediately flashed the latest Shibby build on it. Now only 2 of the physical ports are active: the WAN port, and LAN2 port. All other ports seem to simply be dead. I get no lights or activity at all if I plug into them. I'm fairly certain the ports were working before the update -- but I didn't explicitly test them all beforehand. But the port I was plugged into when I flashed is one that is no longer working, so I know at least THAT port had worked previously.

    I've tried reflashing multiple times, and I now have a Toastman build flashed. But still, only the WAN and LAN2 port work. And I'm not even entirely sure which those actually map to in the firmware itself.

    Has anyone experienced anything like this? Or have any suggestions on how to troubleshoot or fix it? I suppose I should try to flash the default ASUS firmware and see if that works. I've searched quite a bit and can't seem to find anyone with a similar problem.
  2. koitsu

    koitsu Network Guru Member

    Once in the Tomato-based firmware, did do Administration / Configuration / Restore Default Configuration / Erase all data in NVRAM (thorough) ? If not, start there. My guess is that this is the issue; a single switching IC is responsible for 5 ports (4 LAN and 1 WAN), and there are NVRAM variables which control certain assignments and behaviours of those ports.

    Otherwise, I recommend you try rolling back your firmware to the original Asus firmware and see if those 3 ports suddenly start working again. Please report back with your results.
  3. joe_k

    joe_k Reformed Router Member

    I know this is old, but I basically got lazy, and since it was working fine for it's main purpose (which was a second AP), I hadn't bothered trying to fix it. So I had no updates. Until two days ago.

    I've tried everything to get this thing working, to no avail. I'm thinking the unit is probably defective. I've tried multiple times to reflash the stock Asus firmware, and it never succeeds. I've used the "Firmware Restoration Tool" provided by Asus. I've tried using the emergency web interface. And I've tried flashing from a non-stock firmware. They all *appear* to succeed, but the firmware never actually flashes. At least it doesn't work.

    However, I was able to successfully flash a few non-stock firmwares no problem! Including the aforementioned Shibby build, as well as a DD-WRT build. Regardless, only the WAN port and LAN port 2 work. All others are dead no matter what. It doesn't matter which firmware I use, or even if I boot into the emergency recovery mode. Only those 2 ports work.

    So I'm out of ideas at this point. I may try to return it to Asus, but it's probably too late, and may not be worth the trouble.
  4. Toastman

    Toastman Super Moderator Staff Member Member

    The whole thing appears to somewhat unstable / unpredictable. If you can, I would try to dump it ASAP.
  5. joe_k

    joe_k Reformed Router Member

    By dump it I assume you mean stop using it? I've already done that.

    I was only using it as a secondary AP anyway. And I never got VLAN tagging to work correctly in concert with my primary router (E3000), which is one of the reason I got it in the first place. I'm wishing I had just shelled out the extra cash for the RT-N66U to use as my main router, and used the E3000 as a secondary AP. But it's all seeming like overkill now anyway. Especially considering how much time I spent trying to get everything working.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice