RT-N12 Wireless Ethernet Bridge locks up

Discussion in 'Tomato Firmware' started by virgil, Jun 20, 2011.

  1. virgil

    virgil Network Guru Member

    I have an RT-N16 configured as an access point (to the ADSL router) and an RT-N12 configured as a wireless ethernet bridge to connect my desktop and WDTV live. This config used to work well on a G network with two WRT54G's, but since I switched to an N network, the RT-N12 wireless bridge would lock up when I have long data transfers (e.g. from the USB drive on the RT-N16 or from another PC to the desktop.

    I have tried shibby -055 and victek 9006. Same thing. I tried the factory Asus firmware in repeater mode - same thing. Strangely enough, when I set the RT-N12 to G-only, it doesn't have the problem. Would this be a faulty RT-N12 or is there some compatibilty issue on the wireless bridge mode?
  2. virgil

    virgil Network Guru Member

    So has anyone gotten the Wireless Ethernet Bridge to work in N-mode.

    It seems to be extremely slow, actually (minimal speed increase compared to G-mode)

    I have tried it in 20MHz Channel Width mode, and was expecting a 2-3x increase.
  3. virgil

    virgil Network Guru Member

    Okay - i managed to get the store to replace my RT-N12. I have changed the configuration so that it is my main access point, while the RT-N16 acts us a wireless ethernet bridge - so that the PCs get the Gigabit ethernet ports. Have tried it for over 3 weeks, and the router still tends to lock up when there is some heavy downloading.

    Have tried BW limiter disabled, and it still happens. The wireless clients lose connectivity from the access point, and the RT-N12 needs to be power cycled.

    I found some references to the issue on the web, but no solution offered.

    http://webcache.googleusercontent.com/search?q=cache:IWPIJg3KOZAJ:vip.asus.com/forum/view.aspx?board_id=11&model=RT-N12&id=20100610161552765&page=1&SLanguage=en-us RT-N12 bridge issue&cd=3&hl=en&ct=clnk&client=gmail&source=www.google.com

    I have tried Victek's and shibby's K26 MIPSR2 versions.
  4. gschlact

    gschlact Network Guru Member

    I am having a similar problem that has recently started. Single E3000 Cisco Linksys connected to cable modem.
    Until recently, everything working great. Not almost daily (overnight), i need to power cycle the router to fix the issue / problem because it no longer does DHCP for the clients and typically doesn't provide internet either until cycled.

    I have reduced all leases and see them renewing hourly trying to identify whether one of them was the culprit - nope. The DNS lease from modem is 3 days. The Time connect is now set to hourly and working. This just leaves a major backup to the NAS on the Router as potential culprit. BUt, this has been my config for months. Not sure what is acting up but am frustrated for the past week.

    Does anyone have any ideas?


    (Tidbit - i have found 20Mhz on the 2.4 channel to provide stronger signal at further distances than 40mhz at same power level. SImilarly, Advanced -> Regulatory Mode = 802.11h mode also provide stronger signal and longer distance). Using 300mw at 2.4G to go through 5 walls, funiture and about 80 feet. Boy do i wish the E3000 had external antenna ports for higher gain for 2.4 & 5Ghz.)
  5. Toastman

    Toastman Super Moderator Staff Member Member

    The E3000 cannot provide 300mW. The setting corresponding to maximum power output is approximately 60. 802.11h mode can give huge problems with router disconnects and reboots.
  6. gschlact

    gschlact Network Guru Member

    Thanks for the response.
    I meant to include the fact that I am using:
    Victek's version: Tomato Firmware RAF1.28.9007 MIPSR2_RAF K26 USB VPN-NOCAT
    I had read that you previously mentioned the Tx Power=60 as the maximum. However, I have carefully used my laptop stationed on my desk with <inSSIDer 2.0 > that showed about 6-7db improvement from 60 to 280-300mW which is what you would expect (3db = doubling power so, 60->120->240 = 6db. Not sure how to explain this though.

    Onto my Problem...
    BUT, my bigger nightly problem is the crashing of the DHCP / DNS server in the E3000. I had made all the timers (DHCP lease, time ntp.org update) hourly (I had Trigger Connect On Demand = On and have now made it Off). The DHCP lease from the modem on wan side is 4 days. In the morning, any device that had fixed IP and DNS info would be fine (Vonage adapters), but nearly all my devices lost connection and the web server in E3000 was no longer responding.

    DNS on E3000 = checked for Use Internal, Uses static and received (no statics currently), prevent DNS rebind
    Static DHCPs exist too, and I have their lease time = sames as dynamic.

    Essentially, all day yesterday, i saw in the logs (on router, not received on PC), the hourly updates. BUT it appeared that each time the DHCP renewed, the miniDLNA got restarted and had to begin scanning again which will take hours to create the db. (I had Scan Media at Startup = On which i have today changed to off. Additionally, I have deleted the db (afraid it was corrupted), and forcing a manual rescan as I type. Coinciding with 'overnight' as I would call it 1am-6am, is that one of my machines does a Synced backup to the same USB drive on the E3000. The PC backup software to do the 'sync' would also scan the media files on the E3000. I am not sure how long it takes the Media Server to do virgin scan, but am thinking that this might have still been running and causing the problem. Last night though, the DHCP leases were set to >>24 hours, and only the Time Update would have been the only other 'event' occurring in the window overnight that it failed.

    ANY ideas would be much appreciated.
  7. virgil

    virgil Network Guru Member

    I have had the RT-N12 v1 running as the access point with a number of static IPs configured and the bandwidth limiter enabled, for over 1 year. My last version was 062v MiniIPv6, and the unit generally ran OK, except that it locks up once in a while after extended periods of use. There are only about 10-12 machines configured to access this AP, and only 4-6 active at any given time. Some older machines are -G only, with a handful of -N ones.

    RT-N16 with Tomato RAF 1.28 MIPSR2 K26 shibby 062 Mega
    RT-N12 v1 with Tomato RAF 1.2 MIPSR2 K26 shibby 062 MiniIPv6

    Alas. the RT-N12 B1 was finally made available locally so I got rid of the good old RT-N12 v1. I loaded shibby RT-N5x 083V miniIPv6 and manually configured it as an access point. Worked fine on the first day, but on the 2nd day, after I enabled the bandwidth limiter - the unit locked up 5 times on that day. I disabled it and it ran fine. I suspect there are still some issues on the RT-N12 B1 but I will need to investigate this further.

    S0 I will start a new thread on this - i realize that RT-N12 B1 is still a work in progress, but looking forward to posting further developments.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    guy, nope. I have no ideas about that. If it used to work well and now it doesn't, with the same firmware, then the course of action is to erase NVRAM. Reconfigure from scratch and see if the problem remains, that will eliminate corrupted NVRAM as the cause. If it is still the same, start looking for something else that has changed.

    You most probably found the cause - the media server and sync'd backup ...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice