RT-N16 crashing every couple of hours

Discussion in 'Tomato Firmware' started by VanillaXtract, Jul 11, 2012.

  1. VanillaXtract

    VanillaXtract Serious Server Member

    I purchased a RT-N16 about 3 weeks ago. I put toastman's VPN build on it and had been running rock solid until about 2 days ago. It hangs up and I can't use the internet, SSH into my router or access the web interface. The light on my flash drive goes out as well. However the switching function still works as I can access every device on my network. I tried upgrading to 7500.2 (was running 7500 I think) but the same problem exists. This started happening maybe a day after I tried overclocking but the router would reboot after a few minutes so I have been running at the stock 480MHz since.

    1. If it's an nvram problem can I backup the config, do a thorough clear, and restore the cfg file or would that bring the problem back?

    2. I am running squid optware and made some configuration changes several days prior to this but I don't see how that could crash the router, any thoughts on this?
  2. koitsu

    koitsu Network Guru Member

    Restoration of the configuration file might result in continuation of the problem, yes.

    It sounds like the router itself is actually rebooting. Have you checked via the GUI (Status -> Overview -> Uptime) or logged in via the CLI and run "uptime" to see?

    Your overclocking may have actually damaged something physically. This is why folks should never overclock; it's risky business. I would recommend you do two things: 1) reload the firmware (meaning "upgrade" to the same version), and 2) do an NVRAM reset ("thorough erase"), then manually re-enter all the parameters you prefer.

    Also, if you're boosting the wireless power, you might try saving that for last. Meaning, do the above but don't boost the wireless power. Let things run for a week that way and see if the router is stable. If it is, then go ahead and boost the wireless power and see if it remains stable.

    As for the switching function still working -- yes, this is because the switch on the RT-N16 is a dedicated IC (Broadcom BCM53115) that is independent from the rest of the underlying hardware. Thankfully TomatoUSB works very well in this regard and does not re-initialise/reset the BCM53115 during kernel startup (otherwise you'd see link loss to all your machines on the LAN, etc.). This is one of the main reasons I stick with the RT-N16 products. For sake of comparison, the WNR3500Lv2 uses the BCM53115 but does mess with the switch IC when loading the kernel, resulting in loss of link (twice!) when the kernel reloads. You can read about this in a post of mine talking about compatibility issues between older SB6120 modems and the newer revision RT-N16 (scroll down a ways).
  3. VanillaXtract

    VanillaXtract Serious Server Member

    I can't check the GUI. I can only access after unplugging the router and plugging it back in, so it is definitely rebooted then.

    I suppose the overclock it may have, but I doubt it as many people run it safely at that speed and it ran for maybe 5 min total at the overclock.

    1. I guess I'll do that when I get home. It's just a pain setting up fstab, firewall rules, static IP's, etc.
  4. koitsu

    koitsu Network Guru Member

    Okay, so then it sounds like the router is actually locking up (barring the BCM53115) rather than just rebooting on its own. That would imply a hardware-level problem (overheating, damage to components, whatever), and overclocking may have contributed to that. Give what I recommended a shot and see if there's any improvement. Otherwise you might have to do an RMA.
  5. VanillaXtract

    VanillaXtract Serious Server Member

    Alright I shut the router off and uploaded the firmware via the rescue utility. I restored 7499.1 instead since I knew that worked fine when I was using it. I suppose that did a full nvram clear since everything was back to the defaults. Hopefully I will be reporting success in the morning.
  6. VanillaXtract

    VanillaXtract Serious Server Member

    Well it's been 4 1/2 days and running rock solid. So I am not sure whether it was a bad flash or a compatibility problem, but all is right in my networking world again.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice