RT-N16 wireless recently started getting flaky

Discussion in 'Tomato Firmware' started by DarkNova, May 14, 2012.

  1. DarkNova

    DarkNova Serious Server Member

    I have had an Asus RT-N16 router for about 6 months now, running with the great Toastman Tomato builds, and its been working great. I've been running version 1.28.7492 for a few months, without any problems. I've had uptimes of over a month with this router, so no complaints.

    But a few days ago, the wireless started getting really flaky. The "Interference Level" started showing "Severe" and computers (I tried several laptops and phones) would start having intermittent connections, they would lose the wireless connection entirely, or the speed would drop, sometimes just to maybe 72 Mbps but sometimes it would drop to practically 0 for a while, and then end up disconnecting.

    Now, some would probably say that I have a new 2.4 GHz interference source in the area, but I am in kind of a rare situation to rule this out. We live out in the country, and my house is several hundred meters from the nearest house. Even with a high-gain wireless antenna I cannot detect any nearby routers. We only have the one router in our house. During the periods where the wireless goes flaky, we are not using any microwaves or any devices that emit 2.4 GHz. I have shut down all wireless devices except for one, and still have the problem (and I've tried changing the one that's on to rule out any single device).

    I have not changed anything with the Tomato firmware in quite some time, except when this problem started I tried adjusting some wireless settings to see if they helped (they did not).

    So the only thing I can think of is with the router itself. I've read some old posts about this router having overheating problems, but later posts seemed to indicate that may have been false and due to old firmware bugs. Does anyone have concrete results about an overheating problem with the RT-N16? I tried blowing a fan on it while the problem was happening, and then it started working properly, but this was just one data point so I will need to reproduce this several times to come to any conclusion. I'm just not sure why it would start overheating all of a sudden, with no other changes, as things have been working fine for months?

    The other thing I was thinking of trying to do a NVRAM wipe and reload. Would this be advised? Really, I would think it wouldn't be useful as nothing was changed on the router that could cause a problem, this would only be for if somehow the NVRAM got randomly corrupted, and I'm a little skeptical of this, but I will try it if someone more knowledgeable than me advises it. Thanks.
  2. mvsgeek

    mvsgeek LI Guru Member

    Is it overclocked? I experienced random reboots and unreliable wireless after I overclocked my "test" RT-N16 to 532. After backing it off to 500 it's been rock-solid.
  3. DarkNova

    DarkNova Serious Server Member

    No, that's a good point but its not overclocked. I have it set to 480,240 which I believe is the factory settings for this model.
  4. Toastman

    Toastman Super Moderator Staff Member Member

    If it's been running for months with no problems, then it's unlikely to be overheating. Something has changed, but not easy to find out what it is. As an initial step, I would recomment you backup your important bits of config using nvram export --set and then erase nvram and reconfigure manually. That often cures some of these strange issues. NVRAM can get corrupted, most often if you have a power outage followed by another one immediately afterwards when the router is trying to write to nvram.

    If it's still the same after an erase, then start looking elsewhere.
  5. DarkNova

    DarkNova Serious Server Member

    OK, thanks, I performed an erase and loaded a subset of the settings (using your guide about determining which ones are important). I will see how it holds up and post either way with the results.
  6. DarkNova

    DarkNova Serious Server Member

    Well, I'm reporting back. After a wipe and reconfigure, the problem still occurred. On a whim, I started changing channels. I was previously using channel 6. Going to a lower channel, I still had the same problem. But I changed it to use channel 11 and I have not had the problem since then! It has been several weeks. This isn't conclusive, but it seems like the lower channels were experiencing an issue. If I lived in a city, I would just write this off as neighborhood interference. But like I said earlier, my nearest neighbor is a long ways away -- it would require a highly directional antenna to pick up his wifi. And when the problem previously occurred, we weren't using any appliances that would generate 2.4 GHz interference (microwave, cordless phones, some baby monitors, etc). The only thing I can think of that we have that does 2.4 and isn't wifi is a couple of bluetooth things like a PS3 remote and controllers, but they weren't being used at the time either. And I had disabled the wifi off all computers, phones, etc except the one I was testing at the time (and I tested with multiple ones, with the same effect). Has anyone else seen anything like this? I probably would need a 2.4 GHz signal analyzer to know for certain.
  7. Toastman

    Toastman Super Moderator Staff Member Member

    It's almost impossible to find out what it is without proper tools, but it would seen that something is probably causing interference on the lower channels. Anyway, this info may help others too.
  8. Planiwa

    Planiwa Network Guru Member

    The wireless world that matters is that which is seen by the router.
    The wl command is a direct way to ascertain what the router "sees".
    What the router sees may not be real.
    With some settings, the router may try to "fix" unreal problems, creating real problems.

    When changing a (minor) setting (such as Channel), there may be major side-effects (such as resetting or restarting something significant).
  9. mvsgeek

    mvsgeek LI Guru Member

    Metageek's Wi-Spy is pretty good and won't break the bank. It identified a signal source on channel 3 which turned out to be the cordless mouse/keyboard of a PC sitting close to the router.
  10. Elfew

    Elfew Network Guru Member

    Toastman - I reported same issue (maybe before 2months) with your builds, but I didnt know it is related to channel. You adviced me reflash and do 30-30-30... nothing help.

    With Shibby firmware I dont have this issue... that was the reason why I flashed shibby on my asus rt-16n.
  11. Josh Vamos

    Josh Vamos Serious Server Member

    I find with shibby the only time I have issues is when channel width is set to 40mhz, it seems like the stock firmware comes with some kind of blended mode, where as the third party firmwares only work either or. In this case it either, works flawlessly or doesn't work at all.
  12. Toastman

    Toastman Super Moderator Staff Member Member

    No difference in the wireless that could cause this. Almost certainly a different issue altogether. Seems pretty obvious that there is wireless interference. USB3.0 devices perhaps?
  13. Josh Vamos

    Josh Vamos Serious Server Member

    USB 3.0 Devices plugged into the router? My DLNA server drive is USB 3.0 and I am having difficulty setting that up today.
  14. Toastman

    Toastman Super Moderator Staff Member Member

    USB3 Hard Disks generate harmonics that are in the wireless band used by the router. They need to be in well screened enclosures. But it's almost impossible to find external drives that have the electronics screened well enough to stop interference. Running a proper NAS, where the drive can be some distance from the router, may be less problematical, but plugging in a HDD right next to the router's antennas is asking for trouble :eek:
  15. koitsu

    koitsu Network Guru Member

    Dark_Shadow likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice