RT-N66U How could Asus fix CFE thing?

Discussion in 'Tomato Firmware' started by jsmiddleton4, Dec 4, 2012.

  1. jsmiddleton4

    jsmiddleton4 Network Guru Member

    For those of us with RT-N66U's earlier models and the CFE could Asus release an update?

    If so what are some of the ways it could work or install?
  2. GhaladReam

    GhaladReam Network Guru Member

    Asus very likely will never release an official CFE update because of the bricking risk involved. The average user/owner of a SOHO wi-fi router is your average Joe with little to no networking skills. This is partly why the stock firmware is so "pretty". The only thing the new CFE has over the old one, is full access to 64K of NVRAM, which the "average Joe" won't understand anyway.

    That being said, maybe someone can come up with a Windows installer/exe of some kind that doesn't require Linux?
  3. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Seems like it would required reading the MAC from the router, writing that MAC to the new CFE firmware, then moving the new firmware into the router and rebooting. Or place to manually enter the router's MAC, then write the new CFE.

    Probably have to start from a full reset so router NVRAM is back to defaults.

    Maybe doable. Certainly way beyond my abilities.
  4. mstombs

    mstombs Network Guru Member

  5. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Thanks ms.... Followed the steps and it worked perfectly. Took me a couple of times in terms of the commands as I had a space where there wasn't one, etc.

    But it works!

    Edit: However I'm not sure that it working is a good thing.

    Now I can play endlessly with firmwares and do nothing productive other then swap out firmwares on my router.

    At least with the bug in the older CFE it forced a certain constraint on my being distracted by bright shiny objects.....
  6. digiblur

    digiblur Networkin' Nut Member

    So what's the big hang up on this nvram thing. I just flashed shibbys 64k and boom 64k. Just seems so much safer and they already got it figured out.

    Sent from a little old Note 2
  7. jsmiddleton4

    jsmiddleton4 Network Guru Member

    You don't need a firmware that is especially coded with the work around to ignore the "I have 64K but only report 32K" bug .
  8. digiblur

    digiblur Networkin' Nut Member

    The firmware is already coded so it's no big deal. No thanks on the bricking. One of the few ways you can brick this router.

    Sent from a little old Note 2
  9. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Your call. Its easy. The steps are quite clear now. Weren't even this morning.

    You can also brick it if the firmware isn't mindful of whatever Shibby, merlin, etc., have done to work around the CFE bug. Its clearly a bug and Asus is releasing the new models with the x.3 CFE boot code.

    If I can do the CFE update believe me anyone can.

    Its all done in the router now and you don't do anything but telnet to the router. Follow the steps and your fixed and good to go from this point forward.

    Again your call but its nice to know I'm not going to worry about a firmware being 32K bug aware....
  10. digiblur

    digiblur Networkin' Nut Member

    I can't afford another one right now so if it ain't broke then I am not fixing it.

    They aren't modifying the CFE so you could have some totally Fubar code and it still wouldn't brick.

    Sent from a little old Note 2
  11. RMerlin

    RMerlin Network Guru Member

    Something as likely as a power outage right in the middle of a CFE upgrade = bricked router. But power outage in the middle of a regular firmware upgrade = break out the Firmware Recovery tool, and you're back in business.

    There will always be a serious element of risk in flashing the CFE. I don't expect Asus to provide such an update because of that element of risk. RMA handling is expensive. And I still recommend against doing it unless you are 100% confident in what you are doing. And you are using an UPS (IMHO) :)
  12. digiblur

    digiblur Networkin' Nut Member

    I just fixed my spare UPS with a new battery so I could take the router down and do this. You guys are tempting me to tinker... Arghhh ;)

    Sent from a little old Note 2
  13. Cyberian75

    Cyberian75 Network Guru Member

    CFE updated with no problem, but when I tried to flash back to Tomato using the Recovery Tool, the router became unresponsive. It boots up ok with all the lights, but I can't even ping it with a static IP. Now even its mini updater doesn't come up.

    Did I brick it?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice