Running TwonkyMedia on Tomato 1.23 ND USB on Linksys WRTSL54GS

Discussion in 'Tomato Firmware' started by Aquafire, Apr 1, 2009.

  1. Aquafire

    Aquafire LI Guru Member

    Hi All,

    A little background :

    I have flashed Linksys WRTSL54GS with Tomato 1.23 ND USB + FTP/Samba Mod by teddy_bear.

    After installation i tried to install Optware packages via the guide provided at Since the internal formatted JFFS2 flash was around 3.7MB, probably it ran out of space and gave me errors and didnt complete the installation.

    So I added a USB flash disk formatted with Ext3 to a USB Hub attached to Linksys WRTSL54GS . Mounted it internally as a disk to

    then since the optware packages are installed to router's internal /opt directory , I mounted the USB flash disk as binded to the router's internal /opt folder. In this way I was able to install uclibc-opt_0.9.28 and Ipkg as the optware packages successfully.


    After installation of optware my natural choice was to make and use the Linksys WRTSL54GS as a standalone DLNA/Upnp server so it can share and stream the media from any attached USB hardisk (this is the reason I got it for in the first place).

    Since I have done a similar experiment with Western Digital 1TB World Edition NAS device, i thought it would work along the same lines. I downloaded the embedded NAS version of TwonkyMedia for Linux ARM little endian uclibc 0.9.28 from .

    Now this version (hopefully) should run on Linksys WRTSL54GS as well, however it has some predefined folder locations from which it runs correctly in the Western Digital NAS device. In WD first I need to define a new folder 'TwonkyVision' in '/usr/local' . Then the zip file from twonky site is unzipped (ipkg-unzip) in
    folder . Then there is a shell script which starts the and runs the twonky server. Once it is started the shared media is shown on the PS3/Mobile Phone or any other DLNA complaint media renderer.

    The problem with Linksys WRTSL54GS is that when i try to define a new folder 'TwonkyVision' in the folder /usr/local it gives me an error message that filesystem is Read-Only. I am logged in via 'root' user however. Any clues how it can be done ?

    Then since the Twonkymedia directory and media database can grow considerably (as your media collection grows) due to its indexing and caching of the images, i thought that having Twonkymedia in router's internal folder is not a workable solution anyways.

    So i created a new folder 'TwonkyVision' in the space provided by attached USB flash (mount bind as /opt). As usual i unzipped all files in this folder and when i tried to run , it gave me an error that folder /usr/local/ does not exists. It is true since I am not running it from /usr/local/TwonkyVision folder.

    I tried to edit the file and replaced the entry '/usr/local/TwonkyVision' with the entry "/tmp/mnt/disc0_1/TwonkyVision". Tried running the again (it calls a file twonkymedia in the same folder) and now it shows another error like "word expected not " ) " ) ". After that I am stuck till now.

    If someone else has done a similar experiment, then the most help i need is that can someone guide me how to run the TwonkyVision Linux ARM little endian uclibc 0.9.28 from any other user defined location instead of the hardcoded "/usr/local/TwonkyVision" folder. How to edit the file and do anyother adjustments if necessary. It maybe equally true that linksys with tomato and optware is even not capable of running Twonkymedia.

    I have tried other DLNA server in the NSLUG2 optware package library at, but none is as flexible and easily configurable as twonky.

    I am using puTTy for the terminal SSH access to Linksys WRTSL54GS and WinSCP for folder browsing/file management.

    Thanks for reading and for help.

  2. mstombs

    mstombs Network Guru Member

    Wouldn't help with hard coded directories, but I'd have thought the MIPS LE version would be better than ARM!
  3. Aquafire

    Aquafire LI Guru Member

    Why do you think that the MIPS LE version would be better. Is it not that the Linksys WRTSL54GS is based on ARM processor.

    Please correct me , since i dont really know much about the Little Endian and Big Endian differences and versions.

  4. mstombs

    mstombs Network Guru Member

    The Broadcom SOC in Tomato compatible routers use a MIPS core running in LE mode. Look at the firmware source and Toolchain - lots of references to mipsel.

    The NSLU2 uses a Intel IXP processor with an ARM core.

    Re your other problem with editing sh files, make sure you use an editor such as notepad++ and save files with Unix line endings - winscp may have to be told to use binary transfer for everything, it sometimes converts files to windows line ends for you.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice