RV016 and VPN, does it work?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by jstumbo, May 29, 2004.

  1. jstumbo

    jstumbo Network Guru Member

    I just got a RV016 for my office this week and still I have not been able to get the VPN working for my remote users. They are using windows XP. I spent 3 hours on the phone today to the techs at Linksys and still could not get it running.

    I have configured it how they said to configure it, even had one of them take control remotely and configure it for me. Then I followed the instructions on their website for configuring windows xp. Still they cannot connect, it just eventually times out like there is not VPN server.

    Looking at various forums, it looks like there is a problem?

    I am about to ship this thing back if I cannot get it working pretty quick. I am moving to china myself in a week, and I need to have VPN connectivity to my network.
  2. hanoirocks

    hanoirocks Network Guru Member

    Have you tried this tutorial

    I've never used the XP VPN, too much hassle. Have you tried this tutorial. It's for the RV082 but it should work the same with the RV016.


    I tried the SSH Sentinel client on my RV082 but there is a known issue with connecting if your client side has a dynamic IP. Supposed to fixed with the next FW release.

    Good luck
  3. hanoirocks

    hanoirocks Network Guru Member

  4. jstumbo

    jstumbo Network Guru Member

    Still not working

    I checked out both of those sites. Acutally had before, but thanks. All I get on the client machine when I ping the internal ip address of the router is "Negotiating IP Security." it does this 4 times, and then the ping is over. The example on the website shows that for the first one, but than the other 3 pings receive a reply.

    Looking at the log files on the router it shows that the connection was accepted on port 500 (pptp) and then the next line in the log says "failed nat control" with a description of "SIOCADNAT - no child process", which leads me to believe that the router is running FreeBSD for an OS and that it has a problem.

    Any suggestions?
  5. hanoirocks

    hanoirocks Network Guru Member

    You're right on the FreeBSD OS.

    I looked up SIOCADNAT and found a lot posts to do with NAT and Free and Open BSD.

    From what I read people were having to edit ipf.rules and ipnat.rules. Correct me if I'm wrong but doesn't the OS exist within the firmware?Have you tried reflashing the firmware 1.2.3 version?

    You can also view your config file if the RV016 is the same as the RV082.
    Once your logged into the GUI, type in your address bar.

    My hidden page has the following options:

    sys_setting1.htm -- Enable Telnet Service

    var_log.htm -- System Log

    sysconf.txt -- rg_conf text file
    (Click setting backup first sys_setting.htm)
    sysinfo123.htm -- Manufacture Information for Testing Program.

    Don't know if any of that will help.
    Good luck.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice