RV016 Beta Software saves the day (and the night)

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by burtbalmer, Sep 21, 2007.

  1. burtbalmer

    burtbalmer LI Guru Member

    We have a freshly acquired RV016 with 5 ADSL connections at the office. It had major issues. Lost connections. Crashed. We upgraded to 2.0.17, same thing. The router mysteriously died in the wee hours of each morning, and each office day started without Internet access until the bleary-eyed admistrator came in and recycled the power. We had to mount a big RED switch outside of the server room, flicking it recycled the router. It was that bad.

    We lost our remaining hair, and were ready to move to Clarkconnect (cheap, but the box with two quad NIC cards would have cost 10 times the cost of the RV016.0

    I stumbled across the RV016 v2.0.20 Beta Firmware, posted on this forum. I thought: It's Beta. But what the heck, it can't get worse than this.

    Installed it. And all our troubles went away.

    The router is rock steady now. There are occasional re-boots, but it re-boots gracefully, re-establishes all connections, for all intents and purposes unnoticeable (unless someone is in a big download ...)

    We cancelled the order for the router box.

    Thank you, Linksysinfo!!!!!!
  2. Toxic

    Toxic Administrator Staff Member

    Thanks for the complment, though we are only part of the chain, the guys who have worked hard on the RV0xx series have done some good work in the last year. all credit should go to them.

    you still stay connection drops, I take it this is with the the ADSL modems? are they ALL the same make? is MTU set at 1492 or lower?
  3. burtbalmer

    burtbalmer LI Guru Member

    Yes, with the ADSL modems. They are ALL the same. We are, lo & behold, in Beijing China, and we are using the modems that have been issued to us: SureKAM 268L1. We've tried to find others, but all we can BUY here are ADSL Modems with routers, and all have a Chinese UI. We have Chinese at the office, but router setup pages seem to to them like Chinese is to us :) The only plain vanilla modems are those issued by the telco.

    MTU is set to 1462, seems to be most comfy with that number.

    Also, FYI, the minute we change from "Gateway" to "Router" mode, all traffic ceases. No go.

    China is the reason for being for this beast, as there is only 2 Mbit ADSL. And those 2 Mbit are achieved only when the stars align perfectly.

    Observing two phenomena:

    1.) Occasional re-boot. All lines come back nicely. Can live with that.

    2.) All lines go out together. Come back one by one. Some earlier, some quite later. And the late ones are persitent. Don't react to Disconnect/Connect. Suspected outages at the switch, however, when I initiate a direct PPOE connection with the laptop, the link is established. That one is a bit puzzling. Even hard resets don't help it ....

    But after a while, alll is good again.

    All in all: MUCH, MUCH better than before.
  4. Toxic

    Toxic Administrator Staff Member

    Your RV082 has to be in Gateway mode if the ADSL modems are connected to the RV082 directly. if the RV082 was behind another router, then you use it in "router" mode.
  5. burtbalmer

    burtbalmer LI Guru Member

    I understand. Other boxes are slightly more forgiving ....

    And it was a test anyway.

    One connection was to go through a Motorola MTA/VT1005, which is a "Router" of some sort , more a SIP device (used by Vonage) with NAT. We disabled all "routing" in that beast and left it between the port and the ADSL modem, works fine.

    (Indication: Even when all ADSL lines go down occasionally, I still have dial tone on the phones, so the Motorola maintains the line connectivity ...)

    The other test was a bit more ambitious. We tried to connect a CISCO ASA 5505 (successor of the PIX) between one ADSL modem and a RV016 port. That didn't work too well. But that was BEFORE the firmware upgrade. We'll give it another try.

    However, the ASA is a fully fledged router (and then some) .... So with the ASA, some ports would be behind a router, some would go naked into an ADSL modem. Can I have a Router (possibly) / Gateway (maybe) setting :) ?

    Feature request: Enable/Disable the firewall selectively per WAN port. That would make the (currently unemployed) ASA happier ....

    PS: Correction to the 'All Modem' answer. One line is a PPOE line that connects to the Ethernet broadband service of the building. It's REAL PP over Ethernet. THAT one is the most stubborn. It's also the most useless. My hunch is all tenants in a 40 floor building share one 2 Mbit ADSL line ..... When the connections drop, they drop on that one also .... And it's always last to come back.

    So now:

    WAN1 -> ADSL Modem
    WAN2 -> ADSL Modem
    WAN3 -> ADSL Modem
    WAN4 -> Motorola MTA/VT1005 -> ADSL Modem
    WAN5 -> Building Broadband PPOE

    WAN4 & WAN5 were configured that way after the firmware update and after everything started working.
  6. burtbalmer

    burtbalmer LI Guru Member

    More little buggies

    Now that most is under control, the minor details:

    When there is a "Router" (i.e. the Motorola box) between the RV016 and the ADSL modem, the dynamic DNS client registers the IP of the internal interface of the device that sits between it and the ADSL modem, in this case ...

    Rightly you say, the "router" should have its own smarts to register the outside WAN IP, but in this case, it hasn't. No big problem for me.
  7. burtbalmer

    burtbalmer LI Guru Member

    After a few weeks of usage: There still are hangs (whole system down, needs hard reset) albeit much less frequent than before. Enough to be troubling though.

    Willing to play guinea pig ...
  8. burtbalmer

    burtbalmer LI Guru Member

    I think I rejoiced too early. While the new image definitely reduced the frequency of crashes (it crashed twice a day) the crashes still happen. And they happen enough to be very annoying. I have (hopefully temporarily) replaced the RV016 with a Linux box running Clarkconnect. It has been running rock-steady for days.
  9. jlbcrp

    jlbcrp LI Guru Member

    When dealing with linksys offering to play guinea pig is not always a wise idea....They can get you over your head real quick...:eek:

    That all being said I was reading though what you have posted in this thread and I sort of have gut feeling that your problems are not firmware issues... I think your problems are more related to a hardware issue somewhere within the device.....Most likely a short circuit somewhere causing something to be un-stable and crashing your system....
  10. burtbalmer

    burtbalmer LI Guru Member

    If you read the boards, these crashes and hangs are well documented. Also, as I said, the frequency of the crashes diminished radically with the new firmware image. Went from one or two crashes a day to maybe one a week. Doesn't look like hardware to me. Too bad, I really liked the unit.
  11. death_hawk

    death_hawk LI Guru Member

    I'm having a similiar problem to the original poster. I think I'll have to try out the beta firmware.
    At this point, I'm also saying: "Can't be any worse"
  12. death_hawk

    death_hawk LI Guru Member

    Well, it's no worse, but it's also no better.
  13. burtbalmer

    burtbalmer LI Guru Member

    All I can say, that with great sadness, I had to pull the plug(s) on the RV016 and replace it with a (much more expensive when you look at the bottom line) Linux box with Clarkconnect. That box just keeps on humming. I can go on a trip, leave an office full of females behind, and they still have connectivity when I come back. The only peeve I have about Clarkconnect is that when an ADSL modem goes down, it stays down until manually reset - but I haven't seen a single solution that recovers from that kind of a problem,
  14. DocLarge

    DocLarge Super Moderator Staff Member Member

    Sorry to hear that, Burt. I will say the WRVS4400N is now showing great stability in the field. Still, clark connect is a great blackbox solution. Should you look at an actual hardware router in the future, try your luck with the WRVS4400N...

  15. v2owp

    v2owp LI Guru Member


    Does the WRVS4400N support multiple WAN connections? A quick check of the Linksys site doesn't seem to mention multi WAN. I'm guessing multi WAN was the reason be bought the RV016 (that's why I did).

  16. Toxic

    Toxic Administrator Staff Member

    nope sorry the WRVS4400N is has a single WAN port.
  17. burtbalmer

    burtbalmer LI Guru Member

    I've had and have a box full of single, and some dual WAN port routers. Thank you.

    I bought the RV016 for the specific use of up to 7 WAN ports. It failed me.

    For single WAN port (with fall-back to a second) I have a Cisco ASA 5505. A 5510 with full content security is on order. There is no shortage of single port routers. I could open a store.

    I would LOVE to have a reliable dedicated Multi WAN box. The RV016 looked great on the spec sheet. But it's a disaster in the reliability department, so with great sorrow we had to put it out of its misery. It's not that we didn't try.

    The Clarkconnect box works great. The 4 NIC card in it alone did cost more than the price of the RV016 ....
  18. v2owp

    v2owp LI Guru Member

    Sorry to hear that you've been having so much trouble. My RV016 has been running pretty stable so far but as of right now I don't have any DSL connections (cable and wireless). Is this just a problem with DSL connections in general or a certain type of DSL? My company is thinking of adding a DSL connection as an additional backup connection and I'd like to know if there's anything in particular I should be watching out for when looking at DSL providers.



    Firmware 2.0.17
  19. happyhacking

    happyhacking LI Guru Member

    this hw looks like to be unstable forever

    at this moment the rv016 killed my nerves for a while now, i was thinking i was the only one with this kind of problems like the orig. poster, but in fact
    it looks like this kind of hangs will prevail even with fw updates, its pretty sad.
    i was forced now to buy a xincom x16-r to replace the 2 rv016 that i already own, this will be my latest try on this kind of hw, then i will try linux box... hehehe, i will post my impressions on xincoms solution. btw nice post clarifieing
    the common but un docummented troubles, i know that for a retail price of about 500 bucks we cant expect a high end mission critical solution, but hidding this kind of info for ppl with great expectations of the hw its sad, i already have this routers since 2005 and i am
    still waiting for a proper fw update that
    can fix the dayli perhaps weekly hangs on connections. hope xincom has a better aproach
  20. burtbalmer

    burtbalmer LI Guru Member

    Based on the reports, it doesn't appear as if the troubles of the RV016 are isolated to DSL, or - as you may hope - a certain kind of DSL.

    Just google RV016 lockup, and you will see countless reports with all stripes of connections, cable and DSL.

    Of course I also suspected my ADSL modems first, switched them all - no change.

    I then isolated the ADSL modems from the RV016 with single WAN boxes that did the PPOE, presenting the RV016 with plain vanilla DHCP Ethernet connections. The RV016 still locked up. And the DSL connections in the individual boxes were alive.

    As Ralph Nader would have put it: "RV016 - hazardous at any speed."
  21. v2owp

    v2owp LI Guru Member


    I did as you suggested and googled "RV016 Lockup". There were several posts and reviews from people that were having similar/same problems as you described. However, there were also several people (like me) that were having minor or no problems with the RV016. Two thoughts about this:

    1. At one site I found a post in which someone actually explained one scenarios that might be a cause of some of the problems. I know you've already ditched the RV016 but maybe someone else will find this useful.

    (Read the first response below the article.)

    2. I know when you go to the Linksys site to download drivers and etc. it only lists one hardware version for this router. However, I suspect that there might be some units that are better or worse. Maybe much like cars your's was produced on a "bad" day (maybe your box was made on a Monday or Friday!)? Or, perhaps Linksys has these manufactured at 2 or more different facilities?

    I'm sorry you had such a bad experience with the RV016 (I've been there with other products and software) so far mine has been good. Any others with an opinion?

  22. burtbalmer

    burtbalmer LI Guru Member

    Thanks for the assist, but I never trust automatic MTU. I always test it and set it to the best value. In my case, that value was 1472. When I have time, I'll give it another try with 1400. But honestly, with a track record as bad, and with that MTU "revelation" 2 years old, don't you think Linksys would have had ample time to put something as trivial into a later firmware rev?

    As for SSH: Most of my failures and hangs were in the middle of the night, with no traffic at all, let alone any SSH traffic.

    And as far as your car analogy goes: Yeah, it looks like I was sold a lemon. And it also looks like there are bunches of lemons out there.
  23. PapaDoom

    PapaDoom Guest

    Has the RV016 2.0.20 Beta software been removed from the downloads section here? I can't seem to find any active links to get it.

    I'm experiencing problems with autonegotiation: particularly, all of the machines on my network that have 1 Gbps/100 Mbps/10 Mbps NICs seem to generate a ton of packet errors. I've mitigated the problem somewhat by buying a gigabit ethernet hub, attaching any of my devices that support Gbit speeds onto that hub, then attaching it to the RV016... but frankly that is an ugly solution.

    I was hoping updated firmware might help... but 2.0.20 has been in "beta" for two years now, and I still can't get it from the official download site. Help?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice