RV016 v2.0.12 Beta Firmware Report

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Jul 30, 2006.


How does the RV016 v2.0.12 firmware perform?

  1. It has fixed all my issues

    0 vote(s)
  2. It fixed some issues (Please list issues below)

    4 vote(s)
  3. Still have same problems. (Please list issues below)

    4 vote(s)
Thread Status:
Not open for further replies.
  1. Toxic

    Toxic Administrator Staff Member

    Linksys has released this firmware as a beta. I would like some imput into its functionality and any issues that you find with it.

    This thread is not a flame attack on linksys. it is purely to raise issues with the firmware so we can submit our findings to the developing team.

    There is also no point in asking for new features, since this firmware is beta it will be released as an official release in due time.
  2. adisor19

    adisor19 Network Guru Member

    Hmm, i see no mention of stability improovements in regards to load balancing multiple WAN connections... That's my main concern as it's the main reason i forked 400$ for this router.

  3. Toxic

    Toxic Administrator Staff Member

    It would have been nice of someone to show issues about the RV016 on these forums. I cannot see any post from you about this issue before now :frown:
  4. adisor19

    adisor19 Network Guru Member

    It's true, i haven't posted about this here, but i had read in other places discussing the problems of RV016 about how unstable it is inregards to load balancing more then 2 WAN connections at the same time. I also read that Linksys can only guarantee 2 WAN conenctions being load balanced and not more, even though the router has offcial support for 7 of them.. Anyone know what is the official Linksys position on this ?


    P.S. i'll be on gone vacation for a month starting the 1st so i won't be able to visit here too often during this time..
  5. Toxic

    Toxic Administrator Staff Member

    I'll check up on this for you, though dont hold ya breathe :jester:
  6. millerduck

    millerduck LI Guru Member

    QuickVPN problems 443 vs. 60443

    I have been able to make QuickVPN client work as long as I do not forward port 443. If I do (needed for HTTPS access to OWA), then I get a 403 not authorized in the wget_error.txt. I was hoping that this new firmware would resolve this issue since it is supposed to listen on 60443 too.

    In looking at wget_error.txt it looks as though it never attempts to use 60443 when 443 fails. Is there any way to force the QuickVPN client to use this "new listening port"?

    I am running version of the QuickVPN client and any help would be great.

    I was looking forward to this version as a fix to this issue, that is why I am posting this here.

    Chris Miller
  7. TazUk

    TazUk Network Guru Member

    The most recent version of the QuickVPN client is 1.0.40, so give that a bash and see if it helps :)
  8. sterner

    sterner LI Guru Member

    QuickVPN does give you the option to use either port 443 or 60443, so it should work for you now.
  9. millerduck

    millerduck LI Guru Member

    Thank you for the quick responses.

    FOUND IT - THANKS - editCM

  10. sterner

    sterner LI Guru Member

    In the downloads section on this site
  11. akk142

    akk142 Network Guru Member

    Traffic Monitoring

    All I want for christmas is a log of traffic on a per-ip, per-user, per-mac basis. Anything of that nature would do, even an estimate within a kilobyte or megabyte.

    I already tried leaving suggestions for the engineers.

    I manage an RV016 for 60 college students and if I knew who's bandwidth was out of control, particularly upload bandwidth, life would be easier. One more way to deal with business majors' computer-illiteracy.

    Any ideas. SMNP doesn't work. As far as I understand, there is only a sensor for the entire lan side. Help anyone?

  12. Toxic

    Toxic Administrator Staff Member

    so SMNP is broken? this is the first report i have heard that is does not work.

    can anyone one else confirm SMNP does not work?

    as for your christmas list, this Forum thread is for bugs only. If however SMNP is definately not working, then i shall report it, but i need confirmation from others that is it not working, and what software has been used to try and read SNMP logs.

    I take it syslog is no good for your requirements?

  13. mlai

    mlai Network Guru Member

    Flashed the 2.0.12 onto my RV016 (previously 2.0.10). Everything seems fine. The "File Exists" bug in the log does seem to have been fixed. However, access an locally hosted services via external ips still seems to be slow.

    And when UPnP is mapping an external port to a different internal port (for example external port 81 to internal port 80), computers on the LAN still cannot access the service via external ip and port.

    CustomDNS update has been fine.

    One problem about the flashing process though. This version of the FW seems particularly problematic to flash and reset. I had to flash, reset, downgrade back to 2.0.10, and reflash, reset multiple times to get the router to behave correctly. Symptoms include:
    1) changing internet connections from default DHCP to PPPOE will cause router to reboot.
    2) unable to logon to the ISP (not sure if this is due to RV016, though)
    3) A very large amount of error packets and dropped packets received via WAN (from the statistics page).
    4) random reboots.
  14. Toxic

    Toxic Administrator Staff Member

    I just flashed a rv016 remotely and had no bother.
  15. markn455

    markn455 LI Guru Member

    Problems maintaining connection via PPPoE. When it does, takes a long time to reconnect again.

    I discovered what seems to me is a bug. When you go to Service Management and create a new service, and then you go to forwarding and forward that port to a trusted IP on the lan and enable it, the router starts forwarding the ports without a firewall rule being created. This seems like a huge problem to me. The only way to stop the forwarding is remove it, or create a firewall rule that denys the access. Absense of a rule defalts to ALLOW rather than DENY. My experience with other firewalls is that they always default to DENY until a rule is created specifically allowing the access is defined.

    Ball Ground, GA
  16. markn455

    markn455 LI Guru Member

    I figured out what the problem was with this. It was actually a problem with the DSL itself. When a phone call would come in, the DSL would drop while the phone was ringing. Also, if you picked up the phone and placed a call, the DSL would drop until the part on the other end anwered the phone. Corrected the problem with the DSL and the router maintains the connection just fine.

    Ball Ground, GA
  17. Toxic

    Toxic Administrator Staff Member

    thats is an ADSL filter problem. do you have filters on ALL phone connections in the house?
  18. akk142

    akk142 Network Guru Member


    Let me rephase that.

    SNMP works, but when I used snmp last (it's been a while), I could only moniter the LAN as a whole. I could moniter IPSEC, each specified WAN port, and possibly a few others, but I am positive I could not moniter anything specific within the LAN.

    Maybe I'm wrong and only reached the tip of the iceburg?

    Can you attach to particular IP addresses, MAC address, or port that is part of the LAN? If so, how, and what is a recommended piece of software?

    Maybe another forum thread.


  19. markn455

    markn455 LI Guru Member

    Actually, it was a problem with the phone line running out to an electric gate. Put a filter on that, and that solved the problem.

  20. username_taken

    username_taken Network Guru Member

    If it's anything like the RV082 syslog doesn't actually capture the number of bytes transferred. I've called Linksys helpdesk over this numerous times and they just tell me I must be using the wrong syslog tools. Well I'm not, it simply doesn't log it. I would guess their helpdesk are just reading from a script, but I had no luck trying to get put through to an actual engineer to get a definate yes/no about it working.

    I'd be very interested to know if the RV016 syslog does in fact report the bytes downloaded.


    08-24-2006	11:49:20	Daemon.Info	Aug 23 17:49:03 2006 vpn RGFW-OUT: ACCEPT (TCP> on ixp1) [0,0]
  21. videomasterz

    videomasterz LI Guru Member

    Wow! Is all I can say right now... I did a backup just to be sure updated to firmware 2.0.12... i used to download at only 380KB on a 5.2 megabit downstream connection my LAN ip was binded to.... now i am downloading as if my computer was hooked up straight to the cable modem at around a steady 600KB!

    I know the RV016 was having problems with the MTU, my connection would drop every 5-10 minuts then pick up right away as a result I would loose my download speed it just wouldnt stay steady, I had to change the MTU to 1500 not to auto, and that kinda fixed the problem but wasnt as steady as I would like it to be.

    updating to this firmware vesion also fixed that file exists i always see in the log.... everytime i see it thats when my connection would drop before... anway i just enabled the MTU to auto.. and my speeds are even better..

    one thing i do notice is when i connect my dsl modem..by the way there is a couple cable modems and 1 dsl modem.. i notice when i try to connect to the dsl PPPoE connection... my connection would drop and i would loose my download speed.. and it can nver catch back up to that 600KB... i guess thats the routers way of connecting to a WAN? it has to pause for a sec????
  22. videomasterz

    videomasterz LI Guru Member

    I guess I spoke too soon! After about 7 minutes it does it again it drops me, and I get crappy speeds from then on :( It was pretty steady at first but then it was up to its old ways again!

    attached is a pic of the disconntions???or drops...

    Attached Files:

  23. adisor19

    adisor19 Network Guru Member

    So, i'm back from vacation and i've finally installed my RV016 and here's my story so far :

    I mainly purchased the router for it's loadbalancing feature since i have 3 connections that i wanna use fully when bittorrenting. I'm mainly comparing it to DD-WRT that i was using on my WRT54GS.

    Using latest beta firmware as posted on this site.

    1) No automatic static IPs based on the mac adress. The router just gives IPs as they come so if one computer gets turned off and back on, and another one grabs it's IP adress, i gotta redo the port forward settings again. It does support static IPs, but you gotta do i manually by entering the MAC and the desired associated IPs. This is a real pain in the ass. If only Linksys would take note from DD-WRT !

    2) When doing intensive Bit-Torrenting, the active ip connections table gets full rather fast as my MSN keeps disconnecting and reconnecting every 2-3 minutes. This is again, VERY sad for a 400$ router with 64MB of ram. In DD-WRT i could adjust the keep alive connection period as well as increase the size of the active ip connections table. With the RV016, there's no way to even know what's going on.

    3) Stability wise, i can't complain yet. Besides the diconnection problem when bittorrenting, it's ok. It hasn't froze yet.

    4) Load balancing is rather meh.. it doesn't seem to fully use all 3 WAN connections to their fullest even after disabling SPI. I don't know whether this is a CPU problem or what but i wish the firmware coders would investigate this a bit and improove the performance of the load balancing algorithm.

    That's about it for now. I'll update once i find other things.

  24. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    I'm 90% sure it was firmware that fixed this issue....
    I just finished a site to site VPN upgrade between some office with 2 sites a couple of states apart.

    Nightmarish project...the end I worked on had an old NT4 server running an old domain. A few years ago the other office put in a 2K3 server..running its own domain. Trust was built between them through the tunnel.

    The project I'm in the middle of involved replacing the old NT4 server...with a 2K3 server. I planned on joining the directory of the other 2K3 server..running DCPROMO, making my server hold a copy of the catalog, and running DNS locally. All "appeared" well until I killed DHCP from the old server, engaged the new servers DHCP...rolling out this servers IP as DNS for all workstations on my end. First test workstation...no internet. DNS on the server wasn't functioning..did allow forward lookup zones for the directory. Tried to force replication...no go..ugly errors. dcdiag..uglier errors. Ran dcpromo to demote...bounced, dcpromo to join..appeared good..but still same end results. Looked at errors with fine tooth comb. Found a few articles about RPC since SP1 of 2K3...with IPSec VPN tunnels...some hardware doesn't work well. Did some more reading...network data corruption can be a cause. The slow link of a VPN already causes enough problems with this...how hardware handles the data adds a bunch of possibilities.

    Remembering some past threads about the newer firmware in relation to SACKs on RV0 routers...I know SACKs can cause issues on higher latency connections. I was working on an island that had radio transmitted internet from mainland...so I tried this firmware on both RV016s (both ends). After the bounce of the routers...I bounced the servers...about 15 minutes later forced replication...BAM. Good. Compared ADUC...new users I added showed up in the other...
  25. videomasterz

    videomasterz LI Guru Member

    I'm seriously thinking about reverting back to 2.0.6 now... for some reason as my previous stated... my drops are more severe than 2.0.6, When I drop I loose connection to the server I am getting files from and it times out? never did that before in 2.0.6?? now my downloads take forever to get done :( MTU problem??? still?? possibly??

    If it helps I have 5 WAN enabled... not using WAN1.. only WAN 2-5 ...... using IP group... not auto balancer
  26. videomasterz

    videomasterz LI Guru Member

    Ok just an update of what I did so far. I did a reset on the router to factory defaults, the major dropping and not being able to connect to the server has disappeared, keep in mind im using firmware 2.0.12. I then enter all my port forwarding for my servers, but what I know notice is my download speeds are steady but really really slow? I tried putting MTU manual at 1500 but still very slow like only 2megabits when I have a 5 megabits connection???? and this is even when everyone is sleeping! need some insight on this.
  27. adisor19

    adisor19 Network Guru Member

    I had done a reset when i installed the .12 version and i have 3 load balanced connections of : 10mbps, 3Mbps and 1.5mbps. I noticed that my torrent downloads rarely went over 2Mbps.. So i guess you're not the only one. Let my know if your downloads imprrove.

  28. videomasterz

    videomasterz LI Guru Member

    Well im about to try out 2.0.3 firmware 2.0.6 was the most stable and fastest for me, I have 3 cable connetions equals about 8 megs and 1 1meg connection on dsl, this router is really making me angry I drop when playing PC games on the net!
  29. videomasterz

    videomasterz LI Guru Member

    Ok adisor19,

    I am using the firmware version 2.0.3, I couldnt upload my config file from vesion 2.0.12, I had to do a hard reset and re configure my router for the servers. Anyway! I am downloading at steady 600KB then it is average about 475KB steady for about 20 minutes now! The other version 2.0.10 and 2.0.12 would drop me every 5 - 6 minutes. Now I can download at max speeds, I even notice my internet browsing is very fast, and my speedtests are even faster.

    I had to set MTU to manual at 1500, I disabld Block WAN requests in the Firewall, and just adjusted the bandwidth management settings for my connection, and boom! no more drops fast speeds.

    I just hope the new version they come up with will fix these bugs. I'm sticking with 2.0.3 from now on.
  30. adisor19

    adisor19 Network Guru Member

    Hmmm, so between 2.0.3 and 2.0.6, did you notice any speed difference ?
  31. videomasterz

    videomasterz LI Guru Member

    Yes I did, right now downoading steady 400KB+, before I would download around 300KB+ rarely ever reaching in the 400's with the version 2.0.6. This firmware 2.0.3 impresses me. On local speed tests I am able to score higher than ever before. You would once in a while if you have a bandwidth monitor see the bandwidth drop down to almost zero but pick up again.

    With version 2.0.10 or 2.0.12 the bandwidth would drop and wouldnt be able to recover again, I would time out on the server I am downloading from. This version 2.0.3 the bandwidth would drop, but I am able to recover so fast that it looks like nothing happened.

    Don't know whats wrong with these firmwares? I am even thinking of downgrading all the way to first generation firmwares just to try it out.

    To give you an idea on how good this firmware is 2.0.3, at 2.0.6 my local speed test I was getting was around 7megabits - 9 megabits. NOW with 2.0.3 I am able to score 28-30 megabits no problem and did this test during the sametimes too.
  32. videomasterz

    videomasterz LI Guru Member

    so any ideas or updates on this???? Right now im wishing xincom would hurry up and make their quad wan router thats been in development forever. Had a xincom the 502 one, loved it, but bought this router for the extra WANs.
  33. adisor19

    adisor19 Network Guru Member

    OK OK , i've been a lazy bum lately. Time to shove 2.0.3 and see if my load balancing performance imprroved. Will post an update in the next hour to let you know if i see a difference.


    P.S. are there any other routers out there supporting multiple WANs besides this POS ?
  34. Toxic

    Toxic Administrator Staff Member

    the Draytek Vigor 3300v has 4 WAN ports afaik. http://www.draytek.co.uk/products/vigor3300v.html
  35. videomasterz

    videomasterz LI Guru Member

    Thanks for the info Toxic, but I am hoping that the router you mentioned doesnt have just 4 LAN ports (LAN-Side 10/100BaseT (4 ports) ) as stated in the article, I'm assuming you can switch out those VoIP cards and put the regular RJ45 ports there to have more LANs? Looks like a very good performing router.
  36. adisor19

    adisor19 Network Guru Member

    Found out that PepLink have awesome load balancing routers (with INCOMING AND OUTGOING load balancing not just outgoing like Linksys...) Unfortunetly they're soo expesive, you need to sell a kidney or 2...

    Anyways, meanwhile i'm stuck with this thing.. so, does anyone have a link for the 2.0.3 somewhere ? I can't find it on the Linksys website...


  37. adisor19

    adisor19 Network Guru Member

    Err, forget my last message.. I've found 2.0.3 and i'm currently testing my BT speed to see if it improoves..

  38. adisor19

    adisor19 Network Guru Member

    All right, so testing v 2.0.3 has the exact same results : slow load balancing. My BT speeds are still lower then 2.0 Mbps even though i'm balancing 2 connections of 10Mbps and 5Mbps respectively.

    Any news of an updated 2.0.12+ version Toxic ?

  39. videomasterz

    videomasterz LI Guru Member

    hey adisor19,

    My speeds have improved from the sucky and retarded 2.0.10 when im using hte 2.0.3, but I am not using the load balancing feature, I am using hte IP Group (By Users). I binded myself just to one WAN and I can pull the full 5megabits, maybe just for now try doing that for your router. just so you can get the full 10megabits instead of 2megabits.
  40. adisor19

    adisor19 Network Guru Member

    Ah ok that explains why i saw no difference then.. unfortunetly that kinda defeats the purpose of load balancing as i shelled 400$ on this thing so that i would get a faster speed by combining all my connections together.. *sigh*

    i'm currently considering other solutions if Linksys doesn't fix their load balancing performace. I'm gonna see if Intergate from www.vicomsoft.com is any good as it too seems to have load balancing built in and since it's a software solution, it's cheaper.

    Toxic, if you're reading this, can you atleast confirm wheter Linksys is working on improoving the performance of their load balancing ?


  41. Toxic

    Toxic Administrator Staff Member

    Hi. Sorry but I cannot confirm any improvements on load balancing.
  42. videomasterz

    videomasterz LI Guru Member

    Mr. Toxic,

    Can you confrim if the mtu problem is going to be fixed? i.e. my session being dropped constantly, and not being stable?

    for adisor19, you should get a xincom 502 twin wan, if your just using two cable modems that is the best load balancing router I have worked with to date. We bought the RV016 awhile back for $500 just to get the 7Wans since we are using 4 WANs right now. Just waiting for xincom to release their quad wan.
  43. markn455

    markn455 LI Guru Member

    Is Xincom still doing anything? They seem to have stop producing any firmware updates and any other noticable activity since they got bought out.

    Ball Ground, GA
  44. Toxic

    Toxic Administrator Staff Member

    I cannot confirm this since i wish to know, how you find the MTU is to blame for your sessions being dropped.

    what type of connections do you have. Cable and ADSL?
  45. adisor19

    adisor19 Network Guru Member

    Hi Mak,

    Do you currently own a Xincom router or have any experience with it and load balancing ? I'm currently considering getting one and selling my RV016..

  46. markn455

    markn455 LI Guru Member

    Yes, I have a XC-DPG603 sitting in the rack powered down. I came off that unit and went to the RV016. The Xincom worked well except for one thing. When I streamed video across the LAN for an extended period of time data would stop flowing occasionally. I had to restart the Xincom and data would start flowing again. Seemed to happen only when moving high volumes of traffic on the LAN. Nonthing was going out to the WAN. It was very strange and I didn't like having to go restart the router in the middle of a movie. Switched to the RV016 and the problem never happens.

    Load balancing worked well (maybe better than most). However, if you are downloading a single file, it does not make the download any faster nor does it spread the traffic for the one download across multiple WANs. If you have a ftp tool that sill setup multiple download streams, then it screams.
  47. adisor19

    adisor19 Network Guru Member

    I'm thinking more in terms of Bittorrent transfers.. does it choke on them like the RV016 does ? Ever since i got the RV016 and i use bittorrent, the connection table in the router fills up and it starts dropping other connections like MSN. Pple keep complaining that i keep signing on all the time :S I'm not even talking about the poor performance of BT...

  48. videomasterz

    videomasterz LI Guru Member

    I have one ADSL connection and about three Cable connections on 4 WANS. I notice that if I kept it on auto MTU, I have constant drops majority of the time. If I make it manual MTU of 1500. My connection is way more stable and doesnt drop as much. Remember I am only binded vi IP to ONE wan.

    adisor19 I am pretty sure the win wan xincom will boost your bT like crazy lol!
  49. adisor19

    adisor19 Network Guru Member

    hehe that's what i'm hoping for but i'm also lookig for stability and a BIG capacity connection table that won't kill connections if the table gets full like in the RV016..

    If anyone can confirm, i'm definetly getting one cause it seems to be the most resonably prices dual WAN router.. If only they had a 4 WAN version....

  50. videomasterz

    videomasterz LI Guru Member

    I heard that DLINK is gonna have a 4 WAN load balancing router pretty soon :D they have a dual wan out already only $121! cheaper than the xincom.
  51. Toxic

    Toxic Administrator Staff Member

    thread closed since new beta firmware is out and users will not keep on topic.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice