RV042 and Packet8

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by russwmc, Oct 21, 2005.

  1. russwmc

    russwmc Network Guru Member

    Does anyone have Packet8 running through an RV042? My Packet8 DTA310 will connect to find out I have a message but will not make or receive a call. It all works fine through my SnapGear router so I know it is unique to the RV042. I have changed the MTU based on ping return and also tried Auto. I only have one WAN connection.
  2. russwmc

    russwmc Network Guru Member

    Additional information on RV042 and SIP/Packet8...

    I am now back to using my SnapGear router. I decided to give the RV042 one more try with Packet8. I can connect the RV042 WAN to the LAN side of the SnapGear and then connect a PC and DTA310, Packet8 device to the lan of the RV042.

    Low and behold the DTA310 device connects and I can call out. Thinking that something is now working fine with the RV042 I proceed to replace the SnapGear router, again.

    WAN <--> SnapGear <--> (WAN) RV042 (LAN) <--> DTA310 and PC ---- WORKS

    When directly connected to the WAN the RV042 will NOT allow the DTA310 establish a call. I have no idea why it won't connect through the RV042 in it's useful configuration of actually being a firewall. I have tried turning off all firewall options, putting the DTA on the DMZ, Passing every port I can imagine to it, nothing works.

    WAN <--> RV042 <--> DTA310 ---- DOES NOT WORK

    Any ideas? I see from another post there is also a problem with the RV016 as well. I guess Linksys has made sure that they will only support Vonage.

    Needless to say, calls to Linksys support are useless. Since Packet8 device works the problem is definitely with the RV042. The DTA310 does not require any ports forwarded, it sets up an outbound SIP connection and handles incoming traffic through this established outbound connection.

    I just don't understand why when I put the SnapGear between the RV042 and the LAN with the DTA310 behind the RV042 Packet8 calls work fine. Makes no sense. Do any of the Linksys RV or WRV routers work with Packet8? So far it's the RV042 and RV016 down.
  3. DocLarge

    DocLarge Super Moderator Staff Member Member

    I'm preparing to make "the jump" to VOIP myself, but it appears to be Linksys is up to their same old shit again. Out of a matter of interest, the problem your having is similar to the "NAT-T" issue that the WRV54G suffers from, it just won't do it. So, to get around that, you had to place a device in front of it that could do NAT-T in order to get the vpn functionality you were after (using third party vpn clients from behind the router instead of bypassing it and making a direct connection to the modem and then out to the internet).

    It sounds like putting the snapgear in front resolves your problem, which means Linksys may have left out another piece of the puzzle (again) to make sure they can enforce "proprietary control" over VOIP with Linksys products...

  4. russwmc

    russwmc Network Guru Member

    If I still had Packet8 I would test to see if the new RV042 version fixes the problem or not. Anyone out there with Packet8 willing to let me know?

  5. ccbadd

    ccbadd Network Guru Member

    I had problems with my Packet8 BPA410 and WRV200. What firmware are you running on your 310? I played arround a little with the Nat Traversal settings in the BPA410 and found that the last setting, "Packet8 with ICE" has resulted in my line working perfectly. I am using the unlocked 14.17 fw from this link:


    I don't know if the Nat-T settings are exposed or not with the standard fw, but the unlocked fw only unlocks some additional setting, it does not allow you to use with other providers.
  6. ed001

    ed001 Network Guru Member

    You may be able to bind a few ports on the RVXXX to a specific interface. I will actually be installing two DTA310's behind an RV082 very soon (or at least I hope so). Until then I think putting it on the DMZ could also help.
    I'll check back with the results.
  7. ed001

    ed001 Network Guru Member

    Forgot to mention and I'm sure you know, make sure it's up to date and you set a nice beefy password on the DTA310
  8. russwmc

    russwmc Network Guru Member

    Putting it on the DMZ didn't do anything for me. I have a DTA310 with the latest firmware. I never found the ICE setting that ccbadd referred too on the 310.
  9. ed001

    ed001 Network Guru Member

    I did not get a chance to install them behind the 82 yet but I got both of them working just fine behind a WRV54g.

    This is a long shot but is the 310 set to DHCP or are there static entries? I could be wrong but if for example your Snapgear is set to and the linksys is and the default gateway and/or DNS servers on the 310 are still set to, putting the snapgear in line may open the route to the outside world. If the 310 can't find either a gateway or resolve a domain name it won't work.

    If you have a hub laying around plug it in-line and do some sniffing. I always find this helpful. If you need some instruciton on this post back. I doubt you do though if you built your own Snapgear box. Backtrack on a thumb drive is always a nice thing to have laying around.
  10. russwmc

    russwmc Network Guru Member

    When you try it behind the RV082 I am interested in knowing the results. It was set to use DHCP. I did try various static settings as well. Even changed MTU on RV042 and verified that same MTU would work on SnapGear.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice