RV042 Console Mod

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by noaaah, Mar 3, 2005.

  1. noaaah

    noaaah Network Guru Member

    I've successfully modified my RV042 so that I can use the serial port to get into the console of the device.

    I'll be posting a page on how to do this soon, keep in mind that it will invalidate your warrenty and its not risk-free.

    I may also make customized firmware or modify the existing firmware for the RV042. One reason is because the RV042 (the one I have) randomly reboots every several hours to days. It may be heat-related or it may be related to something else. Being able to see the console when this occurs is very valuable. Also once you console in, you have more control over things such as VPN endpoints.

    I'd like to know how many people are interested (in non-official firmware) before I get very involved into this. If not alot of people are interested, then I'll probably use the existing firmware and just login via console.
  2. zachaller

    zachaller Network Guru Member

    I would be very happy with a 3rd party firmware i would reallly like the dual wan ports to work with same gateway and some diffrent load balancing options i am learning C++ but dont quit know enough to do somthing with a firmeware yet but like i said it would be cool to have a 3rd party firmware i think the router could have some pretty neat stuff and post about the serail consol. I really hope you do somthing with it and come on people with these router speak up so we can get some support.
  3. noaaah

    noaaah Network Guru Member

    I just wrote up the document.

    One big petpeeve that I have with the RV042 is that it wont resolve itself.

    What I mean by this is.. I'm using dyndns, and my DNS is rocnoah.mine.nu. I use this because I establish VPN connections between my server here and my real server elsewhere.

    But when I do "ping rocnoah.mine.nu", it says that its unable to resolve it.
    Why? Because I'm using the RV042's DNS servers.

    But if I use the normal DNS servers for my provider, it works.

    The only reason why I'm using the RV042's DNS servers is because I was testing out the load balancing feature.. And dont even get me started about that. It leaves alot to be desired..


    I'll probably post to this thread or another thread as I find more information.
  4. zachaller

    zachaller Network Guru Member

    very interesting i might have to try that out some time for fun and I know what you mean about the load balancing well first for me it dosent work at all because same isp and same gateway and linksys wont give me the 1.3.6 due to toubles they found it it wich really angers me because i am pay for 2 connections and cant use them that is my biggest thing with this router and i am not shure how hard it is to fix or y it exactly dosnt work if know i would love to here it.
  5. noaaah

    noaaah Network Guru Member

    Tell me about it.

    I've tried it, and I lost half of my AIM buddy list because of it.. Thats because the RV042 sent a certain amount of data through my cable modem, then sent a certain amount of data through my DSL line.. Thats all good except for the fact that the data going to the same host gets sent from two different connections.. So when I re-arranged my AIM buddy list, some of the changes was sent out of the connection that wasnt being used for AIM, thus the AIM server quietly discarded the changes. When I logged on AIM later on, I was really pissed.

    I do agree that for the load balancing feature to be 100% effective, you need an ISP that will give you two connections, and then tie them together on their end so it seems that you have one external IP address. However, good luck getting your cable company and phone comany to do that.

    So what I want to do is to add in a feature so that if a person connects to a certain address, any data for that connection will follow the same route.

    For example, AIM uses TCP. So when my AIM client connects to the AOL server, the router will see that connection and as long as the client/server uses that connection, the router will always route the packets through the same WAN interface, NEVER through the other WAN interface. However if another person (roommate) connects to AIM and happens to connect through the other WAN interface, then the router should always use the second WAN interface until the connection is ended.

    How would this be done? Well, one could make a table in the router. When the router sees a TCP connection occuring, it will assign it an ID and put it in the table. If theres a break in the connection, then it will remove it from the table. While the connection is up, anytime a packet is sent, the router will check the table and then forward the packet out of the corresponding WAN address.

    I know theres a feature in the router thats suppose to force it to always use a certain WAN port for a certain feature.. I've tried it, and it doesnt work.

    I'm using 1.3.1. I've not tried 1.3.3 yet, and I wouldnt mind trying 1.3.6 if I could get my hands on it. I would LOVE to see what the kernel messages say on the console for 1.3.6.

  6. zachaller

    zachaller Network Guru Member

    ya good luck on the 1.3.6 i spent 5 hours on the phone with shitty tech till i got to a lvl 2 then i got some crapy answer like we were haveing troubles so we are not giving it out any more so know i got 2 dsl connections with one doing nothing

    also another thought dont know if it is possble but could you creat like a virtual port for the WAN with it own ip then you would have to get 3 ips from your isp but could you get the router to some how route the 2 physical ports to the logical ip and change the ips in the packet to the logical, it probably imposible but if you could somehow do it on the router itself would be really cool. I think the troubles here would be to establish the logical one on the internet so the packets know how to come back or i just have no idea what i am talking about even though i am almost cisco certified (CCNA) shows what they teach you.
  7. noaaah

    noaaah Network Guru Member

    Hopefully somebody on here has 1.3.6 and could email it to me - and I'll be more than happy to copy/paste the output from the kernel for 1.3.6 onto here.. So that way we will know for sure why 1.3.6 doesnt work.

    Why would you want to create a virtual port for the WAN, so you have 2 IP's for each WAN and then 1 virtual IP? Basically you want to "merge" the two physical WAN ports into 1?

    If thats what you're saying, you cannot do that without support from your DSLl company. They would have to do the same thing on their end, so that way you will have 2 lines with the same IP address. Plus, each ISP is assigned a block of IP addresses, so you would have to get a 3rd ip address for the virtual WAN that is NOT being used.. And if its being used, your ISP may get pissed off because two computers using the same IP address = disruption of service.

    I use cable and dsl because once a while the cable goes down from bad storms, or other reasons. So DSL is my "backup", but I would like to use it alot more often than I do :-/

    Please let me know if I guessed what you were trying to say or not.
  8. overslacked

    overslacked Network Guru Member

    I'd love to have another firmware option - it's a shame Linksys isn't able to share more of the codebase with the RV series. Although a lot can/has been said against PPTP, I'd like to see a PPTP VPN server on this little guy.

    Thanks for the write-up on the magic console - what I really needed was another cable draped across my desk!
  9. noaaah

    noaaah Network Guru Member

    I have a cable going from my laptop (Linux machine, running NX client to my server here) to the router.

    I've thought of potentionally opening up a telnet server BUT.. There are no telnet daemons in the firmware. There must be one in the bootup firmware BUT.. Havent had any luck mounting it so far. The mount command seems to always want to mount the default mount (root file system) and nothing else. It seems like they modified busybox to do that.

    If you have a computer next to the router, can connect it to that computer and then ssh to the computer next to the router and fire up minicom. I may do that since I have an old fart server (which also happens to be my phone/answering machine server) next to the router.

    Theres also an ethernet-to-serial port device that you can use as well.

    If I find a way to telnet into the router, I'll definately post it on here, because I'm sure that alot of people would love to be able to do that instead of having more wires.

    As for PPTP.. I think I saw mention of PPTP somewhere..
    Just checked, yup, the router supports PPTP.

    Not sure if its pptp over VPN, since I use linksys's normal VPN - between the RV042 (here) and my BEFVP41 (parents home). I can do more research into it, but maybe you can do it instead and post on here. Or somebody else can do it. Lets just see whoever finds out the information first. ;)

    Running pptp gives me this output:
    Note: the "-"s are not part of the output, they're there to seperate the output from the rest of the text.
    pptp-linux version openrg
    ./pptp hostname [[--phone <phone number>] [--quirks ISP_NAME] -- ][ pppd options]

    Or using pppd option pty:
    pty "./pptp hostname --nolaunchpppd [--phone <phone number>] [--quirks ISP_NAME]"
    Currently recognized ISP_NAMEs for quirks are BEZEQ_ISRAEL

    Let me know what you think.
  10. overslacked

    overslacked Network Guru Member


    Wow, that's frustrating. I haven't made a cable yet, but I have very little doubt it's (pptpd) sitting right there, quiet and lonely, waiting to be used. I guess its too early to make that judgement, but it does feel right.

    I run Slackware (as you may have guessed) on random ancient computers, and I'd love to help do what I can. I don't really understand what it takes to create a new firmware package, I've mostly been here trolling for RV042 info, but I'm pretty capable.

    I looked at the GPL'd code for the RV042, there is a mount.c.diff but it's empty (every other file had a .diff too). I wonder, is there an fstab? Would you mind posting it?

    Time to find a way into this guy....
  11. zachaller

    zachaller Network Guru Member

    I wouldnt mind helpin out to with what little little i can the telneting into the router would be real nice(not to shure i want to start attaching wires to my $180 router yet but will see if things start getting real cool) and i love the info noaaah keep it up and am going to start messing around a little with this thing too.
  12. noaaah

    noaaah Network Guru Member


    You may want to look at the RV042 information topic that I started, I posted even more information on there.

    As for the firmware, I'll respond about that there shortly.

    heres a fstab file, but its in the root "/" and it seems to be generated after bootup, when it makes the ramdisk in /dev/ram0..
    Especially because theres NO fstab folder in /mnt/cramfs.

    The fstab folder in / has only one entry:
    none /proc proc defaults 0 0

    Not that helpful, eh?

    And the mtab file has the same information as mount.
    Check out the posts in the information topic.
  13. akk142

    akk142 Network Guru Member

    noah, when i try to goto anything but the root directory of your website, I receive Forbidden. I have no clue why that happens. Are my security settings too high in my browser?

  14. zachaller

    zachaller Network Guru Member

    I dont know this for shure because i am not the most active but i was when noaaah started talking about moding the RV042 any way i dont think he has been around for a while so he might have taken them down.
  15. chuckwagon

    chuckwagon Guest

    RVo42 Keeps rebooting itself - Randomly!

    Hey All,

    So I have a RV042 and Linksys just wanting to keep replacing it but obviously after 2 replacments, this hasnt done the trick.

    The router will randomly reboot itself, sometimes after 2 hours and sometimes after 22 hours - depends on its mood I guess - So what to do? I have the latest firmware on it, and I have re-flashed it and still nothing -

    This is more annoying than anything, cause when this thing reboots, office looses internet connection, I cant ping the router till it comes back up and then its fine - but for how long who knows...

    Any suggestions would be great! IM at my end here......

    Thanks in advance for any insight!

  16. skorell

    skorell Network Guru Member

    Have you tried putting the router on a UPS or power conditioner? Maybe you have a dirty line. I have this same router and it is very stable with It does seem to have a problem with my download speed (caps out at around 4Mb), but that is another story.
  17. Sfor

    Sfor Network Guru Member

    The link to the console modification description is no longer valid.

    I do have 2 faulty RV042 units with booting problems. I hope I will be able to get some informations about the issue using console log data. However I do not know what serial port settings are necesary to receive RG Bootloader console output.

    The funny thing is, both units are booting fine after sending "boot -s 2" from the RG Boot telnet session.
  18. Toxic

    Toxic Administrator Staff Member

    unfortunately noaaah was last seen here on these forums in 2006 :(
  19. Sfor

    Sfor Network Guru Member

    It looks like the RV042 uses the same COM port settings as the WRV54G: 115200,8,N,1 - flow control - none
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice