RV042: HOWTO recover from bad flash

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by megablank, Jan 11, 2005.

  1. megablank

    megablank Network Guru Member


    I just managed to break my RV042. Linksys told me to apply the actual beta firmware 1.3.6 to solve the problem with dyndns.org. After the next reboot, the diag led started blinking and nothing else happened.

    As I have some more Linksys devices (NSLU2, WRT54, WAP54), I was not too much surprised about this behaviour... :wink:

    So I tried, just for fun, to open a telnet session to - and got a connection to the bootloader!

    After some extensive testing, I finally worked out how to flash the firmware. But be careful: this seems at least to work with firmware 1.3.1.

    Here is the step-to-step guide to recover the firmware. Do these steps running linux, because it provides all neccessary tools.

    First, you have to get the firmware file from Linksys (the *.rmt file). But this file can't be flashed directly, because it contains a header with 109 extra bytes.

    You have to remove these 109 bytes from the beginning of the file. Running linux, I used dd for this purpose:

    dd if=RV042_1.3.1_040924.rmt of=image131.img bs=1c skip=109c

    Then we need a tftp server. Normally, the files go to /tftpboot, so copy the previously generated image131.img to this location and make sure that your tftp server is running.

    Change the IP address of your Linux PC to (or whatever, except of

    Now, power off the RV042, press the reset button at the back and plug in power again. Hold the button, until the orange diag LED is flashing.

    Now the router has the IP address

    telnet to the router. You should get a shell from the bootloader.

    Enter exactly the following:

    load -u tftp:// -s 2

    After some time, there should be a message saying that the download was successfull.

    Type in "reboot", and if everything went well, your router should be alive again.

    Yours, Markus
  2. radius13a

    radius13a Network Guru Member


    I am on my 2nd RV042, the first one died after trying to flash it. I wish I would have seen your instructions. The Linksys support people are clueless. If they would have sent me information like this I could have saved having to return my first unit. Oh well. I guess it will come in handy if the next firmware upgrade screws up again. Thanks for the post.
  3. Vexamus

    Vexamus Network Guru Member

    Yeah, just fyi, thanks very much for the information, pretty much saved my company yesterday. Thanks for all your hard work.

    FCCYMIS Network Guru Member

    The firmware given by linksys tech support in the phillipins was a corupt version. they claim they are now using a new version. i used tftp to restore it. 1.3.6 is 5mb ( on 7 RV042)
  5. Vexamus

    Vexamus Network Guru Member

    gee, mind hooking me up?
  6. Chiefer

    Chiefer Network Guru Member

    Is there a way that I could do it in a WINDOWS machine? :cry:
  7. tuannd

    tuannd Network Guru Member

    I just bought RV042, the original firmware was 1.2.3
    tried to config PPPoE, but PPPoE didn't work, and when tried to open VPN Tab and click on subtab Gateway to Gateway), I receive error page, and unable to browser the web anymore (the RV042 was able to ping, but unable to connect using browser)

    Then I tried go to LINKSYS site and this forum to find the firmware 1.3.1 and 1.3.3, and decide to upgrade firmware to 1.3.3

    But after ugrade the RV042 repeately reboot at booting proccess, and I unable to use it anymore. I can't telnet to RV042...

    Pleaser help me to rescue this RV042

    Thank you
    TuanND from VIETNAM
  8. tuannd

    tuannd Network Guru Member

    I don't have Linux, could you please send me the image131.img
    My E-Mail : aulacco@hn.vnn.vn

    My RV042 was failed after ugrade from original firmware 1.2.3 to 1.3.3

    Please help
    Thank you
    TuanND from VIETNAM
  9. tuannd

    tuannd Network Guru Member

    I was able to update 1.3.1 with image131.img ( with cut 109 bytes)
    But the problem still the same, RV042 repeately reboot at booting proccess

    Tried use full RV042_1.3.1_040924.rmt, RV042_1.3.3_041209 and RV042_1.3.6.rmt to update, Successfull update display in Telnet session
    after reboot POWER LED and LAN LED were on, but connect to RV042 was failed.

    Still able to start RV042 in diagnosed mode.
    Please advice how to rescue

    Thank you
  10. tuannd

    tuannd Network Guru Member

    I supposed my RV042 failed after update firmware was that I didn't reset the RV042 to default seting before update.

    Please advice how to rescue this device

    Thank you
  11. noaaah

    noaaah Network Guru Member


    Umm.. Firmware 1.2.3 is pretty old, and I'm not sure if theres a few editions of RV042.. I mean - some other routers have revision A, B and C - and sometimes one revision doesnt use the same firmware as another revision.

    But in the case of RV042, I'm not sure if the one you have is a specific revision or the same as all the other RV042's. In either case, you shouldnt have a problem upgrading the firmware - it should've not killed your router.

    Did you try putting the computer to or so and use the router's default address of after flashing?

    I would recommend you to call linksys. You may also want to return the router and get a replacement.. It sounds like (so far) to me that your RV042 is not working right. It may be a hardware defect or something else.
  12. tuannd

    tuannd Network Guru Member

    Had tried to contact with Linksys support, but they just tell to return RMA
    I tried one again :
    In save mode, telnet to RV042, then do command erase flash section 3 -> and now to my suprise the RV042 return to work with firmware 1.3.1 (which I had update using method introduced at the beginning of this topic)
    I am very happy because I am in Vietnam, the shipment cost for RMA is too much !!!

    I hope this information would be usefull for another people
  13. TheSurf

    TheSurf Network Guru Member

    Problem aber recovery

    Hi @all,

    mybe you can help. The Linksys Support is only a pice of crap.
    They don't flash your router back, they say it is broken and over.

    Back to my case:

    I have flashed a 1.3.3 and swithed the rv042 off für about 2 weeks.
    When I switched it on I only got a Diag-Led flasching.
    Then I start examine and found the bootloader. With the help of this thread I managed to get an other firmware running. I can boot it with "boot -s 2". But when I switch the router off, it always goes back to bootloader and I habe to put in "boot -s 2".

    Can someone send me his config-output from:

    bset and vom "rg_config_print /bootloader"??

    Hope to hear from you, you are my last hope!
  14. cyboc

    cyboc Network Guru Member

    Markus, thanks for your input. Using your TFTP-based procedure as a guide, I managed to discover an even easier HTTP-based procedure. My method is easier because it works directly with ".rmt" files; in other words, you do NOT have to go to the trouble of using the dd command to strip the rmt header to get a ".img" file.

    Here is a step-by-step guide to recover the firmware via HTTP on a RV082 (I assume that it works on a RV042 and a RV016 but I haven't tried it). I tested this with the "RV082_1.1.1_040317.rmt" firmware image (i.e. RV082 firmware version 1.1.1).


    1 ) Power off the RV082 by unplugging it.
    2 ) Press and hold the reset button.
    3 ) Power on the RV082 by plugging it in.
    4 ) When the "Diag" light on the front of the RV082 starts flashing, release the reset button.
    5 ) Open a browser and goto You will get a screen with a "browse files" button and a "load firmware" button.
    6 ) Browse to and select the ".rmt" file that contains the firmware you want to flash the device with. For example "RV082_1.1.1_040317.rmt".
    7 ) Press the "load firmware" button. You will see a progress indicator and a message to the effect of "Firmware is loading". After several seconds (45 seconds?) you'll see message to the effect of "Load successful. Now rebooting".
    8 ) After the RV082 has rebooted, it should be working again with the firmware you uploaded.

    Note that some settings may be lost. For example, when I reloaded the "RV082_1.1.1_040317.rmt", image I had to go to "" to reenable the telnet server.
  15. pintosack

    pintosack Guest

    I too had this problem. I followed cyboc's fix and it worked ...
    I had called Linksys tech-support before this, and they told me to send it back and that there was nothing they could do... ya right...
    ***just a note.... with cyboc's directions, i had to put in a static ip on my computer , and then connect.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice