RV042 mortality rate

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by tdacosta, Feb 7, 2007.

  1. tdacosta

    tdacosta Network Guru Member

    I just wanted to share my experience with a pool of RV042 routers that we installed to provide VPN services to satellite offices. We purchased five RV042 routers and one RV082 over a period of several months, nearly two years ago. To date, we have had four of the RV042 boxes die. The symptoms on all four were very similar--the DIAG LED comes on and the router stops communicating over one or more of the WAN/LAN interfaces. Sometimes a reset would bring the routers back to life for a few hours.

    A couple of weeks ago we ripped apart the four failed units to see if we could identify any failed components on the board. After probing around with an oscilloscope, it became apparent that the 12V to 3.3V switching converter on the RV042 mainboard was not operating correctly. We measured almost 500mV of ripple on the 3.3V output--way too much for proper operation of some components. It appears that the low ESR capacitors on the converter output had degraded over time. After replacing the capacitors with new ones, the converter output was cleaned up enough that the ripple on the 3.3V output was less than 30mV.

    We have put the repaired routers back into operation and over the course of the last week, we have not seen the routers stop working even once.

    I just ordered a new RV042, which should be here today. I am going to take it apart to see if Linksys has changed the power supply design, or components. It certainly looks like there is a serious flaw with the units that were sold two years ago--I hope they have fixed this issue in newer units.
  2. OpticalMan

    OpticalMan LI Guru Member

    Thanks for sharing! I have the RV082, have you had a problem with that PS? I'm wondering if the power supply is the same for all the RV units and therefore may have the same failure after some time.
  3. neutralman

    neutralman Network Guru Member

    @tdacosta - very good post! we are lucky to have you on this forum
  4. tdacosta

    tdacosta Network Guru Member

    Opticalman, the RV082 has been operating with no issues so far. The power supply design on the RV082 is completely different from the RV042.
  5. d__l

    d__l Network Guru Member

    I hate to impose on your helpfullness, but is there any chance you could post photos of the power supply/motherboard of the router you plan to examine? I think many here would be appreciative of that sort of info. Thanks. :)
  6. tdacosta

    tdacosta Network Guru Member

  7. Toxic

    Toxic Administrator Staff Member

    Thanks for the info. though this shows a serious flaw in the ones you bought I have never heard of this flaw before now.
  8. Kompressor

    Kompressor Network Guru Member

  9. aviegas

    aviegas Network Guru Member

    Interesting, I have seem something like this with one of my RV042s!

    It's an old model (2 or more years in service). What I can say is that this particular router was running in a hostile environment (hot). On a hot day, it would certainly hang. Sometimes stop completely. I have seem unrequested factory resets and firmware corrupts (all recoverable). For a while, leaving the wiring closet door open would keep it running. After a while it was so bad that it was replaced.

    It is still around, so maybe it can be fixed.

    tdacosta, was there any apparent damage to the capacitors? Did you replace all 3 of them? Can you share more details on the "bad" board version?

    Thanks in advance!
  10. askingnv

    askingnv LI Guru Member

    External identification of "Bad" RV042

    Have you found a way to identify the "Bad" RV042 without opening the case?

  11. tdacosta

    tdacosta Network Guru Member

    aviegas, since I've placed the repaired units back into operation, I don't have them handy to look at the PCB revisions. Three of the failed units have serial numbers starting with DHY004600, DHY004B00, and DHY004700.

    One thing that was common on all of the failed units was a very audible "hissing" noise coming from the area of the large inductor next to C7 and C11 while the unit was powered. Using an oscilloscope is the only sure way to observe the ripple on the output of the switching converter.

    If you want to try repairing your failed RV042, I would suggest the following components for replacing the capacitors:

    C7, C11: 1500uF/10V Low ESR Electrolytic, Digikey P/N 493-1499-ND
    C13: 820uF/25V Low ESR Electrolytic, Digikey P/N 493-1556-ND (this is one of the input capacitors to the converter, but I replaced it anyway)

    To further reduce the output ripple, parallel a surface mount ceramic capacitor on the back of the board where the leads for C7,C11 come through. A 10uF/16V, Digikey 399-3525-1-ND would do well for this purpose.

    See http://www.digikey.com for the above P/Ns.

    An unfortunate characteristic of electrolytic capacitors is that they have a limited lifetime. They tend to degrade very quickly when used in high ambient temperatures. An electrolytic capacitor uses a liquid electrolyte that dries out over time. There are different grades of electrolytics which are rated for operation at different maximum temperatures for a guaranteed period of time. Many of the cheaper capacitors are rated for 1000 hours of operation at a maximum specified temperature at which point their capacitance rating can change a substantial amount. The equivalent series resistance of the capacitor also degrades a fair amount--this one can be a big problem for switching converters. The net result is that what worked on day one when it was first plugged in, has gotten to the point where things work intermittently.

    The problem is well known to hardware design engineers, but unfortunately, designing solely with solid capacitors instead of electrolytics is very expensive. Equivalent solid capacitors are also much larger physically than electrolytics. Usually, a balanced approach is taken in power supply design where smaller ceramic and low ESR tantalum capacitors are used to augment the characteristics of oversized electrolytics. The circuit degrades over time, but due to overdesigning the parts, the circuit is still within the ripple requirements.

    Hope this helps.
  12. aviegas

    aviegas Network Guru Member

    It's been two days since I've "revived" my heat damaged RV042 (DHY004600000 series). It was not simple to get it back alive, but so far no problems.

    As everything with Linksys routers, one's mileage may vary when trying something out of the ordinary. And as expected, I had some problems in the process.

    First I tried the suggested 1500uF/10V for C7/C11 and did not replace C13. When I powered the router, it was able to light up, but did not work (not responding). Then I tried a hard reset without success.

    The behavior reminded me when I inadvertently used a 5V power supply. The switch works and the lights seem to indicate that everything is fine, but the router would not boot. So my guess is that something was wrong with the power circuitry.

    Next I decided to go with the original specs for the capacitors. This mean that C7 and C11 are 1000uF/16V while C13 is 220uF/25V. After replacing the capacitors the router would still not booting. But it was a different scenario than before: it looked like the router was bricked, as after a bad firmware update.

    Then I attempted a "stop on boot" procedure to get a console prompt (powering on with the reset button pressed and releasing it as soon as the diag light starts flashing). Bingo! I was able to telnet to the router and get a prompt. My guess is that the router firmware got corrupted somehow (bad power? Last time it was used? I have no idea).

    Time to perform a bad firmware recovery. I'm lucky to have all the necessary tools at hand (the written procedure, an old firmware that can be loaded by TFTP - 1.3.1 - and a TFTP server). After a few minutes the router booted firmware 1.3.1. Next, I upgraded to and loaded the saved settings.

    I'm stress testing the revived router subjecting it to a high ambient temperature, something that in the past would quickly cause it to hang. So far no problems. I will post after the stress test is over.
  13. Beta2K

    Beta2K LI Guru Member

    I also have a RV042 that's failed due to apparent issues in the switcher... to add insult to injury there's what looks like a regulator up on the edge of the board that had one pin that was never soldered in place, to be honest I don't know how it ever worked (pull the pin up, no boot, push it down, boots ok.) The inductor in mine gets _very_ hot, I'm suspecting it's operating environment along with a warm running inductor that close to the caps caused them to start to fail and it all went down hill from there, caps deteriorate, stress on the switcher goes up, inductor gets hotter, caps get worse.... Anyways, I thought I had it fixed with the regulator lead and now it's gone down again so I'll have to wait till Monday to get to work and replace those caps.
  14. Beta2K

    Beta2K LI Guru Member

    On a side note, I pulled the solder from the COM1 spot and installed a header on it, I also installed a header on the jumper block. Have to try experimenting and see what those jumpers do and is the COM port is live.
  15. tdacosta

    tdacosta Network Guru Member


    The value and type for C13 are not especially important in the converter design. It is mostly a bulk storage capacitor and smoothing filter to further reduce the 120Hz noise coming from the rectified wall transformer. The input capacitors that are important to the converter operation are present in the form of several ceramic capacitors on the top and bottom of the board.

    C7 and C11 are the output filter capacitors for the converter. On those two, the higher capacity will produce lower output ripple. If you use alternate capacitors for C7 and C11, ensure that they are a low ESR type, and not just a general purpose electrolytic.

    If you have access to an oscilloscope, throw a probe on the output capacitors and check the ripple. If you're under 50mVpp, you should be fine.
  16. aviegas

    aviegas Network Guru Member

    Interesting enough the 1500uF/10V capacitors I have used were low ESR...
    The fact that these larger capacitance onces did not work still puzzle me.

    I do understand the role these capacitors play in the power circuitry. That's why I went for the larger ones at first. Maybe I got a bad capacitor in the batch.

    Since it's been a while since I had access to a oscilloscope, I can't really/properly check it out, so the stress test I'm (successfully) conducting is my only alternative at the moment.

    Maybe later I will see if I can try new capacitors and give it yet another try. So far it's working.
  17. ccb056

    ccb056 Network Guru Member

    I have a DHY005xxxxxx RV042, had it for about 2 years, there is a slight hissisng sound comming from it.

    Should I be worried?
  18. Beta2K

    Beta2K LI Guru Member

    Is it getting hot as well?
  19. aviegas

    aviegas Network Guru Member

    I would look for the following:

    a) The hissing sound - coming from the coil near the capacitors, as posted by tdacosta

    b) The router freezes or does not respond to ping/management web server (but still routes).

    c) Running too hot - I've noticed that after fixing the router it was running "colder" (I do not know why).

    d) A router that runs in a hot/poorly ventilated environment.

    My failing router was running hot, hissing and placed in a very hot environment. By lowering the environment temperature I was able to run it indefinitely. But if the surrounding temperature was to hot, the router would simply freeze (and each time in less time, like something was degrading).

    But "if it ain't broken, don't fix it".

    BTW: 4 days in a hot environment and still running fine!
  20. aviegas

    aviegas Network Guru Member

    7 days without a problem, in a realy hot environment.
    For me the test is over and I will reassign the router.

    This means that heat and/or time may cause these routers to fail, but the fix is simple.
  21. giffordj

    giffordj LI Guru Member

    You guys should offer this to a service for the rest of us. I would pay to have you fix my RV016 that is starting to show the same symptons.
  22. Thingfish

    Thingfish LI Guru Member

    Mine started hissing recently after having it about 2 years. A fan has been on it since it was new as it always ran warmer than I liked. I replaced the caps with Sanyo WG 1500u 16v and a 220u 25v but it still hisses from the inductor, which gets quite hot.
    It still works but I do not use it as I am sure it's days are numbered.

    Any ideas why the coil still hisses?
  23. bad_the_ba

    bad_the_ba Network Guru Member

    Thanks a lot for these posts... this has helped me out a lot more than linksys tech support ever could. I purchased 3 of these units for one company with as many locations, then as they started to show problems that could not be resolved by firmware upgrades or rebooting or even relocating the router, I purchased another and took a dead one to play around with. By this time, linksys assured me it was out of warranty and that there was nowhere I could send it. I then purchased another for a small doctor's office that wished to add another location in the future. This proved to be incompatible with their PPoE connection, so I ended up with one dead RV042 and one "good" one. Over the time that I have owned them, I have seen similar issues as you have described. I now still have the three that I manage for the first business, and I typically will reset, change firmware, or swap out with the one booting one I have, just to make things temporarily work. I am suspecting that all of them are part of this bad lot of PCB assemblies.
  24. rmcouat

    rmcouat Addicted to LI Member

    I have 15 of the RV042 installed, 13 since early 2006 and lately they have been going bad with the Diag light lighting solid on some and the router rebooting intermittently on others.

    I have just put new quantity one 220uF/25V and quantity 2 of the 1000uF/16V electrolytic capacitors in the units. All three units made a hissing sound from the small toroid inductor near the power jack. I measured the 3 capacitors taken off the boards and the 1000uF caps were down to 950uF, the new ones were almost 1100uF so slight degradation. The 220uF caps were measured at 5uF, 11uF and 20uF which is a severe degradation from the original 220-240uF I measured on the new caps. Once I replaced all the caps the hissing sound went away for me. I am now testing stability. I measured the AC ripple on the adapter jack before and after replacement of the caps while the unit was open. The ripple was as much as 1.7V AC at 5000 Hz before the caps were done and after it was in the 30 mV range.

    I used Nichicon 7000 hour at 105C replacement parts from Digikey. I could not find the so called Low ESR caps there but these are rated low resistance long life.

    220uF 25V is 493-1549-ND
    1000uF 16V is 493-1526-ND
  25. rmcouat

    rmcouat Addicted to LI Member

    Follow up on capacitor change RV042 should also replace adapter

    I changed capacitors on some more RV042 routers as described in my previous post. I found an additional piece of information.

    Using a Digital Voltmeter measuring across the DC input jack you should get 12V DC from the 12VDC 1A switching wall wart. Put the meter in AC mode and I can measure 1.2V AC at 5000 Hz with the original power adapter before changing the capacitors.

    Put a new 12V DC 1.6A adapter in place and the AC component drops to 0.7 V AC

    Put the capacitors on the RV042 board and use the old power adapter and the AC is 0.6 V AC

    With new capacitors AND a new 12V DC adapter I get 10 mV AC. Now we are talking good values for nice clean input power.

    My theory is the adapters run warm and degrade over time which puts a larger high frequency AC on the input jack of the router as the adapter filter caps go. This forces the 220uF input filter capacitor on the board to work harder raising the internal temp causing it to degrade. Once the filtering in the 12V DC supply gets below a certain amount the DC-DC converter for the 3.3V supply goes unstable and the hissing sound from the toroid starts. I was able to make the router work just by getting a new power adapter but the hiss was still there until I changed caps on the board. Also replacing the 12VDC adapter did not fix all the failed units, replacing the capacitors as well has fixed all the units I have repaired so far.

    I have found 1000uF caps as low as 900uF which isn't too bad over > 3 years but of the units I have reworked so far the 220uF cap has read as low as 1.4uF, 5uF, 6uF and 14uF, so all have failed.

    Hope that helps someone.

  26. Sfor

    Sfor Network Guru Member

    I've got two damaged RV042 units.

    The first one is working correctly, except for WAN1 and LAN4 ports. The C12 was damaged as well, but it did not seem to have any bad influence on the device performance (I replaced it anyway). After replacing T2 the WAN1 still does not work, so it seems the AD6999 controller is damaged. This chip is hotter than the one in the other RV042 unit. The problem is if the replacement of this chip is a good idea, since the device still works quite well on the WAN2 port. The chip does have some EEPROM registers built in, so I do not know if just replacing the chip with a new one will work.

    The second one does not go through the self test. After powering up the system light turns on then all the lights come on for a second with exception of the DIAG an DMZ Mode. The web interface offers just the firmware upgrade page. Still, loading a new firmware changes nothing. According to the reports there was a problem with inability to change the password. I'm suspecting the flash module failure. I'm curious if it is possible to replace the JS28F640 chip with a new one, then to load a firmware through the web interface.

    Does anyone know if the COM1 port is usable for any service tasks?
  27. nanook

    nanook Guest

    i know this post is old, but i recently bought a used RV042 router that developed the whistle of death and intermittent operation. i checked the power brick that came with it and was getting 16v instead of 12. i put a new 12v on the unit and it still whistled, so i replaced the 3 caps you indicated with identical ones that i harvested out of a power supply and now it's working perfect. i just wanted to thank everyone for their insights and ideas.
  28. dvdmih

    dvdmih Addicted to LI Member

    I have an RV042 that is showing these symptoms and I have a quick question for those with more knowledge of this type of repair.

    I was under the impression that when replacing capacitors you should always replace with the same voltage rating (or slightly higher). However, the capacitors on the RV042 I am working with are 1000u 16v. Should I still replace them with the above recommended (1500u 10v) or should I use 16v capacitors?

    Thank you.
  29. cycle

    cycle Networkin' Nut Member

    I too have a RV042 which has always hissed loudly since I purchased it second hand a few years ago. After moving offices this was driving me nuts as the router was now close to my desk! I had assumed that the hiss was normal until I came across this thread (it has always run hot but has never failed despite 3 years of hissing!)

    Many thanks to tdacosta for the instructions. I followed them, replacing all 3 capacitors and adding the 10 uF ones underneath as well. Not the easiest soldering job in the world but 30 minutes later I have a perfectly quiet RV042 which is working wonderfully (and required no reset etc). Didn't need to replace the power supply.

    For any UK-based readers you can use Maplin parts VH41, VH50 and WX44. Total cost under £2, so well worth the investment!
  30. Sfor

    Sfor Network Guru Member

    Recently I had an opportunity to replace all elecrolytic capacitors in an old RV042. I did use the capacitors with the same ratings. But a month later I did encounter another problem with this RV042. When an UPS was switching to batery backup the RV042 was rebooting itself. The problem was gone after replacing Linksys AD 12/1C power adapter.

    Later I did investigate the faulty Linksys AD 12/1C. It appears there is a transformer, 4 diodes an a 1000uF 25V capacitor inside. The capacitor looked good, but after measuring it's impedance it was clear capacitor malfunction. The ESR of such a capacitor shold not exceed 0.08 ohm, while this particular one had over 8 ohms.

    The lesson from this is, the RV042 220uF capacitor is too smal to keep the router running during short time power outages related to UPS switching to battery power. The help of the power adapter 1000uF capacitor is necesary in such a case. So, it could be a good idea to replace the 220uF capacitor with a bigger one in order to help dealing with degraded capacitors in power adapters.

    By the way, the Linksys AD 12/1C case is glued together. The only way to open it is by force. In my case it was hammer and screwdriver used as gouge. I was able to glue the case back, after replacement of the capacitor.
  31. Toxic

    Toxic Administrator Staff Member

    Nice find but quite a nasty way of opening a power supply ;)

    Sent from my Nexus 5 using Tapatalk
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice