1. zachaller

    zachaller Network Guru Member

    Well i am really upset at this router now that i get my new connection 20mbits at night and around 10mbits during the day the thing is when i have the connection going through an RV042 it is really slow speeds are like uner 1mbit i messed around with all sorts of mtu values following this page


    anyother idea from you guys.

    I should also mention it works fine on my wrt54g
  2. duomenox

    duomenox Network Guru Member

    What type of connection are you getting? Cable (COAX), some sort of high-speed DSL, Sat, BPL, Fiber?

    20-Mbits is really high for a transfer rate.

    I get a max DL of 10-Mbits from my CBL provider, and that is only when I am accessing another node on their internal network (like my neighbor), I get a steady 1-Mbit up to alot of places.

    Just Curious, this little router can handle it! The Internet ports are full 100-Mbit ports. Are you using any media converters... Cheap media converters will drastically decrease network speeds, especially if they don't have much onboard memory.

    As for the MTU, Auto works really well. The basic idea behind Auto is that the router will pick the largest packet size that will not become fragmented in transit... well the largest with 1500 as the max. You standard ethernet's max mtu is 1500 and exceeding that will fragement your traffic and cause even more delays.

    Can you verify that you are getting 20-Mbits? If so, how are you verifying this, what tests are you doing and are you altering your network? Are you plugging in your PC directly to the Modem and getting faster speeds than having the router between the two?

    Just curious, need more info to help.
  3. DocLarge

    DocLarge Super Moderator Staff Member Member

    Try doing ping -f -l [packet] [gateway]

    So, if you wanted to test a packet size of 1350 and your ISP's gateway was you would enter this:

    ping -f -l 1350

    If you get "packet needs to be defragged" it means your packet size is still too large. Auto is the best option if you're unsure "but" there are times where you can drop your mtu to "manual" with a packet size of "1350" and your packets will pass with no problem and speeds are still within acceptable parameters. The best thing to do is to check your mtu using the format about; when you find the best packet size (you'll get a normal ping reply when you find a good size) use "DR TCP" to change your registry mtu settiing on the fly. You can download DR TCP at DSlreports.

  4. Toxic

    Toxic Administrator Staff Member

    make sure in the your RV042 in sys_dualwan2.htm is not setup for limited bandwidth.
  5. zachaller

    zachaller Network Guru Member

    ok hears the deal i have an unrestriced connection, so they say, i have gotten actually about 17 mbits on this test sites and 10mbits from a few others


    Dont know how i found them i live in ND and have never heard of charter

    in the late hours of the night/(early morning) i can get this doing a direct connection through my pc and with a connection through my wrt54g i get around 7 to 10mbits wich is acceptable then when i plug the RV042 in i can't even get 2 mbits i have done the ping thing to try a manual MTU and auto to no help

    and i did check the bandwitdth limiting even though i am not using and dual wan

    Here is a picture at around 11pm i am getting around 10mbits still not late enough this is the modem pluged directly into my PC

  6. zachaller

    zachaller Network Guru Member

    anybody i am right now talking to linksys tech (about to kill myself) they want to try an RMA i just dont think it is a hardware issue just wondering what you think i should to to try and fix this
  7. peridigm

    peridigm Network Guru Member

    Did you resolve this issue?

    I am having similar problems. I am testing with RV042, RV082, RV016, D-Link DFL-80, DI-624, DI-604, DI-804HV. I own a computer sales/service business and have access to lots of routers for testing. I am currently working with the local ISP tech for my cable company trying to figure this issue out. When speedtesting through the router the best I can get is 1.5 - 2.0 MBps. I should get 5. I get full upstream which is 500KBps. Connecting directly to modem gives full bandwidth. I have tried adjusting MTU on routers that support it. I have clients and friends who are experiencing the issues with the same cable company. At this point I am not blaming the problem on the ISP since the connection is blazing when connected direct to the modem. Transfer rates are close to 600KBps downloading files from MS.

    The best I can come up with is the ISP hands out a different IP when connected to the modem directly. I configured the router to use this IP address as a static and thought I found the problem. My first 5 speed tests were close to 5MBps. Then it started dropping back down to 1.5-2MBps. Time of day does not seem to be an issue.

    Looking for answers.
  8. skorell

    skorell Network Guru Member

    I have an RV042 with firmware on a Cox Cable 9Mb down 1Mb up connection and am seeing a full 9 down after tweaking the RWIN settings on my PC. Try setting your RWIN setting (TCP Receive Window) to 64240 and make sure your MTU is set to 1500 on the PC and router. You will need to reboot the PC for these changes to take effect.

    You can use Dr. TCP to set these setting though a GUI interface vs. modifing the settings via the registry.

    You can download Dr. TCP from here: http://www.dslreports.com/drtcp
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice