RV042 port forwarding suddenly not working?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Statick, Mar 13, 2012.

  1. Statick

    Statick Networkin' Nut Member

    Hi, I have a site using an RV042 as an internet gateway. The site's been online for about 2 years, and from the start I've had a number of ports forwarded to the windows server, which have always worked fine, being the usual windows SBS ports and those required for incoming VPN access to the server. There is also a port forwarded to the phone switch which the phone people have never reported any problems with.

    LAN IP range is 192.168.101.x /
    Server is
    RV042 is
    Firmware Version:
    DHCP is disabled (windows server has DHCP)

    ADSL modem is connected to WAN1 port and accepts IP address from DHCP.

    I can connect my office desktop to that site over VPN (it's connected now) and get RDP access to the server no problem. I can point my browser to the site and get the IIS homepage, and I can also reach Outlook Anywhere etc from there. This all works fine, and is dependant on several port forwards which are clearly working fine.

    They recently upgraded their CCTV system to one which allows remote monitoring of the CCTV cameras over the internet. This requires 4 ports to be forwarded to the CCTV hardware. I've added these to the port forward list, as well as to the firewall access rules. However the CCTV software won't connect to the hardware over the internet.

    The CCTV is on
    The ports it uses are 8016, 8200, 8201 and 10019

    If I run the CCTV software on a desktop client somewhere on the local network, and point the software to the hardware using the local IP of, it connects just fine. Also I can use telnet on a desktop client on the local network, and connect to the CCTV hardware on any of the 4 ports using the same local IP (, and all of them accept a connection.

    If I attempt the same thing over the internet, i.e. connecting the CCTV software over the internet using the site's gobal IP address, it just times out. If I attempt to connect to the site's global IP address on any of those 4 ports using telnet, it just times out. Meanwhile the existing port forwards to the site still work - I still have a VPN to the server working, I can still reach the IIS homepage and Outlook Anywhere pages, etc.

    The only thing that is different, as far as I can tell, is that the port forwards that are working were set up 2 years ago, and those that are not were set up last week.

    If I inspect the "incoming connection" logs after attempting to connect to the CCTV hardware over the internet, it shows the connection on the relevant port being accepted every time.

    Here's a copy/paste from the port forwarding "show tables" page.

    Service Name Protocol Ext.Port IP Address Enable
    HTTP TCP 80~80 Enabled
    HTTPS TCP 443~443 Enabled
    SMTP TCP 25~25 Enabled
    PPTP TCP 1723~1723 Enabled
    GRE TCP 47~47 Enabled
    sharepoint TCP 987~987 Enabled
    phones TCP 8082~8082 Enabled
    CCTV1 TCP 8016~8016 Enabled
    CCTV2 TCP 8200~8200 Enabled
    CCTV3 TCP 8201~8201 Enabled
    CCTV4 TCP 10019~10019 Enabled
  2. Sfor

    Sfor Network Guru Member

    Are you sure it is enough to forward just the TCP connections? Did you try to forward UDP, as well?
  3. Statick

    Statick Networkin' Nut Member

    sorted it, had put the wrong gateway IP on the cctv box.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice