Rv042 Pptp

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by ccb056, Sep 7, 2006.

  1. ccb056

    ccb056 Network Guru Member

    I have upgraded to the Beta firmware on my RV042 and I can establish a PPTP connection to the router, but I cannot access any computers behind the router (cannot ping them) nor can I ping the VPN connected computer from within the router using the VPN local address.

    Does anyone have a working VPN connection with the RV042 where the computer connected via VPN can talk to the other computers behind the router and the other way around?

  2. aweber1nj

    aweber1nj LI Guru Member

    Yeah, as I posted in a different thread, I have my Treo connecting via Mergic PPTP to the router, and then I can ping all my PCs and servers, and can use PalmVNC to actually remote-control my servers.

    Tre cool.

    I don't know that I did anything special in my setup, but am using the same beta f/w, I believe.

  3. ccb056

    ccb056 Network Guru Member

    Mergic PPTP???
  4. ccb056

    ccb056 Network Guru Member

    anyone know how to fix this?
  5. sedin26

    sedin26 LI Guru Member

    I do have this working but I likely don't have much help for you. I have the same firmware as you...

    All I did was add a username and connect. It had the same problems as you the first time but when I disconnected and connected again, it worked fine...I can ping all the machines back and forth on both ends.

    Something else that may be of interest, I also tried out QuickVPN and have found that it now works flawlessly and I can even run Netbios through it. Needless to say, I am pleased and will be going this route for the time-being.
  6. ccb056

    ccb056 Network Guru Member

    what are the ip's you have on the router's side and the connecting client's side?

    the ip's behind my router are:

    all arae assigned staticly though the router's mac address static dhcp

    the connecting computer has a local ip address of but when it connects to the vpn, it gets a vpn ip of

    I have not tried the latest quick vpn, i am going to try that

    I am also going to install the ipx/spx/net bios protocol on a few machines
  7. sedin26

    sedin26 LI Guru Member

    The IP's behind the RV042 are:, 101 and so on.

    These are assigned by a Windows 2003 Server machine in that subnet.

    The client machines I have tested with have had varying subnets but the Quickvpn client is getting, 91, etc...assigned by the router.

    I never had any trouble working with IP addresses but Netbios was a bit more challenging.

    I have a DNS server in the 192.168.221 subnet and I don't know that it would be possible without that.

    My RV042 is and my DNS server is

    The RV042 has a Static Wan address and I have two DNS servers set up for that WAN address - the first is the internal DNS ( and the second is the ISP DNS server.

    On each client machine, I have to set up the main tcp/ip connection to use as one of the DNS addresses. I also have to set it to use the full dns suffix. For example, if the internal network(behind the rv042) was on the domain "linksys", I would need to set each client machine's TCP/ip to append the suffix "linksys.local"

    With these steps, netbios seems to work over the QuickVPN connection. I don't know for sure but I doubt it'd work without the DNS server/domain in place behind the RV042.
  8. ccb056

    ccb056 Network Guru Member

    OK, when i connect via PPTP the IPX/SPX protocols aren't supported (go figure), but after changing the computers behind the router to and the vpn connecting computers to the computers can connect via PPTP and ping all the computers behind the router, along with accessing shared drives and such.

    Anyone know how to get the RV042 to relay IPX/SPX and/or netbios??????

    Also, another gripe, when a computer is connected through VPN, it can access all the computers on it's "new" network, but it cannot access any of the computers on it's original network, and none of the computers onn the original network can pink the vpn'd computer until after tthe vpn'd computer breaks the connection.

    Anyone know how to fix that, or does everyone have the same problem?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice