RV042 to RV042 VPN multicast routing?

Discussion in 'Networking Issues' started by nimby, Apr 9, 2007.

  1. nimby

    nimby LI Guru Member

    So, I've got 2 RV042's linked over a wireless bridge. I'm attempting to get a Windows Media Center 2005 system to talk with a Linksys Media Center Extender ... I can PING across the VPN, but nothing involving multicast is making it across.

    I don't have the config's right in front of me right now, but going from memory ...

    Side 1 -
    WAN1 -
    LAN -
    Media Center 2005 box -

    Side 2 -
    WAN1 -
    LAN -
    Media Center Extender -

    Bad ASCII network diagram:

    I've got all the basics enabled, RIP is diabled, and the two RV042's are setup as Routers, with the WRT54G as a gateway. My latest thought is that I need to get both ends of the VPN on the same subnet, but the RV042 doesn't appear to like being set to a /16 net (not an option in the web interface, and doing it via telnet makes the unit require a hard reboot)... So, is there a way to force multicast into the tunnel, and maybe port trigger/forward it to the MCX box?
    The VPN tunnel is established as a Gateway to Gateway VPN, and I can ping accross it, but nothing from the media center extender is getting accross to the media center PC.

    I think this might be a case of my staring at it to long, but I feel like I've tried everything.

    Edit: this is how fried I am, I accidentally posted this in the general networking, when I ment to put it in the RV0** section. Could a mod please move this?
  2. nimby

    nimby LI Guru Member

    Well, a bit of progress was made ...
    I was able to get the Media Center Extender to talk to the Media Center 2k5 box, but it seemed to only give me an error message, nothing more :-/

    It's definatly an issue with getting multicast to see both ends of the tunnel as the SAME network, but I can't seem to get that to happen with the interfaces that linksys gives you.
    I've also tried telnet'ing into the rv042's and setting the routes and interfaces manually, but doing that breaks the ipsec tunnel and won't allow it to re-establish the tunnel untill I reset it to a 192.168.2 and 192.168.3 on each end internal.

    Also, trying to set the RV042's to a /16 net via telnet seems to break the boxes and require a hard reboot.

    Any ideas? Please? :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice