RV042 upgrade firmware failed

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by sardy, Oct 23, 2005.

  1. sardy

    sardy Guest

    when i finish upgrade rv042 firmware and reboot,the diag led blinking,does anybody can help me?


    ICHIRO Network Guru Member

    Can you access

    The DIAG lamp has blinked in RV082.
    The display of the FIRMWARE recovery has appeared when it accesses

    RV042 is guessed the similar display.
    It is not likely to be able to recover if not displayed.

    I do not understand whether to recover according to the same
    procedure as RV082 because there is no experience that the DIAG lamp blinks though RV042 is used.

    To the telnet effective.

  3. johnvpn

    johnvpn Network Guru Member

    The RV042 I have had the same problem - after upgrading the firmware using the web interface upgrade menu the unit never recovered and just flashed the diag light.

    In desparation I tried the TFTP Utility from linksys' downloads page (why would i need a TFTP utility? - would be better labelled "Firmware update via TFTP") - this did work and got the firmware upgraded to the current . Good luck...
  4. gottobekidding

    gottobekidding Network Guru Member

    Hi JohnVPN,

    I have tried to use the TFTP Utility from the downloads page, but when i tried to unzip the file, it indicate it has an CRC error, and the file is corrupted. Is there else where i can download this file.

    Many Many Thanks
  5. stmm

    stmm Network Guru Member

    Flashings failed because the file is corrupted.

    The TFTP utility as well as the firmware on the Linksys website were corrupted some how.

    They have now fixed the files.

    If you redownload the TFTP utility it should properly unzip.

    If you have downloaded the firmware ".rmt" file I have posted instructions on how to recover your device.
  6. gottobekidding

    gottobekidding Network Guru Member

    Corrupted Flash

    Hi Stmm,

    Thanks for the information. After upgrading to the latest firmware, I am having problem of connecting to the VPN using the QuickVPN Client. It hanged on "Verifying Network". I have seen similiar problem been post in the forum. I tried to disable my XP2 firewall and upgrading the ipseccmd.exe utility, but problem still persist. Has anyone successfully connect to the RV042 ( using QVPN.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice