RV042 v1.3.8 Beta Firmware + QuickVPN v1.0.47 Beta

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Dec 20, 2006.

  1. Toxic

    Toxic Administrator Staff Member


    RV042 Firmware v1.3.8 Release Note


    1. Support RV016-like Bandwidth Management.
    2. Support RV016-like Port Management with the exception that VLAN is not supported.
    3. RV042 will first check if its wan ip address changes before it tears down the IPSec tunnel and reconnect. The change is to mitigate a customer issue where the dsl modem is not configured to be in the bridge mode and its DHCP server is giving out 10-minute lease time, causing RV042 to reconnect the tunnel every 9 minutes.
    4. Removed the 45-minute VPN retry limit when Keep Alive is enabled.
    5. In the Access Rules Editing page, a new field "Enter Policy Name" was added and a scheduling option of 24 hours was added.

    6. Enhanced the security of QuickVPN by supporting self-generated certificate on the router. Several functions (buttons) were added to the Certificate Management section on the VPN Client Access page. Administrator can generate new certificate, export certificate for admin backup, export certificate for QuickVPN clients, and import certificate for admin. The router's certificate needs to be delivered to all QuickVPN users and placed in the install directory of QuickVPN Client, e.g. C:\Program Files\Linksys\Linksys VPN Client\. This way the QuickVPN client will only trust these certificates placed in its local directory and will not be deceived by a hacker in the middle to connect to a hostile computer. With QuickVPN Client v1.0.47, when the client encounters a certificate that is not trusted, the client will pop up an warning message, suggesting the user quit the connection attempt. The export and import functions can be used when the admin wants to reset the router to factory default, but does not want to re-distribute the certificate to all of the QuickVPN users.

    Issues Fixed:

    1. Fixed the TCP Window Scaling issue with Windows Vista beta.
    2. Fixed an issue with MTU. After the VPN tunnel is established, changing MTU setting from Manual mode to Auto mode will cause on-going tunnel connection not able to transmit VPN traffic correctly
    3. Fixed the known issue that the local DNS Server's IP address does not get passed to DHCP clients.
    4. Updated the maximum number of entries for protocol binding from 30 to 100 in the Daul WAN help page.
    5. Support the new PeanutHull DDNS service. The option, PeanutHull, was renamed to Oray.netPeanutHullDDNS on the DDNS setting page. The help page for DDNS was updated as well. (Note: In China, the specification of PeanutHull DDNS service was changed on Oct. 1st, 2006. Old PeanutHull DDNS client will not work after Oct. 1st.)

    Known Issues:

    1. This is firmware is not compatible with some cable modems (e.g. Motorola Surfboard) that provide more than 2 DNS Server entries to RV042 whose WAN connection type is DHCP - the router will keep rebooting.
    2. After firmware upgrade, the router needs a power reset to function properly.

    **If firmware upgrade should fail using the Web UI, a TFTP utility can be used to load the v1.3.7.2 firmware into the router. You could then upgrade the firmware to the latest version using the Web UI.**

    Please contact linksys Support for the Beta Firmware.
  2. Toxic

    Toxic Administrator Staff Member

    If you do find any bugs relating to this firmware or compatability with QuickVPN v1.0.47 please give indepth findings. this will help Linksys fix issues resulting in this new beta.

  3. aviegas

    aviegas Network Guru Member

    Router problems

    Just installed 1.3.8 beta and after 10 hours, the router HTTP interface stopped working (not responding to a TCP connect), but the router was still operational. After roughly 15 hours, the router stopped working: totally hung - time to power off and restart. This never happened in two years.....
    Let's give it a chance and hope that a pattern does not develop.
  4. Toxic

    Toxic Administrator Staff Member

    strange. mines be running since the day i got the firmware 14th Dec. I rebooted between then and now but its been sold for me.

    so far System up time : 5 Days 20 Hours 56 Minutes 10 Seconds
  5. marshal

    marshal Network Guru Member

    I tried it. It last 10 minutes on my router..

    The upgrade went through, then, the router was resetting as soon my cable modem was connected.

    I downgrade to and all goes back to normal
  6. aviegas

    aviegas Network Guru Member

    Bad news

    Happened again, after a few hours.... But I'm still willing to give it yet another try. I will Reflash, Reset to defaults and Reconfigure once again and see what happens. The TCP window fix is a must as I have 4 machines (2 running Linux and 2 running Windows Vista) that require it (yes, I know the workaround to fix the window size, but...)
  7. Toxic

    Toxic Administrator Staff Member

    Whats the WAN configuration on your RV042? are you able to ping the router once httpd stops working?
  8. aviegas

    aviegas Network Guru Member

    The WAN config is Static on WAN1 (DSL behind yet another router) and DHCP (cable). The interesting part is that if the cable modem is off or not responding the router locks when attempting to renew the DHCP lease.

    I'm now back to, just to be 100% sure that it's not another problem, so I can't comment if it would respond to pings once httpd died. I would guess it would, as the routing layer was still working fine.

    Now the horror story: reverting back to was hard. The router stopped in the middle of the firmware downloading, so I had to resort to reloading using tftp. Then for some reason it stopped in the middle of the download again. Only worked on the 3rd attempt.

    Let's see if it stays up and stable. Then I will give 1.3.8 yet another try....
  9. aviegas

    aviegas Network Guru Member

    So far, it's been 24hrs and it's up and running back with
    Later tonight I will try 1.3.8 once again.
  10. leebob

    leebob LI Guru Member

    I had a similar experience after this upgrade. Once I reset it, it worked fine. Interestingly, if I make a PPTP connection from a LAN side desktop outbound to the server I have hosted on the LAN side as well, the router will reboot within 60 seconds. If I make a PPTP connection to other VPN lan's outside of my own, it works fine.
    I have a static IP connected to cable. Two IPSec tunnels configured but not in use during these tests.
  11. aviegas

    aviegas Network Guru Member

    Yesterday, I've reloaded 1.3.8 and it's been stable for more than 24hrs. Sounds like some sort of "nvram" reset is needed to get this firmware running, or at least some conflicting configuration. For now on, I will always do a hardware reset on firmware upgrades, just in case.

    Feature wise, this firmware is very nice, jut lacking the VLAN stuff. But protocol binding is still broken. I still can't force traffic for a particular host thru WAN2. It will act as nothing is being done and will take either route. When I set the route to WAN1, it works.
  12. aviegas

    aviegas Network Guru Member

    Now it's almost 1 1/2 days back with 1.3.8 and all seems normal. Not a single reset so far. Maybe 1.3.8 changes the NVRAM data area layout and depending on the original settings it will give different results uppon upgrading. Reseting to defaults may be the way to go.

    One thing that I've noticed is that it fails to connect to the cable modem on WAN2. Each time I restart the router I get as address and it only connects after a specific "renew" request.

    Also, IP address based protocol binding is still not working to WAN2. It does not get "locked" to WAN2. It does work to WAN1 though.
  13. aviegas

    aviegas Network Guru Member

    Backing away from 1.3.8

    I'm back to - all of a sudden the "apparently stable" 1.3.8 setup started to reboot and WAN2 was always off (cable DHCP). As soon as I asked to renew the IP address, it got one and hung. Time to manually reboot. After a few minutes hung again. Reboot, reloaded (no errors this time), factory reset, reloaded a saved working config and back to business: no more hungs and reloads.

    There is something really fishy with 1.3.8, and I would be it's related to DHCP. The behavior suggests some form of data corruption (in one of my attempts the GUI got corrupted to a point of showing partial pages, but the router was functional. Had to reload to reenable the GUI).

    So I'm done with 1.3.8 for now. I will wait for a future and hopefully more stable firmware drop.

    You all have a great 2007!!!
  14. lectricgenius

    lectricgenius LI Guru Member

    v1.3.8 Beta woes

    I was having issues with my RV042 router with respect to the load balancing and the ability to service a voip phone on the lan side. After days of attempting to tweak the configs, against all better judgement, I decided to give the 1.3.8 Beta firmware a shot.

    First, I would recommend to anyone who wishes to try this version to first make sure they know their configuration. Secondly, I suggest to restore the factory settings before applying the upgrade. I am not certain why, but for some reason, until I removed all of the settings, the upgrade would not take properly. In fact, I spent nearly 3 hrs attempting the upgrade! My detailed experience follows:

    The process involved a first failed attempt which only served to "lock the router up completely". It was re-setting so quickly that I could not log back in to even look at anything. Having read the warnings, I waited a substantial amount of time before deciding it would not work. I do not think at this point tftp would have helped, because it would not stay operational for more than 30 secs. The first response was to disconnect power and hope it would reset. This had some benefit, as I was able log in after resetting via power disconnect. But, the router was still resetting so frequently that no changes could be applied.

    Next came the master reset button trick. This stabilized things somewhat. After about the sixth master reset, the router quit resetting on less than one minute intervals. Once operational, attempting to login brought up a gui I had never seen before. It was not the usual default page, but rather a blank white background with one input field in the center for upgrading firmware. Assuming the obvious, the first upgrade attempt was a failure, so I chose to upload the 1.3.8 firmware again (yes, a glutton for punishment I know). This time it took properly. When it finished, everything came up no problem, but all of the fields were blank, so I began to configure for my setup (mediacom cable with moto sb5120 on wan1 and local network provided by landlord on wan2-- this is a verizon dsl connection being shared for whole apt bldg.)

    When I had everything configured the way I need, I applied settings followed by a restart. After the restart, was back to resetting on <1min intervals again. Spent a lot of time attempting to figure out what was wrong. At that time, I had plugged the LAN into my voip phone so I would have phone service and was using its built in router to supply the wan2 on the rv042. After alot of hair pulling, I finally narrowed it down to the connection from the voip phone's router. If I disconnected wan2, all was well. Just for good measure, I swapped the two connections to make sure it wasn's a fluke. Finally discovered that the RV042 will not let me connect anything from the phone's router to either of its wan ports.

    I should note that prior to upgrading, the RV042 would operate fine with one of the wan ports being supplied by the phone/router.

    Now, I have to connect both internet connections into the RV042's wan to avoid constant resets. Unfortunately, with this setup, my voip phone will not work. I have tried to forward ports, protocol binding, static routes, and everything else I can imagine.

    All in all, I believe the firmware is an improvement in what it is supposed to do. I like the added features, but they do not seem to function as planned. I believe if the developers work the "bugs" out of this firmware, it will be a powerful upgrade. Until then, I do not recommend that anyone with a life to try this. If you are up for some sleepless nights and enjoy experimenting with matters such as this, by all means, I wish you luck!
  15. Toxic

    Toxic Administrator Staff Member

    Just been give an Update on the 1.3.8 firmware:

    Known Issues:

    1. This is firmware is not compatible with some cable modems (e.g. Motorola Surfboard) that provide more than 2 DNS Server entries to RV042 whose WAN connection type is DHCP - the router will keep rebooting.
    2. After firmware upgrade, the router needs a power reset to function properly.
  16. lectricgenius

    lectricgenius LI Guru Member

    The funny thing is that it is working with my motorola surfboard modem. The constant resets happen if I run one connection through the phone's router first.

    I have 2 distinct yet totally different problems:

    If I connect both internet connections straight to the rv042 and the voip phone to one of the lan's, the phone does not work.

    If I connect one of the internet connections to the phone, and the phone's lan port to one of the rv042's wan's, the router goes into "continuous cycling".

    I have tried to configure both the rv042 and the phone router every way I can think to do, and I just can't find a cure.
  17. Toxic

    Toxic Administrator Staff Member

    sounds like you need to port forward the correct ports to your phone. what Phone adapter and phone service are you using?
  18. lectricgenius

    lectricgenius LI Guru Member

    The phone is a uniden UIP1868P with service through packet8. From what little info I found about their servers, etc, port forwarding was one of the first things I attempted. I could have bad info though.
  19. russwmc

    russwmc Network Guru Member

    This is not related to the beta firmware but... I tried for quite a while to get Packet8 working through the RV042. Could never get it working. If I put a Linksys WRT54G or SnapGear VPN router between the WAN and the RV042 then the Packet8 DTA310 would work on the LAN side of the RV042. If RV042 was direct to WAN DTA would never connect. Tried a lot of different things which may still be somewhere on this board and on Packet8's forum. I wonder if Vonage has this problem? Sounds like SIP in general is a problem through the RV042 based on this recent post:

    If you had that Packet8 device working configured like this with the older firmware then let me know:
    WAN <--> RV042 <--> Packet8 device

  20. lectricgenius

    lectricgenius LI Guru Member

    My intent was not to drag this thread off topic. Yes, I have issues with the RV042 and my Voip, but I wrote my post more with my experiences with the Beta firmware in mind. The biggest issue being that if I connect my phone lan output into one of the WAN's in the RV042, it constantly resets. I was trying to be as thorough in my explainations so that I might help those working with the debugging of this beta firmware version.
  21. starlight

    starlight Network Guru Member

    I now have running the new firmware on 2 routers and it seems mostly working. resolved the issue with ftp and dual wan. 1.3.8 has the old bug back again to switch the wan port during a ftp session :( Thats very bad news because plenty ftp servers don't like this behavior.

    What puzzled me a little bit is the service management button.

    At first it would be fine if i could select tcp&udp and not tcp or udp
    Also what does the protocol ip mean ?

  22. franki_hk

    franki_hk LI Guru Member

    I'm having the following problem with the RV042:

    WAN Port 1: 8M down / 800K up to Internet.
    WAN Port 2: 2M down / 2M up to Internet.
    Set as "Load Balance" mode

    WAN Port 2: VPN to another site using RV042 with same connection speed as this one.

    When I was using a PC to upload a 230MB file to a Web Server, it always stop at the file was uploaded arround 50-60MB. I can't upload the file completely. This problem is consistent and always occurs.

    Finally, I use "Protocol Binding" to force those FTP traffic to WAN Port 1. The problem is then fixed. However, the problem is still happened at the VPN port.

    I think it may be firmware bugs.
  23. pablito

    pablito Network Guru Member

    Is WAN 2 a DSL/PPoE line? Check your MTU. I had a similar issue with the RV082 that was sensitive to MTU and got much better after a firmware update. The issue was always with upstream but happened after just a few kbs.
  24. franki_hk

    franki_hk LI Guru Member

    The WAN 2 is a symmetric DSL line.

    The MTU settings is using "Manual" 1492.
  25. aviegas

    aviegas Network Guru Member

    Ah... I do have a Motorola Surfboard SB1500 cable modem in DHCP mode, so that explains the problem. Indeed I've noticed that there was something related to the modem, as having the cable WAN disabled allowed the router to work, but it would fail as soon as the WAN was enabled.

    Any hope that this will be fixed soon?
  26. venom51

    venom51 LI Guru Member

    I have a motorola surfboard SB5100 as well but have not experienced that problem. The only issue I have come across is the RV will drop the IP every few days and will not recover until I reboot the modem and then plug the RV back in while the modem is booting.
  27. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    RV042 and VoIP

    I have found that VoIP (specifically SIP) is still broken. I can use my VoIP phone behind my Cisco PIX but not behind my RV042.

    I can't get a dialtone when the VoIP adapter is behind the RV042. I notice that the 1.0.29 code for the WRV200 specifically fixes NAT'ng issues with SIP. Is this a recognized problem with the RV042 and, if so, is there a resolution in the works?

  28. Frank The PC Guy

    Frank The PC Guy LI Guru Member

    QuickVPN issue after update to firmware v1.3.8 (Help)

    Hello Everyone,

    I just updated my routers firmware using the new version v1.3.8. The update seemed to go smoothly i guess. I even performed it remotely. I installed the new QuickVPN client 1.1 which was working before. I then generated a new client security certificate and placed a copy in the Linksys directory where the QuickVPN client is installed on the connecting PC.

    Now for some reason it does not recognize the certificate. it asks me twice then terminates the connection. I tried on another PC same thing happens. When I remove the certificate it will connect using only the user/pass.

    Has anyone else had this problem? Any ideas?

  29. Toxic

    Toxic Administrator Staff Member

    you may want to upgrade to the official firmware now which is newer than the beta version.
  30. Frank The PC Guy

    Frank The PC Guy LI Guru Member

    I did

    Im sorry I didnt mention that before. Actually I hope im not in the wrong forum. But, I did use the actual upgrade from the linksys download section (RV042). It was dated 2/5/07 I donwloaded it 2/7/07.
  31. venom51

    venom51 LI Guru Member

    I still see better speeds with the MTU set to manual : 1500.
  32. Mr_Five

    Mr_Five LI Guru Member

    Need help download RV042 firmware

    Hi TOXIC,

    Can u give me a link to download RV042 or firmware ?
    My current firmware 1.3.9 had a problem with auto detect IP at WAN 2

    Need U'r help....

  33. Steve Morris

    Steve Morris LI Guru Member

    I am running 1.3.9 with an older surfboard I think it's an SB4100, and the RV042 would fail/lock up after about an hour of being connected. (I also had a VPN running so there was always some traffic) What I finally noticed that appears to have stabilized the RV042 was that the SB4100 was telling the RV042 in the DHCP packets that it had an MTU of something like 576. Once I changed the MTU setting from AUTO to 1470 (manual) the router has been solid and up for days.

    Hope this helps.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice