Rv042 & Voip

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Bryanba, Sep 19, 2006.

  1. Bryanba

    Bryanba LI Guru Member

    I've got a RV042 with the latest firmware d/l from this site. It seems to work fine for the most part however periodically when talking on the phone I lose either the send or receive "stream" of my conversation. I can hear the other party OR they can hear me but not both ways. I use two VOIP services, Vonage & Viatalk, both VOIP devices are behind this router with fixed IP's.

    If I reboot the RV042 the VOIP service starts working again. I don't need to reboot the cablemodem or the VOIP devices, just the RV042.

    Any ideas?

    Would trying to configure QOS for either/both the VOIP devices help possibly?

    Additionally, I periodically lose connectivity over a VPN tunnel (gateway to gateway). The VPN summary page says it's connected but I'm unable to use the tunnel. Rebooting OR disconnecting/reconnecting the tunnel resolves this problem.

  2. strueblood

    strueblood LI Guru Member

    Check the Router

    What firmware are you using?

    I deploy many RV042 units to my clients and they work great.

    I have an RV042 at home and I'm using broadvoice via SIP which is what vonage uses.

    I have a flawless connection.

    I would check the firmware on the router, check the firmware on your sip devices.

    I have a linksys WIP-330 phone (Wireless Voip Phone) F-ing love it.

    and I have a Sipura device and they both are working flawless with the RV042 and an optimum cable modem.

    The other thing I would check......

    Did you look at the logs?
    Did you run the sys log viewer and watch the traffic go by?
    Are you trapping SNMP to see if you get network drops? (Try PRTG traffic grapher it's great) http://www.paessler.com/prtg

    Did you replace the router to eliminate potential bad hardware?

    I hope that helps

    -Scotty T.
  3. bjelsmore

    bjelsmore Guest

    VOIP and NAT

    Wow, not a single mention of 'link aggregation', 'port forwarding', NAT, etc...

    If you Google this problem you will see that it is VERY common, and widespread. This is the first troubleshooting I've seen that focuses almost exclusively on firmware and bad hardware.

    'NAT' is by far the most common culprit. I wont argue that 'bad hardware' could cause a problem, but as far as firmware, I can't see the version mattering since Vonage works fine on all versions released to date, as well as the beta version.

    SIP (vonage ports UDP 5060-5063) is simply the signaling protocol, the audio is going to go over RTP (vonage ports UDP 10000-25000). You should make sure that you have forwarding rules setup for BOTH, since dynamically things could get flaky (as you are describing).

    Port Forwarding. Assign your MTA a static private address (same subnet as your router). Forward UDP 5060-5061 and UDP 10000-25000 to that static address.

    Otherwise, you could assign your MTA a static private address, and put that address in the 'DMZ HOST' field under SETUP. This will basically allow ALL traffic to be seen by your MTA.

  4. Bryanba

    Bryanba LI Guru Member

    Thanks folks.. I'm using firmware I'm using the default NAT, nothing extra.. just several machines behind this router, mostly dymamic IP's but a couple configured with static IP's. The VOIP MTA's both have static IP's.

    I'm not forwarding any ports but I'll try forwarding the ports mentioned above and see if that helps. Again, both MTA's already have static IP's.

    I haven't tried the syslog viewer or snmp, I wouldn't understand what's being reported anyway. With this router the log entries are greek to me.. I could at least make sense out of the log entries of the prior BEFSX41 (which worked fine for VOIP) but the RVO42 logs are less useful.

    I noticed today when I got home both phones were out. The lights on the MTA's indicated no phone service for either line. I checked the RV042 and both gateway-gateway tunnels were "waiting for connection". I changed the MTA to manual at 1500 and saved settings and within seconds the tunnels reconnected and both MTA's established connections.

    I don't think changing the MTA really fixed anything, I think just making any change and saving it causes the router to "reset" so to speak.. and things begin to work again..

    This is happening once or twice per day..

    Where do I get the sys log viewer ? I used to have one for an earlier model but can't locate it ...

  5. strueblood

    strueblood LI Guru Member

    syslog viewer

    You can get the syslog view on ftp.linksys.com

    I believe it was under the wrtg54g log viewer or something like that.

    I certaintly won't argue other peoples opinions, I hear many talks about port forwarding , private static IP, etc.

    But i'm telling you. I plug my SIP device behing any firewall and Boom! it's working.

    Now I'd agree that the SIP devices might need a firmware update or something but......

    The lastest firmware updated devices should work just find behind a Nat'ed firewall. With the exception of some custom firewall configs specifically configured to drop traffic.

    Heres a thought, try for a day removing the firewall and keeping your SIP device on the DSL or cable modem or what ever you have and see if the problem goes away.

    -Scotty T.
  6. Bryanba

    Bryanba LI Guru Member

    I'm not sure removing the RV042 for a day will tell me anything useful. I already know it's the router causing the problem. I'd expect it to go away with the router removed.

    I've got two more RV042's installed at customer sites using VPN and they work great, however neither of them are using VOIP.

    Incidentially, VOIP worked fine behind the BEFSX41. I didn't have these problems..

    I can forward ports 5060-5063 to the Vonage MTA, but the router isn't logging any traffic for the Viatalk MTA so I can't tell which ports it's using. Both MTA's are Linksys RT31P2's. I've viewed the logs on each of those devices.. I haven't configured forwarding yet because I'm wondering if both services might be using the same ports.. I'll check with Viatalk to see which ports they use..

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice