RV042 vs RV082 vs RV016, features/issues comparison

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by LakeSolon, Sep 28, 2006.

  1. LakeSolon

    LakeSolon LI Guru Member

    I've done quite a bit of searching and have been unable to find a comparison of the current feature set (latest beta firmware revisions) and outstanding known issues useful for purchasing decisions.

    Please post any relevant attributes you can think of and hopefully we'll have such a comparison ;)

    1. Desk-style, ports on back
    2. 1x Dedicated WAN port
    3. 1x WAN or DMZ port
    4. 4x Switch ports
    5. CPU: Intel IXP425-266
    6. Port Mgt features present, but hidden in Web Gui
    7. Lacks "bandwidth management"
    8. 32MB of DRAM
    9. 8MB Flash

    1. rack-mountable, ports on front
    2. 1x Dedicated WAN port
    3. 1x WAN or DMZ port
    4. 8x Switch ports
    5. CPU: Intel IXP425-533
    6. 32MB RAM
    7. 16MB Flash

    1. rack-mountable, ports on front
    2. 2x Dedicated WAN ports
    3. 1x Dedicated DMZ port
    4. 13x Switch ports, 5 of which can be configured as additional WAN ports
    5. CPU: Intel IXP425-533
    6. 64MB RAM
    7. 16MB Flash
  2. net_eng

    net_eng Network Guru Member

    Just so you know, port management on the RV042 is coming on a firmware update(is on the latest betas just not enabled on the web gui). Its already there if you are using beta or Just go to

    It "appears" Linksys is moving all the RV's to have the same options(other than number of ports) which would simplify support and updates for sure. Not sure why they havent done this in the first place.

    If RV016 or RV082 has bandwidth management, I am sure we will see it in the RV042 in the future.

    Its what I see happening though you never know as I dont have any official information, I am assuming based on what I am seeing.
  3. LakeSolon

    LakeSolon LI Guru Member


    If they do get things totally consistent that sure would save a lot of people a lot of headaches =)
  4. d__l

    d__l Network Guru Member

    Does the RV042 have the restart-revert back to a previous firmware feature? Because it only has half the flash size, I didn't think that it could have enough memory capacity for this feaure.
  5. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    The 016 has 64 megs of RAM, the 082 has 32 megs of RAM. I forget what the 042 has...
  6. net_eng

    net_eng Network Guru Member

    The RV042 has 32 MB(megabytes) of memory and 8MB of Flash
  7. swe_deathvalley

    swe_deathvalley LI Guru Member

    Some more on the RV082.

    CPU : Intel IXP425-533
    DRAM : 32M
    Flash : 16M
    Tunnel(s) Available : 100 (FW 1.3.2 )
    Uses 9w maximum power draw
  8. Toxic

    Toxic Administrator Staff Member

    I have not seen this feature on the RV042. I have however seen it on the RV016. I have updated the list a bit as well.
  9. sterner

    sterner LI Guru Member

    RV016 has 16MB Flash
  10. d__l

    d__l Network Guru Member

    The list should indicate that the RV042 does not have this feature. Both the RV082 and RV016 have it and they also have twice the flash memory as the RV042 does. This extra flash memory might be necessary to keep two firmware versions, the Active and the Backup version, available in the router.

    The reason I asked is that only firmware that I have available to check for the RV042 is the version 1.2.3 in the simulator. Oddly enough it does not show any radio buttons to select between the Active and Backup firmware verions, but it does have the help area on the side that says there are Active and Backup versions of the firmware! So I didn't know which was correct. :)

    Attached Files:

  11. net_eng

    net_eng Network Guru Member

    RV042 uses 266 processor

    Just an update, the RV042 uses the IXP425-266 processor not 533 like the RV082 and RV16 :)
  12. aviegas

    aviegas Network Guru Member

    The RV042 <router_address>/lan_setting.htm page has one big difference: no VLAN, as available on both the RV016 and RV082. Maybe this is why it's not enabled yet (???).

    I really hope to see these 3 missing features (Port Management, VLAN and bandwidth management) available on the RV042.

    Next fix the DHCP/DNS issue, better integrate the new LAN IP aliases with Port management/VLAN and DHCP and add true port forwarding (destination port option). These routers will become really fantastic!
  13. net_eng

    net_eng Network Guru Member

    By the way, port forwarding:

    If you want to just forward external port to the same internal port such as:

    <public IP>:80 -----> <private IP>:80

    then use port forwarding section.

    If however you want to forward an external port to a different internal port such as:

    <public IP>:80 ------> <private IP>:8886

    Then use the upnp screen. Dont enable Upnp function unless you want to use it internally. But you can still use this area to create a port forward by going to service management and entering an external and internal port.

    This ability is there at least on the RV042 its just poorly implemented and documented. Try it, I have done it and it works(without using Upnp by the way). Not sure why they did it in this way. It has nothing to do with Upnp(if you dont enable it) but its in the section.

    So you can forward from public accessible port to a different internal port :)

    Hope this makes someones day
  14. Mr_Flibble

    Mr_Flibble Network Guru Member


    You just made my day. I never would have looked under UPnP for that for the RV082 I am using. I was smashing my head against this because it is so easy to do on my WRT54G with DD-WRT! :p

    Thanks so much for that post!
  15. aviegas

    aviegas Network Guru Member

    Made mine too!
    I've always ignored the UPNP stuff cause I don't trust M$ software to make decisions on ports to be opened, so I missed it totally.
    Nice to know that it's there, albeit awkward!
  16. ed001

    ed001 Network Guru Member

    I am currently using the "VPN Backup Functionality" (1.3.2)that for the moment appears to be only available in the 82. I should mention though that I have not seen any beta change logs for the 16 or 42.
  17. net_eng

    net_eng Network Guru Member

    I am glad the information about port forwarding was useful. I believe that is what these forums are for, try to help eachother. If you have a problem or question chances are someone here has either found a solution or has a similar problem.

    Just post as much relevant information as possible and we will try to help :)
  18. viperweb

    viperweb LI Guru Member

    Me being thick

    I have tried like you said to enable the UPnP, setting up the services and the corect internal IP addresses. Port remap didn't work. I've tried adding port forwarding rules - Port remap didn't work and I've tried firewall rules but can't get the port remap to work.

    Can someone give it to me in simple terms how to port forward like this.

    <public_ip>:3399 -> <internal_ip>:3389

  19. RAD_MAN

    RAD_MAN Network Guru Member

    based on the RV042 running firmware this is how i do it

    bring up the UI
    goto "Setup" then goto "UPnP" submenu option
    set "UPnP Function" to "Yes"
    click on "Service management" button
    a "Service Management" window comes up, fill in "Service Name"
    choose your protocol (TCP if you are forwarding RDP btw)
    external port for forward, from what you mentioned 3399
    then enter your internal in local network port, in your case 3389
    then click "add to list"
    then click "save settings" and the window should then close
    back on your UPnP screen select your newly created service from the "service" catagory
    type in the local IP address on the LAN under "Name or IP Address"
    put a check in the "enable" catagory
    then click on "Add to list"
    then click on "save settings" at the bottom of the screen

    then you should have your port forwarding working from different internal and external ports
    i have done this on a RV082 and it is exactly the same

    good luck

  20. d__l

    d__l Network Guru Member

    The "UPnP Function" does not have to be enabled for the port tranlation-forwarding to function properly, and in fact, it shouldn't be set to Yes if you do not want Windows attempting to modify your entries through UPnP.

    Edit: Once you choose your service and IP address, the Enable check box must be checked as RAD_MAN stated. I've found that sometimes when you add a Service Management rule, it may not be enabled after you think it should be. If your rule isn't working, check the Show Tables function to be certain it is really enabled.

    If it isn't, re-check the check box, then click the "Update this Application" button, and then "Save Settings" to enable the rule..
  21. viperweb

    viperweb LI Guru Member

    Rad_man - I've tried doing the same as you said but can't get the remote desktop connection I'm working on to work. I've tried changing firewall settings but still nothing wants to work
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice