RV042 WAN speed

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by alankidwell, Jul 3, 2006.

  1. alankidwell

    alankidwell LI Guru Member

    I tried a search and could not find anything on the subject.

    I have a RV042, just got a it a few months ago from tigerdirect. when i first got it, it worked great from the WAN modem i recived the full stated speed from my ISP 8Mbs. I recently moved, got the same ISP same connection rate of 8Mbs, but when i use the Rv042 as the Gateway to the WAN connection i only recive 1Mbs downstream, but the upstream stayed the same 700Kbs. i Calle my isp, comcast and they came out and stated that it was the router that i had connected to the modem, they connected the modem derectly to my server and everything worked great, 8Mbs down 700Kbs up. I have a router that host my VOIP for vonage, i connected this as the gateway to the WAN, connected my server and all other PC's to it, work totaly knaraly, 8Mbs down 700Kbs up. i decided that as unlikley as it may seem, i set somthing wrong on the RV042, so i reset factory defaults and upgraded the firware only to have the same symtoms. I changed the eithernet cable between the RV042 and the WAN modem with no positive results. So now desperate i call linksys suport, only to talk to a very nice hindu lay with a masters in electrical engenering that instructed me to do what i have already done. She then gave me exchange auth. number, i sent the router back, and recived a new one. I opened it up and guess what, this router does the same thing, i then checked the serial number to make sure they didn't "clean reseat, and not find any deffects" but it is a new unit. So i call linksys back, slightly iratated, i talked to a gentlman that told me to upgrade the firmware and reset factory defaults. he then talked to his seinor tech to find out this is a known issue for this router. But he said there was a fix, a new firmware, and that he would email the link to it. i waited a few days and did not get an email. so i did some searching, ended up here and downloaded the Beta firmware that is posted here. And i still have the same issue. So now i am asking is anyone has had this issue, and if they have found a fix.

  2. Toxic

    Toxic Administrator Staff Member

    What version of firmware are we talking about? latest version of firmware is here:

    RV042 firmware

    any betas are old than that i can assure. there is a known alpha firmware, but this is not for public consumption

    what is the MTU setting on the RV042 set at? if it is at Auto the this is equal to 576 which will slow you wan down, this is a known "feature" :eek: and you should manually use 1500. btw it is talked about in the forums already.
  3. alankidwell

    alankidwell LI Guru Member

    During trouble shooting with linksys we changed the MTU to 1500 with no change. The tech that i talked with the second time told me that the version of firmware on the website is does not fix this "known" issue.
  4. Toxic

    Toxic Administrator Staff Member

    Sorry but there will be difference from Auto(576 to an MTU of 1500, or elese we would not have any MTU setting at all.

    what size of RWIN are you using on your PC?
  5. alankidwell

    alankidwell LI Guru Member


    the RWIN is stock for XP on all Pc's. But i seems to me that the RWIN is not the probly, becuase when i use a diffent router, the VIOP from vonage it work great, only when i use the RV042 is when the speed degrades. As far as the MTU, i am sure that i changed when i was on the phone with linksys and there was no change in WAN speed, but i will doulbe check tonight when i get home.
  6. jack_diesel

    jack_diesel LI Guru Member

    let us know firmware ver.

    let us know the firmware that u are using in ur router know...

    I do have a router rv082..i will check it and let u know once i know the firmware in ur router
  7. Toxic

    Toxic Administrator Staff Member

    Also tell the firmware you have at present please.
  8. alankidwell

    alankidwell LI Guru Member

    Just put on the RV042, then i searched for MTU setting and problems on linksys website, they have a neat little FAQ that tells you how to set your MTU for your network and WAN speed. Set my MTU to the number i got after all the whoops i jumped through. At first i did not see any differance, but after 3 or soo speed test it Jumped to 7Mbs, i was like yeah, a step in the right derection, fine tumed it a little more and now average about 8.5Mbs, higher than my isp advertizes. So thanks for all the help. But y did it not happen right after the change? if it had i would have not sent the first router in for repair?

  9. Toxic

    Toxic Administrator Staff Member

    glad you got it fixed
  10. YeOldeStonecat

    YeOldeStonecat Network Guru Member


    It should happen immediately after you change the MTU. I never trust auto-MTU on any router brand/model...as it hardly works right, too many variables, I always manually set it. But the RV, when on auto, decides on 576..which is the setting for dial up.

    If I flip my RV0 from 1500 to "auto"..and click on save settings..and give it a moment to reboot...I'll notice a big drop. And if I do the reverse..I'll see my gain in speed again.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice