RV042 Wan Speed

Discussion in 'Networking Issues' started by DSMGSX, Jul 24, 2006.


    DSMGSX LI Guru Member

    Hello All.
    I have a Rv042 latest firmware. I cannot get my Comcast WAN speed any higher than 2.5MB

    On my old router , A BEFSR41, throughout is 6.5 MB
    Outbound is alway the same. 737k

    I have Changed MTU to 1500.

    I have tried disabling firewall etc. No difference in WAN speed.

    linksys support seems to indicate a firmware issue, however I am at the latest firmware and still my speed differs from one router to another, by 3MB. Both Routers are configured as close as they can to be the same. MTU , etc.

    Linksys support is USELESS
    Any other ideas?

  2. Toxic

    Toxic Administrator Staff Member

    when you changed the MTU to 1500 and saved setting, try rebooting the router. (power off/on again)

    DSMGSX LI Guru Member

    Tried that

    Simon , thanks for the reply. I Disconneted power, that doesn't make any difference. I see from your tagline your running a newer firmware ( than is available. How do I get that version? Linksys states there is no beta firmware etc.
    What can I do to make this thing run at full speed of my ISP. My 10 year old BEFSR41 runs like a champ. I understand overhead and such from this router, but 3MB is a hell of alot of speed to be losing.
    Linksys support is horrible at best. Looks like I might have to trade this Piece of junk in on a Cisco 871. Their business class support is a complete joke! They have no answers, just to wait around till they may come out with a newer firmware. I guess I should expect it from a consumer company. I am surprised Cisco even lets them put the Cisco name on a linksys product. Pathetic.
  4. pablito

    pablito Network Guru Member

    Must be something else wrong. I get full speed from mine. My troubles are with VPN over certain DSL providers and the work around was an *older* firmware until the new comes out.

    Are you on DSL or cable? DSL usually likes an MTU of no more than 1492 and mine works best with 1452. So milage may vary. More details about the connection and config might help.

    Agreed that tech support sucks but that is no surprise from any company. I don't even try and haven't done so for years.

    DSMGSX LI Guru Member

    I am on Comcast cable, MTU of 1500, SPI and most other defaults are at the DEFAULT level. No VPN setup. Some minor port forwards, What other information are you interested in? Thanks for your help
  6. pablito

    pablito Network Guru Member

    Interesting. Cable is usually the easiest so I'm surprised the RV has trouble. I hooked one up this weekend on a cable line and I got the max of 6M. This is the standard plug and play DHCP cable modem.

    Assuming that you have the latest firmware and the cables are good I might try this:
    .Do a factory reset of the RV and start over.
    .Use a new patch cable and verify it does 100M and not 10M.
    .Unplug the cable modem for a while so that it releases DHCP and sees the RV as the 1st and only device.
    .Leave the MTU at auto and then look at the logs for what it did.

    I'm running one on a cable line with two VPNs running, several port forwards, and a few rules for extra protection. Full speed and so far no troubles. This is on a Canadian ISP. I don't know about Comcast.

    Oh, just for kicks you might try connecting the cable modem to the DMZ port just in case the RV is bad. It should perform the same.
  7. Toxic

    Toxic Administrator Staff Member

  8. pablito

    pablito Network Guru Member

    Whaaa? I'm using an RV082 so it must be different in that respect. I just set one to auto and let it boot (risky since it is a remote router....) On a cable modem it auto set to 1500 and then the expected MTU on the ipsecxx interfaces. Over here on DSL it will auto set to 1452 which is exactly what my other routers will get from the ISP. Glad I picked an 82...

    576 doesn't sound right at all. The support line must be going nuts at Linksys.

    I thought the big difference between the units was CPU and RAM. I went with the 82 since I need VPNs and don't want it running hot or going slower than it should. perhaps the 42 needs a 3rd party firmware more than the 82 does.

    DSMGSX LI Guru Member

    I've performed a factory reset, tested it . EXACTLTY THE SAME RESULT.
    Put my config back in it, SAME AS BEFORE. Any other ideas?
    thanks guys

  10. Toxic

    Toxic Administrator Staff Member

    Refrain from you foul mouth now. this site is here to help. You have NO right mouthin off on this forum, it is not owned by Linksys.
    you have a private message. I suggest you read it when you have calmed down
  11. dirk2005

    dirk2005 LI Guru Member

    RV042 wan speed improvement !!!!!

    I took toxic's advice and set the mtu from auto to to manual 1500.

    What a BOOST went from 3100 kb/s to 11972 kb/s

    I had done everthing else from factory reset, firmware update etc to changing the cable from the modem to the RV042

    Thanks for the advice :thumbup:

    Is there anyway possible to restrict the bandwith to certain ports ?

    next is to get the VPN working
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice