RV08 Throughput slowness

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by neverl8, Apr 26, 2006.

  1. neverl8

    neverl8 LI Guru Member

    I have two RV082. One at work with a 1meg up/1meg down connection. Second RV082 is at my house using Comcast cable. My other linksys router, I was able to produce upward of 8meg download but after swapping out to the RV082, I'm only getting about 1meg download. I have not set up the VPN tunnel or anything yet. Pretty much default. Swapping back to my old linksys router brings the speed back so I'm pretty sure its the RV082. I've did a little search here and some mention setting the MTU at 1500 which I've tried to no avail. I'm using the newest bios from the Linksys support site. What's going on??? thanks in advance, Dave.
  2. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    You've manually set your MTU?

    I've setup quite a few RV0 units...clients love the stability and speed. I've not been able to test them on any connection higher than 10 megs..but even with old old firmware, I think they originally benched around 20 megs of throughput (by an idependent test doing many brands of routers). This new 1.3.2 is supposed to peg the 200 meg max speed of FE now.

    Myself...I have Comcast at home...I swap my home setup all the time. I have a Motorola 5120 modem....what unit are you using?

    I've benchmarked by home setup using a PC directly into the modem, I hit about 6200 down, 340 up. Using the RVO82...I still peg those same numbers, along with my ISA2K4 box or my IPCop box. I start using one of the other older routers I have..wrt54g, or befsx41, or a Belkin or Nutgear, etc...I start to creep down a bit..6100 or 6000 or somewhere in between.

    So what modem do you have? Have you done a factory reset on your unit? And make sure you manually set your MTU to 1500.
  3. Webmeisterus

    Webmeisterus Network Guru Member


    Firmware 1.3.2 cuts my WAN2LAN throughput roughly 5 fold, too (around 1.3 Mbps). Absolutely NOTHING has been effective in my case to achieve normal downstream throughput with this new firmware.

    However, reverting to restores normal throughput.

    I am interested in seeing another person affected by this loss of throughput, though. I origninally reported the availability of this firmware on this and other forums, along with my caveat about the throughput issue, only to have noone else have a similar experience. I assume, therefore, that we have other commonalities in our hardware and/or ISPs that cause us to experience this issue, while others do not.

    I receive cable service through InsightBB, which is half-owned by Comcast, your provider. Unfortunately, others on Comcast do not exhibit the throughput issue, so I doubt that this alone is the culprit. What is your cable modem? I use a Linksys BEFCMU10 v4 with Firmware Version:

    I would like to know what causes this issue, but have the luxury of not needing the RV082 as my primary router. In your case, though, if you downgrade your firmware to, I'm confident you'll restore your expected throughput.

    Hope it helps.
  4. Toxic

    Toxic Administrator Staff Member

    can you try testing the selective acks feature is enabled on your OS and then check that the RV082 is not blocking them? i found the WAN throughput was very slow with the rv042 and selective acks are being blocked by the RV042.

    try testing the tweak test here:


    then look to see if selective accks are ON. if the report says OFF the download the DRTCP from the link provided in the report page. the check to see if they are actuall enable or disabled. if they are enabled then the rv082 is also blocking the Selctive Acks.
  5. Webmeisterus

    Webmeisterus Network Guru Member


    As it turns out, your suspicions are confirmed. The RV082 with Firmware 1.3.2 does seem to be blocking Selective Acks. I wouldn't have looked for this particular problem in a month of Sundays, since EVERY previous version of firmware has not exhibited this behavior.

    Good catch!
  6. Toxic

    Toxic Administrator Staff Member

    I'll PM you m8
  7. neverl8

    neverl8 LI Guru Member

    OK, I'm a dummy now. How would I make adjustment in my RV082 to enable the selective ACKs?
  8. Toxic

    Toxic Administrator Staff Member

    you can't :)
  9. Webmeisterus

    Webmeisterus Network Guru Member


    Although you can't make Selective Acks work under firmware 1.3.2, you CAN install firmware, which will restore the ability of your RV082 to pass Selective Acks.

    Hope it helps.
  10. neverl8

    neverl8 LI Guru Member

    Thanks all. Well that kind of suck that the newer update makes things worse for me. As I've mentioned above, my work throughput is not really affected as I'm only 1meg up/down, but at home, ouch. Any issues at all with me connecting the two RV082 with differenct version of the firmware I should watch for??

  11. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Neverl8...which modem(s) do you have?

    I've upgraded around 6 of my clients rv082's..as well as my own at home...have not seen a drop in performance at all.

    Various Speedstream modems on my end, one Elastic Networks, one Netopia, and on cable....Motorola 5100 and 5120's (I use a 5120 at home)
  12. neverl8

    neverl8 LI Guru Member

    I have the Motorola SB5100/5120 (its one of those from Comcast). Didn't get a chance to downgrade the firmware last night to test out the speed. Will do so tonight to confirm the test. Real noticeable difference in speed from a standard linksys router. I've tried speed test from speakeasy to dslreport and all shows the same slow download speed. I even tried those test from several other PCs to make sure its not my main PC that is cause.

    Will post tomorrow after the downward firmware.

  13. Webmeisterus

    Webmeisterus Network Guru Member

    Using version and varying only the setting of Selective Acks (SAs) my download results are as follows:
    testmy.net speakeasy (Washingtong, DC)
    SAs ON > 6.5 Mbps > 11.4 Mbps
    SAs OFF ~ 1.25 Mbps ~ 1.3 Mbps

    It's irrefutably clear that SAs being used or not makes an enormous difference in my case. Of course, this is on InsightBB cable and YMMV.

    Thanks to d_l over on the broadbandreports >> Linksys forum for the idea of testing with SAs ON/OFF.

    Hope it helps.
  14. Toxic

    Toxic Administrator Staff Member

    if you disable selective acks (or cannot enable them) Webmeisterus then afaik your RWIN will need to be much lower.

    If you have a large ReceiveWindow the a packetloss will require a much larger packet (due to RWIN) to be resent. try lowering the rwin setting and test again

    afaik this is how it works...
  15. Webmeisterus

    Webmeisterus Network Guru Member


    I agree with your assessment if you assume that my RWIN is large, but, in fact, my RWIN is only 64240 and I don't use any TCP 1323 options, i.e., Scaling or Timestamps. I doubt sincerely that I need to reduce the RWIN beyond its current setting, but for the heck of it I'll cut it in half and see what happens.

    Note: Edited to correct mistaken reference to MTU, instead of RWIN. Doh!
  16. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    64240 is a pretty hairy MTU. You talking about TCP Receive?

    I can't replicate any performance drop like you have....I run 1500 MTU, with TCP Receive set at 256960....which is good for a 6 meg pipe, 512920 would be a second choice for TCP Receive.

    And seeing that I can't replicate that sort of performance drop with any clients either...and they're running pure non-tweaked Windows...

  17. Webmeisterus

    Webmeisterus Network Guru Member

    Doh! Yep, I should have typed RWIN instead of MTU. I suppose I'll edit the original post to avoid confusing anyone else. My bad.

    However, the central point of my posts remains the same. Since my particular connection loses packets relatively badly, I need SACKs to compensate without a drammatic loss in throughput. According to BBR's Tweak Tester, I get 100% transfer efficeincy with SACKs and 94% or so without SACKs -- 6% packet loss is ENORMOUS. The packet loss, itself, is likely due either to the fact that my provider is in the process of changing backbone providers (ATT&T to Sprint), or to saturation/super-saturation of the node that services my location.
  18. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    What happens if you raise your TCP Receive to something more standard for a 6 meg pipe...such as 256960....or 512920.

    Maybe you mentioned it up above...sorry if I missed it...but have you run any TCP optimizers?


    I run my home system, and office systems, tweaked...however I don't tweak my clients systems...and they don't see a drop in performance. While I agree SACKs can have a change in performance, I remain that it's a small change...not a huge hit like you're experiencing.

    ...I feel something is screwy with your TCP stack. Maybe run a TCP/Winsock repair utility

    Then maybe try our SG TCP Optimizer.
  19. Webmeisterus

    Webmeisterus Network Guru Member


    I appreciate your concern, however my RWIN, MTU, tweaking settings (or lack thereof) are simply not the issue in my case.

    I had orignially wondered about my TCP/IP stack and reset it via the command line to be certain that the playing field was level. Then re-tweaked as usual. I did these things before my initial post.

    As for the effects of SACKs, in my case the anecdotal evidence is overwhelmingly convincing. If I use another router or v1.1.6.14 firmware on the RV082, I have normal downstream throughput with SACKs enabled and at least a five-fold decrease in downstream throughput with SACKs disabled. In short, my connection needs SACKs.

    As I've alluded to previously, and will now try to make crystal clear, I know that this drammatic effect of SACKs is peculiar to my cable connection and to relatively few others. For whatever reason (ISP backbone transition in progess or my node is saturated), my cable connection loses packets in relative droves (on the order of 6%). In my case, SACKs are the only thing that keeps the lion share of my available bandwidth from being wasted on retransmits.

    To me, since I do not need to rely on the RV082 using v1.3.2 firmware as my primary router, this is simply a matter of professional curiosity. At this point I am more interested in why my incidence of packet loss is so high.

    Thanks for the input!
  20. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    I've seen port negotiating issues between WAN ports of the router, and the ethernet port of modems....I've seen seen this specific to a version of firmware. Often sticking a hub (or a swith if you don't mind resetting the MAC"..can help...I've actually come across a situation where this helped...and it was the ISPs suggestion.

    I have not worked with that particular Linksys cable modem yet...you'd think they'd avoid a conflict between their own brand...but... /shrug

    Maybe have your ISP re-provision your modem?

    So have you tried a more standard receive window? When I get home tonight, I'll try crippling my PC and running a wee tiny 64,000 on it...see if the SACKs kill me more with that low setting.

    I literally just got done upgrading another clients RV082 a few minutes ago...at a small school. Now they are located on an island....they have a horrible DSL service out there...(I have quite a few clients out there..they're all on that same horrible DSL) which is shot across 11 miles of ocean to mainland via satellite. If there's ever an example of flakey broadband with lots of packet loss...it's this one. Their DSL is even backwards when it comes to bein asymmetrical...they're all under 200k downstream, and almost 1000k upstream. :wallbang: tested before upgrade, and after...and they went up a whisker...probably just since it's been at least 6 months since that router had been rebooted. (last summer I'd gather)

    Just most puzzling why it's dropping the perf of a handful of peeps....I'm getting curious what the issue might be.
  21. neverl8

    neverl8 LI Guru Member

    Another puzzling issue

    Ok, after the the firmware downgrade, it seems everything has settled down. Am able to VPN nicely. Both remote desktop and run command and ip to a workstation on the endpoint correctly. New problem is that at home, when I do multiple download, it freezes one of the connection, then the other??? My old Linksys router before the swap, I'm able to do something like 20 download sessions at a time, now even one causes it to freeze at times. Am I missing a setting somewhere?

    MTU set at 1500
  22. d__l

    d__l Network Guru Member

    Webmeisterus, had you used the SpeedGuide.Net TCPOptimizer on your computer's settings prior to upgrading your RV082 to 1.3.2?

    I tried allowing that program to set my system to its "optimum" settings for my 6016/768 DSL line. I really didn't notice any improvement or problems using my SX41 router. Then I installed my RV082 with 1.3.2 firmware and found that my throughput was cut to 10%!!!

    Yes, instead of about 5000 kbps download thoughput on Java-based speed tests, I was seeing 500-600 kbps. This speed slowdown was also seen when testing an FTP download from the Optimum Online download test site so it wasn't some Java quirk.

    So I rolled back the "optimizations" (thankfully it allows this after scewing up my downloads) to my DrTCP optimizations and all was good. Normal 5000 kbps downloads are now the standard.
  23. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    I run with it all the time...and I gained speeds. Pre-1.3.2 firmware, and post 1.3.2 firmware. About 5900 down virgin TCP, 6200 down SG Optimized TCP. Did you restore you TCP settings to virgin state before going from the DrTCP to the SG one? Or install the SG Optimizer on top of a previously DrTCP modded stack?
  24. d__l

    d__l Network Guru Member

    It was on top of DrTCP settings. I simple accepted the "optimized settings". But I doubt the settings in common with DrTCP were the ones that affected the speeds.
  25. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Bingo..cause of conflict. It's like mixing several antivirus programs...they get in the way of each other.

    SG TCP Optimizer assumes all other values are default....in order for it's applied values to operate most effeciently.

    I would apply this logic to any tweak program, wether it's ours, or cablenut, or DrTCP, etc. Fully remove the other utilities first...restore to default..then apply your next one.
  26. d__l

    d__l Network Guru Member

    Ah, but TCPOptimizer doesn't say anything about restoring to default Windows values before using the Optimal Settings choice. Plus DrTCP doesn't install anything into the registry. It only changes a few settings at most for the TCP/IP components in the registry.

    Plus in my case, only two items in DrTCP were set to non-default settings. Several weeks ago I had used a command line restoration of all the TCP/IP components of the registry and had to use DrTCP to reset my RWIN and Windows scaling factor to non-default. All other registry items modified by TCPOptimizer should have been default.

    Most likely the problem with TCPOptimizer came from the Advanced settings area. I do not believe the large RWIN set by TCPOptimiser is the cause of the problem as I currently have the RWIN set to to about half the recommended value of TCPOptimizer without problems.
  27. Webmeisterus

    Webmeisterus Network Guru Member

    I've used just about every optimizing tool at one point or another, including the SG TCPOptimizer. However, upon having the remarkable throughput loss with firmware v1.3.2, I reset my TCP/IP stack using good ole netsh commands. No dice.

    After viewing your latest posts on this issue, I reset my TCP/IP stack again, reset the RV082 v1.3.2 to factory defaults, reconfigured the beast, and looked at the RV082 downstream throughput. Still stinks.

    Tweak up the settings using RWINs of 64240, 128480, 256960, 513920 and the download rates remain pitiful.

    As before, if I downgrade the firmare to or use a different router, my download speeds return to normal -- even with the default TCP/IP stack. Of course, I do a bit better yet after tweaking.

    In my case it seems crystal clear, v1.3.2 firmware absolutely kills my download throughput. Interestingly, though, upload throughput has never been affected.
  28. d__l

    d__l Network Guru Member

    Oh well, sorry that didn't help you at all. In my case, there clearly is something about the RV082 v1.3.2 and the TCPOptimizer settings that do not get along. As I said before, I saw no problems when using my SX41 with those optimized settings.

    I actually watched the slowed Java speed tests in action with Netmeter. The results were always the same. First the download would spike to full speed for one second. Then the speed would plunge to several hundred kbps (I don't have an exact value on that) for 10-15 seconds. This slow speed was very uniform as if was being throttled. Then the speed would jump back to full speed to complete the test.

    The FTP downloads looked similar except I never waited long enough for the final jump up in speeds. It looked as though it was going to take much longer than 10-15 seconds if would happen at all.
  29. Toxic

    Toxic Administrator Staff Member

    If the MTU is set to Auto it uses 576 as the MTU. please set to manual and use 1500 for cablemodems and 1492 or lower for ADSL.
  30. d__l

    d__l Network Guru Member

    All my Linksys routers are set to Manual 1492. That is the very first thing I do to when configuring a Linksys router. No, that wasn't the problem.
  31. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Correct..it doesn't. Not all antivirus programs warn about having others installed being non-optimal either. //shrug//

    I know they don't "install" things into the registry, it's the subtle changes that they do...most of them allow a backup to be made before restoring.

    Each "tweak" programmer had their own opinions on what values to change to gain performance...I've played with them all...they all perform about the same for me. Philip (from Speedguide) was sort of the grandfather of these tweaks...pretty much the first one out there when broadband first started rolling out...he's a firm believer in RWIN values.

    Sometimes all the programs have the same effect on some users, other times...due to the vast nature of varying PCs out there all in various states of health, with a whole plethora of environmental changes out there (different ISPs, different routers, incorrectly setup routers, hosed winsocks from adware, etc etc etc)...some work better than others.

    Hit the tweaking forums...you'll always see someone stating "So and so's tweaking program worked much better for me".

    Assuming all the routers you work on are on PPPoE DSL if you're setting them all to 1492...but if on bridged DSL or cable..that's not optimal.
  32. pieterg

    pieterg Network Guru Member

    I recently upgraded my firmware to 1.3.2 and my max speed was suddenly only 1.5 - 3 mbit whereas my internet-connection-line (cable) is 20mbit.

    Can someone give me a link to the, cause I don't find that on the net. With, I had no problems with speed.

    Tnx in advance ;)
  33. Webmeisterus

    Webmeisterus Network Guru Member

  34. pieterg

    pieterg Network Guru Member

    Thanks, it worked out fine ;)
  35. zorglubxx

    zorglubxx Network Guru Member

    I have 2 20mbit internet connections (1 ADSL and 1 Cable) connected to my RV082 and if I do multi-threaded downloads I can get up to 35 mbit throughput which is very nice.

    My Windows PC is fast and so is my PowerBook, however I also have a KiSS networked DVD player and now accessing the internet through it is excruciatingly slow. I wonder why this is. I have manually set my MTU to 1500 and also tried 1492 but no change. When I didnt have the RV082 and my KiSS player was connected to my ADSL router, it was really fast.
  36. aver5

    aver5 LI Guru Member

  37. Toxic

    Toxic Administrator Staff Member

    the 1.1.x.x firmwares have a slower throughput.

    have you tried v1.3.3.4 beta?
  38. aver5

    aver5 LI Guru Member

    Yes But It sound like make a CPU overload on my RV082 :
    web access on Admin GUI very slow and low low bandwith .....
    are you sure that 1.3.3.xxx ils working on all RV082 hardware release ?
  39. Toxic

    Toxic Administrator Staff Member

    There is only one hardware version release v1.0 on the rv082 btw.
  40. aver5

    aver5 LI Guru Member

    Thank's for your answer I will retry But with an facory reset just before ....

    Best regards
  41. Toxic

    Toxic Administrator Staff Member

    Reset before AND after just to make sure. Once you start setting up, use a manual MTU setting:

    DSL: 1492
    Cable: 1500
  42. JeremyH

    JeremyH Guest

    Apologies for the thread necromancy from a neewbie but I had the same issue with the older firmware (bandwidth limiting), 1.3.5 seems to of sorted that out ...... though .....

    Listening to a fair bit of internet radio, I seem unable to get shout cast to come through consistently.

    Using the balanced connection opposed to WAN2 backup, so I'm guessing its switching back and fourth between the connections and cutting the stream.

    I've tried Protocol Binding the ports (various) it's coming in on to to one WAN though it's not solving it.

    Anyone else getting this, know of a fix or what I'm doing wrong ?

  43. PraL

    PraL Guest

    RVO82 with Speedstream

    I am looking for the best way to connect an ADSL Modem/Router to the RVO82. I have the IP of the RVO82 set as and the ADSL as and it is connected to the Internet port, but I would like to access an IP camera at over the internet, setting the DMZ on the RVO82 to, but need the ADSL's external IP to be directed to the RVO82.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice