RV082 and Large Downloads

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by X, Jan 26, 2006.

  1. X

    X Network Guru Member

    Using Charter Cable Internet; motorola surfboard 5100

    Router Firmware:

    Large downloads (10MB plus) will stall out at random times. I have tried different MTU settings, from 1350 to 1500, with no effect. Hooking a computer directly to the cable modem there is no problems with downloads of large size.

    Any Ideas?
  2. X

    X Network Guru Member

    Follow up:

    I put the RV082 behind a different router and the problem went away.

    I talked to Linksys Tech Support to no avail. They recommend I send it back, but I actually have EIGHT of these things in other locations, and they apparently ALL do the same thing.

    However, the other locations do not do LARGE file downloading, so the problem is not that apparent for them.
  3. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Try putting a small hub or switch between the WAN port and your surfboard. I run mine (082 with same firmware version) behind a 5120 modem, 6 meg pipe that I bench at 6.2 megs with...and it runs flawlessly. I have several 082 and 016 models with clients behind other 5120 modems and various DSL..no issues. Just curious if something odd in compatibility between the 5100 ethernet port and the WAN port here.

    And...manually lock down the MTU...should be 1500 on cable. Don't let it auto-detect MTU...I always set it manually. I believe if I leave the MTU on my 082 set to auto..it will set itself to 574 or 576 or somewhere around there.
  4. pablito

    pablito Network Guru Member

    Anyone else using the RV082 with PPPoE and VPNs? Running the latest 1.3.2. VPNs have a problem with stalling on anything larger than 1K upstream. Downstream is fine but upstream keeps stalling. The VPN stays up and I can still initiate another connection (sftp, etc.) over the same VPN but the stalled connection has to be killed.

    I've tried all manner of VPN specs but no difference. I've manually set MTU to all kinds of values but no difference.

    If I put the WAN port on a non PPPoE connection it works fine. But at my house I'm stuck with PPPoE DSL with an old Speedstream modem. I could put a router in front but that defeats the purpose and complicates port forwards.
  5. pablito

    pablito Network Guru Member

    A quick followup. Looking at an Astaro firewall on the same line where I have trouble I see these MTU specs:
    eth0 (internal) 1500
    eth1 (DSL before PPPoE) 1500
    ppp0 (DSL) 1492
    ipsec0 (over DSL) 1420

    I wish I could see the same data on the RV082. The VPN works great on the Astaro but not so good on the RV082 from a PPPoE line.
  6. d__l

    d__l Network Guru Member

    The getif program: http://www.wtcs.org/snmp4tpc/getif.htm lists these for my RV082:

    admin   oper    type     MTU        descr.
    1           1         24      16436     lo
    1           1         6        1500       ixp0
    1           1         6        1492       ixp1
    1           1         23      1492       ppp0
    1           1         23      1432       ipsec0
    I use PPPoE DSL.
  7. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Curious which older Speedstream modem you used. Out of the RV0 units I have on older modems, most are RV016 models on 5260 units. A few weeks ago I just setup an insurance firm on an RV082, using their 5360 (running bridged, not router), on a 6 meg DSL.

    I haven't file transfered with that one though...have with the 016 models on the older modems.

    When I had DSL at home, my 082 was on a 5260, however bridged DSL, not PPPoE. Back a while..like 3 firmware versions ago.
  8. pablito

    pablito Network Guru Member

    It is the boxy 5360.
    I took the RV08 to a friend's house running PPPoE on a newer (can't remember the name but not Speedstream) modem. The RV worked fine there including VPN file xfers up and down.

    So I think I have a modem issue or an ISP with problems. I haven't looked at changing the modem config, didn't even know I could. If I can maintain my public (static) IP at the firewall and solve my problem I'm all for it.

    Even though I have static IP I have to configure a standard PPPoE and it returns my assigned IP. So the 5360 can be configured to do the PPPoE and the firewall does real ethernet (and maintain my IP)? googling now......

    There are a few bugs in the Linksys firmware that I hope gets fixed someday. This could be a decent router/firewall. Would love to see a decent 3rd party package if it brought more flexible features for the routing/VPN savy.

    Thanks for replying!
  9. Toxic

    Toxic Administrator Staff Member

    I have the RV042 on 10Mbps cable, and have no problems.

    have you tried the 1.3.2 firmware? it does have a better performance boost.

    RV082 Firmware v1.3.2 Release Note

    There are two firmware systems used by RV082. One is firmware v1.3.x which uses the newer Intel CSR1.2.2. The other is firmware v1.1.x which uses the original Intel CSR1.1. The look and feeling are quite similar, however, the v1.3.x firmware provides more features and better performance than v1.1.x. For example, the NAT firewall throughput has reached 200Mbps (bi-directional wire speed) and the IPSec throughput (3DES) has a maximum over 90Mbps. You can upgrade or downgrade the firmware on your RV082 device whenever you want. But like before, downgrading firmware will restore the configuration settings to factory default.

    New Features:

    1. Support VPN (IPSec tunnel) Backup functionality.
    Mechanism: When the dead-peer-detection (DPD) mechanism detects that the primary VPN is no longer available, the VPN backup mechanism will be activated and try to establish a VPN connection via a user-defined WAN interface. The configuration is in the advnaced setting of Gateway-to-Gateway VPN. See the online help for more information.
    2. Support Split DNS functionality.
    Split DNS in IPSec is used to provide DNS service over a VPN tunnel where DNS server is located in the remote security subnet.
    3. Support AES encryption for IPSec
    4. Support DHCP-relay
    5. Support DNS Local Database
    6. Support more PPPoE Keep-alive settings including retry times and redial period.
    7. Allow DDNS Host Name to have only 2 fields such as abc.net
    8. Support PPPoE Service Name option.
    Service Name is provided by your ISP. If the Service Name is not required by your ISP, please leave this field blank.
    9. Protocol-binding supports Destination IP Range Class A/B/C.
    10. Support Static IP/MAC address binding for DHCP server.
    11. Support the option-61 �client-id� in DHCP Client for some customers in Korea.
    12. Allow the Protocol Binding to bind ICMP when "Bind All Traffic" is selected. Remark: The Protocol Binding can bind UDP/TCP without problems. But in earlier firmware, it cannot bind the ICMP packets when "Load Balance" is enabled. This firmware solves the problem and binds the ICMP packets to the user-specified WAN interface.
    13. Implement new PeanutHull specification. In this new spec., the PeanutHull service provider provides new domain name HPH024.ORAY.NET for Linksys use only. The previous domain name ph001.oray.net won't be used in RV082 product.
    14. Allow administrators to have IPSec Remote Group Network covering the RV082's LAN IP. Remark: In earlier firmware if LAN IP is and IPSec Remote Group Network is, the RV082's Web UI will not be accessible once the "Save Settings" button on the VPN setting page is clicked.


    1. Increased the aging time of QQ from the original 1 minute to 8 minutes. The purpose is to solve the QQ problem in China where incoming messages might be dropped occasionally.
    2. Fixed the PPPoE reboot issue that may occur when configuring PPPoE for the first time.
    3. Fixed the issue with booking a flight on www.usairways.com.

    1.3.2 RV082 firmware
  10. pablito

    pablito Network Guru Member

    Hello, the RV came with the 1.3.2 firmware I even did a factory reset and reflash to be sure.

    I have no problems with non PPPoE (cable modem, non pppoe DSL etc). And after last night I found that it worked perfectly on a different DSL network/modem.

    The problem seems to be my old 5360 bridge. I googled around and there are no config options, it is a bridge with no options.

    I need to find a new modem. Now to find one for cheap enough. I blew all the money on the RV and can't use it yet. Actually it works fine except for upstream over VPN. Upstream over the normal internet is fine however.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice