RV082 Certificate Confusion

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by fatpACKet, May 19, 2007.

  1. fatpACKet

    fatpACKet LI Guru Member

    I have the latest QuickVPN client installed with 1.3.5 firmware on the RV082. I exported the certificate for client from the RV082 and copied it into the same directory as the QuickVPN executable on the remote client. The .pem file listed in the QuickVPN directory is the same as the file listed as the current certificate in the routers config (albeit with "_client" appended).
    I am still greeted with the message that the servers certificate cannot be found and have the option to continue without encryption. This is a bad thing.The connection continues fine if I proceed
    Am I missing some critical part of the process to sucessfully import the routers certificate to the remote client pc's?
    I have tried using the mmc certificate snapin to import to ssl store with no success. I have generated a new certificate and repeated the process with the same results.
    Would someone be kind enough to point out my ignorance?
    As an aside, I am curious as to why the VPN client install includes what appears to be a certificate from a WRV200.

    Thank you all in advance
  2. fatpACKet

    fatpACKet LI Guru Member

    Well folks, it seems after 2 lengthy calls to Linksys 2nd level support, the certificate issue was resolved with the 1.1.2 beta version of the QuickVPN client software downloaded from this site. I had hard reset the router this AM with the 1.3.5 firmware installed and attempted to regenerate and re-export a new certificate to a clean installation of QuickVPN 1.1.00. I immediately received the "certificate not found" message with the prompt to diconnect or continue anyway. If i continued i could browse internal resources but not ping internal machines. The ping issue turned out to be the issue with Windows firewall dropping all ICMP packets regardless of whether they had been specifically allowed. This was resolved by installing kb 889527. I found that little gem while reading the enhancements for QuickVPN beta release 1.1.2 on this site. So, while speaking with the tech who asked me to regenerate a new certificate on the router and re-export to the client, (I had already done this enough to know it wasnt going to work) I decided to try a clean install of the beta version of the client and lo and behold it all worked flawlessly. The beta version of the client correctly passed the cert and I can ping internal machines on the lan.
    I want to thank all of you who contribute to this site. I am eternally grateful for your cutting edge support.

  3. EugeneD

    EugeneD LI Guru Member

    I upgraded my firmware to the current version.
    Then, I generated the certificate and used the export utility to copy both certificates to the appropriate directory on the remote PC Quickvpn directory in program files folder.
    Then I created the login user account in VPN clients page and set the account to active.
    I read in the notes that you don't want to use the copy command to transfer the certificate to the QuickVPN folder on the remote computer. Only use the export utility at the bottom of the page. be sure its the client certificate that you are transfering into the remote folder

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice