RV082 dropping connection with Entourage/Exchange

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by dpbklyn, Aug 18, 2006.

  1. dpbklyn

    dpbklyn LI Guru Member

    I am new to these routers and this forum. I have limited experience with routers in general so please be gentle.

    We are a small business using a hosted exchange server. We connect to the internet (and the server) using an RV082 and 2 "load balanced" DSL circuits.

    We have one Mac user in the office using entourage. We also have a couple of PC users connecting with Outlook. The Outlook users connect to the Exchange server without a problem at all. The Entourage user connects then is disconnected throughout the day and is asked for her exchange password every 5 or ten minutes or so. This router was configured by someone whose knowledge was more suspect than mine, so I decided to do some experimenting.

    In another office that is connecting through an RV016 we had a similar issue and as a test I connected them through Linksys BEFVP41 configured as it came out of the box. This office ran perfectly without any issues. Stupidly, I assumed that if I started fresh, and set the RV082 to the factory settings I would be able to configure the forwarding, firewall, etc. without issues.

    I have issues. Before and since resetting this router to factory settings, we have experienced the problems with Entourage. I have disabled the firewall completely (HTTPS is set to ENABLE, Multicast Pass Thru is DISABLE and MTU is set to manual (1400). There is nothing in the port triggering or Port Range forwarding lists. All other setting are factory defaults.

    I have contacted our exchange host, Linksys and Microsoft about this issue and I have not been able to resolve it. Please excuse if this has already been asked, I couldn't find anything on these forum.

    Any help would be hugely appreciated!

    Thank you,

  2. pablito

    pablito Network Guru Member

    A quick test you might try is to disable load balancing. Set it up for Smart Link Backup. If that solves the problem then the issue is the type of load balancing the RV is using. You are likely hitting the remote server appearing to come from different IPs (WAN1/WAN2) causing the password prompts. (Round Robin Load Balancing)

    There are ways to correct that but let's see if that is the problem first.
  3. dpbklyn

    dpbklyn LI Guru Member

    This seems to have worked. How can I configure the router to be load balanced?

    Thank you,

  4. pablito

    pablito Network Guru Member

    The default method of balancing is Weighted Round Robin which most of the time means you'll flip between WAN1 and WAN2 and for your needs is a problem with Entourage.

    Suggest using Protocol Binding options that should be at the bottom of the Sys Management screen. There are a lot of ways to set that up. I don't know Entourage but let's assume it is a POP3 service. (if it is a unique service then even easier to setup)
    First thing I would do is to find out the IP of the server. Likely it is a range of IP addresses (whois tells you a range).
    Service:: POP3 <or whatever service>
    Source IP: <leave as default, the whole internal net> is good enough unless narrowed to that one user.
    Destination IP: <set to the range of IPs of the Entourage server farm>
    Interface:: <whichever interface you prefer>

    This will force that service to that server to run over the specified interface leaving normal load balancing for everything else.
  5. dpbklyn

    dpbklyn LI Guru Member

    One Final Question...

    Thank you for your help on this so far...

    In order to input an ENTIRE subnet in the protocol binding information, is it OK to leave the last octet set to '0'?

    Thank you,

  6. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    It's basically Outlook for Apple Macs....comes in the Office for Mac suite instead of Outlook. Does have Exchange support..or POP3, so to be treated pretty much just like Outlook.

    I've not setup Entourage to do RPC over HTTP like Outlook 2K3 supports.

    But it does bring to mind...some RPC behaviour that I did get to experience a few weeks ago, going over thin connections.

    I am curious why your MTU is set so low....

    Back to the RPC behavior...you'll notice a few threads about the newer firmware on the RV0 series having performance issues, related to SACKs not being supported correctly. I had not run into this issue on my setups...until recently, a client that was on a remote island with a very odd broadband setup...we had a VPN tunnel setup to another location on mainland. Very high latency connection. SACKs has more of an impact on higher latency connections. I had issues with active directory running across this tunnel..through troubleshooting for about 8 hours had found that the issues I had were related to RPC..which has issues with some IPSec tunnels over higher latency. I upgraded both routers to the BETA firmware you'll see on this site..and within 5 minutes everything worked like a charm.

    I'm curious if your MAC is handling things a wee differently than the Windows boxes..where having either MTU be off, or SACKS being off..well...perhaps
    *Setting MTU to 1500 if bridged DSL, or 1492 if PPPoE DSL would cure it..
    *Upgrading to the BETA firmware that supports SACKs better would cure it. I upgraded both routers which migrated my settings just fine. Or wait a little bit til the official version comes out.
  7. dpbklyn

    dpbklyn LI Guru Member

    Though Entourage functions like Outlook for Macs, the way it functions really isn't like Outlook at all.

    When Outlook connects to the server it maintains its connection, when Entourage connects, it disconnects and re-connects throughout the day so it will randomly chose a path when you have your router set to load balanced mode. This will require the user to login to the server throughout the day even though the application has remained open (this was the problem I was having).

    Also, Entourage uses multiple protocols to connect, including IMAP, DAV and HTTP and LDAP and POP3. Entourage is NOT an elegant solution to connect Macs to an Exchange server, but it is the only one out there...

    My MTU was set low at the suggestion of Linksys during trouble shooting. They thought that the problem was with the firewall. I never changed it back once we figured out the real problem. I have set it back to Automatic.

    Thank you,

  8. dpbklyn

    dpbklyn LI Guru Member


    Is the above how I input and entire subnet?

    Thank you,

  9. dpbklyn

    dpbklyn LI Guru Member


    Anyone at all?
  10. sterner

    sterner LI Guru Member

    For the source IP, yes, use 0 as the last octet to include the whole subnet.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice