RV082 PPTP won't work

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by mr-linksys, May 30, 2005.

  1. mr-linksys

    mr-linksys Network Guru Member

    I'm trying to establish a VPN between 2 offices, using 2 X Linksys RV082. One site is working (using a provider with static IP). Had no problem setting this up.

    The provider on the other site (Dutch KNP mxstream) is using PPPoA to setup a connection to their ADSL network.
    I'm using a Speedtouch 580 ADSL modem/router.

    According to the instructions I should setup my Speedtouch modem as bridged and setup my RV082 as PPTP on the WAN.

    Tried everything but didn't work. I contacted the Linksys helpdesk and we went throught all settings of Speedtouch modem & RV082. Still didn't work.

    Linksys thought it might be the Speedtouch modem, and told me to replace it. They couldn't tell me which modem would actually work. Couldn't even tell me which modem from their own brand would work. I asked them to find out, and they came back to me the next day and told me that the RV082 has a firmware problem and it won't work at all with PPTP. At the time we were testing we were using firmware 1.6.11.

    I just can't imagine that I'm the only one having this problem.

    Is there anybody who can help me out? I can't change from provider or anything, and I need this VPN tunnel urgently!

    Thanks and regards,

  2. TazUk

    TazUk Network Guru Member

    I would have thought Automatic Configuration - DHCP would have been more appropriate :?
  3. RockyRouter

    RockyRouter Network Guru Member

    I was researching how to do this on the Qwest DSL forum on Broadbandreports.com. Rather than PPTP, the consensus there is to set the DSL gateway to bridge mode, then set the router to PPPoE mode, and type your DSL username and password into the router. It's not a sure thing, however, since apparently not all DSL providers are compatible with PPPoE.

    If that doesn't work then the 2nd option is to configure your DSL router for DMZ, and put your Linksys router in the DMZ, a so-called double-NAT configuration.

    Good luck!
  4. DocLarge

    DocLarge Super Moderator Staff Member Member

    Nice idea, Rocky, but the only problem when bridging a PPPoA device is that now, the device behind speedtouch adsl modem/router (RV082) needs to manage the PPPoA connections, so this is not going to work if the device is only capable of connecting via ethernet, which is the case with the RV series routers. I ran into this issue when I got over to England a few months ago and thought by buying and bridging an ADSL2MUE PPPoA router/modem device I'd be able to use my WRV54G (ethernet device) initially (which failed badly because of the "exact" same reason we're discussing...).

    This is one occasion where Linksys is actually right, unfortunately. Your other site is probably up and running because it's either using PPPoE, Cable Modem, or an ADSL modem that's capable of an "ethernet" connection. Your speedtouch ADSL Modem/Router is "only" capable of utilizing PPPoA connections which (again) means you are "shit out of luck" trying to get an ethernet device (your RV082) to connect because it (Speedtouch adsl modem/router) is configured to make the connection and route all of the packets and is a different broadband signal.

    So, the solution for you is what TazUK suggested for me which is get an adsl modem that's capable of making an ethernet connection. Taz had suggested a model from Dlink, but I couldn't find it due to Dlink phasing it out but I found another brand that I'm using with my wrv54g right now; the x-modem CE from www.adslnation.com. A device such as this or similar to it is the "only" way you're going to be able to use your ethernet device over an ADSL connection:



    This device kicks ass by the way. Once you get yourself an x-modem ce or a similar device that makes an ethernet connection over ADSL, just follow the instructions in the quickvpn setup guide for vpn connectivity and you're in the "hi-zouse!"

  5. RockyRouter

    RockyRouter Network Guru Member

    I can't take personal credit for the ideas, and I have not tried them myself as of yet, but they have apparently solved this sort of problem for others. Here are a couple of links to more detailed explanations of what I was trying to describe. These links come from the Qwest DSL support forum on Broadbandreports.com, and so the hardware and ISP configurations described may not relate to other situations without some revision, if at all. YMMV! :)

    How Do I Connect My 701 In Bridged Mode?

    How Do I Put A Router In My 701g's DMZ?
  6. DocLarge

    DocLarge Super Moderator Staff Member Member


    just as I thought. If the ISP "does not" allow PPPoE, which is the case in this particular situation, it won't work.

    *Sigh* ADSL is some bullshit, however, Rock, if it PPPoE were allowed, without a doubt, your scenario would work :) .

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice