RV082 v1.3.3.5 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Sep 23, 2006.

Thread Status:
Not open for further replies.
  1. Toxic

    Toxic Administrator Staff Member

    Ok guys Linksys has given me authorisation to release this as a beta.

    The main difference is the firmware now supports Multiple Subnets from network page.

    RV082 Firmware v1.3.3.5 Release Note

    There are two firmware systems used by RV082. One is firmware v1.3.x which uses the newer Intel CSR1.2.2. The other is firmware v1.1.x which uses the original Intel CSR1.1. The look and feeling are quite similar, however, the v1.3.x firmware provides more features and better performance than v1.1.x. For example, the NAT firewall throughput has reached 200Mbps (bi-directional wire speed) and the IPSec throughput (3DES) has a maximum over 90Mbps. You can upgrade or downgrade the firmware on your RV082 device whenever you want. But like before, downgrading firmware will restore the configuration settings to factory default.

    New Features:
    0. Support multiple subnets when RV082 is in the gateway mode, i.e. NAT enabled. Web UI allows users to specify multiple class C subnets on the Setup->Network page.

    1. Support Bandwidth Management, a feature already exists in RV016. Note: Since a new tab "Bandwidth Management" is inserted to the menu bar, the tabs "Restart" and "Setting Backup" are pushed to the "More… >>" page.

    2. Support NAT-Traversal on both Gateway-to-Gateway and Client-to-Gateway modes.

    3. Support Custom DNS, a paid service provided by dyndns.org. A Custom DNS checkbox is added on the Setup -> DDNS -> DynDNS.org page.

    4. RV082 will listen to port 443 and port 60443 for QuickVPN connection. Remark: The earlier firmware listens to port 443 only.

    5. Support SNMP Cold-start, Warm-start, Link-up and Link-down traps.

    6. Change the DHCP Server implementation. When the DHCP client requests the IP address of DNS server, RV082 will offer the DNS server address obtained from ISP. (In previous firmware, RV082 offers the DNS server address as RV082’s LAN IP.)

    1. Add "linksys.com" as the default Domain Name and leave Host Name to be blank after a reset to Factory Default.

    2. Restrict the Dynamic IP Range in DHCP Server Configuration to be in accordance with the LAN IP and Subnet Mask of RV082.
    For Example, when LAN IP/Mask =, the DHCP IP Range user can configure will be restricted in the range of through

    3. Fixed a PPTP Server problem that failed to establish PPTP connection when DMZ Host was enabled.

    4. Fixed an issue with saving a pre-shared key with an apostrophe.

    5. Disallow user to configure RV082’s LAN IP address to be a broadcast IP address (x.x.x.0.)

    6. Add an alert message if user configure “Send SNMP Trap to:__†as a non-IP address.

    7. Modified the alert message when Remote Management is enabled.
    (1) When https enabled, remote management enabled, and password = admin, the pop-up message will read:
    The Router is currently set to its default password. As a security measure, you must change the password before the Remote Management feature can be enabled. Press "OK" to change your password, or press "Cancel" to leave the Remote Management feature disabled.
    (2) When https disabled, remote management enabled, and password = admin, the pop-up message will read:
    Please be warned that once remote management is enabled, it will be more secure to remotely administer the router via https via port 443 instead of http. The Router is currently set to its default password. As a security measure, you must change the password before the Remote Management feature can be enabled. Press "OK" to change your password, or press "Cancel" to leave the Remote Management feature disabled.

    8. Update the on-line help of VPN Client Access (Quick VPN) to explain the two versions of firmware of RV082. The default version supports 15 QuickVPN clients, whereas the q50 version supports 50 clients.

    9. Fix the subnet mask issue. Remark: When the router’s subnet mask has been set to, you will no longer be able to change the subnet back to For example, suppose you change the subnet mask from to 255.255.192 and save the settings. You then want to change the subnet mask back to You select it from the Subnet Mask drop-down box. Every time you click the Save Settings button, error “DHCP IP Address Range conflict with the LAN IP†will appear, and it will not allow you to change it.

    10. Fixed the "Selective Acks Off" issue that affects performance.

    Known Issues:

    1. Changed the DHCP Server implementation. When the DHCP client requests the IP address of DNS server, RV042 will offer the DNS server's IP address obtained from ISP. (In previous firmware, RV042 offers its LAN IP as the DNS server's IP address.) However, if users configure a DNS server in the LAN and specify the IP address of the local DNS server on the Web UI, RV042 does not offer the local DNS server's IP address to the requesting DHCP clients.


    Discussion of any relevant problems this firmware should be done in this thread in this thread. if you have a bug, please give as much details as possible of how to replicate the problem, and what methods you have tried to fix it.
  2. pablito

    pablito Network Guru Member

    This beta is working very well and many of the fixes and changes are what I needed. Bravo.

    One thing that remains is how the "hidden" firewall rules are done. Not a bug per se but seems to be normal behaviour. When adding a port forward an associated firewall rule is assumed to be added but is hidden. Those rules apparently are at the top since any deny rules you might add are ignored for any ports that have port forward rules.

    In other words I might add a single IP to be allowed to a particular port and a deny rule for everyone else. The port forward will allow everyone in on that port no matter what deny rule I put in. I might add subnets that shouldn't be allowed any access but they will be allowed over any port forwarding rule.

    I'd like to see these hidden rules placed below any custom rules and before the default non editable rules at the bottom. Or even better to make them visible and editable.
  3. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Doing online speed tests I lost about 10% throughput. :(
  4. rchatterjee

    rchatterjee Guest

    What firmware version were you running before?
  5. YeOldeStonecat

    YeOldeStonecat Network Guru Member beta. Online speeds with that the same as prior official versioni for me.
  6. Toxic

    Toxic Administrator Staff Member

    any posts in here please keep on topic. it makes it easier to track bugs.
  7. pablito

    pablito Network Guru Member

    I don't know if this problem was introduced with the beta as I've only now tried but I can't make multiple IPSEC tunnels to a common end point. Now with multi subnets (yeah!) I tried to create a second tunnel with that new subnet. RV complains about a conflict with the subnet existing on another profile.

    A spec legal tunnel pair like this can't be saved on the RV:
  8. zorglubxx

    zorglubxx Network Guru Member

    I get same fast speed with this beta as with previous one. Looking good so far.
  9. joopy

    joopy LI Guru Member

    Up and running works like a charm only e-mail (log) from router is not working proberly.
  10. zorglubxx

    zorglubxx Network Guru Member

    I've noticed a couple of bugs, I dont know if they are new to or if they were there before:

    - In the System Management tab I have entered a whole bunch of protocol binding items. However in the listbox where they are all displayed, it doesnt show correctly if that command is bound for WAN1 or WAN2. If I click on it then it does show correctly WAN1/WAN2 in the "interface" popup.

    - Also in the System Management tab: I've tried to add hosts under "Network Service Detection" clicking one of the boxes (ISP Host, Remote Host or DNS Lookup Host) but if any of these are checked then the Save Settings link at the bottom of the page is disabled. I have to uncheck all the "Network Service Detection" boxes that I might have checked before "Save Settings" works again.
  11. gentlemanRT

    gentlemanRT Network Guru Member

    with the build the pppoe connection does not transmit data after 12 hours i have to reconnect that it works again. i also have troubles with pop3 sessions. I did not have this issues with the latest none beta or with other routers.
  12. heidnerd

    heidnerd LI Guru Member

    In firmware versions prior to 1.3.2, the router had only reported traffic for ixp0, ixp1, br0, and ipsec. ixp0 is WAN1 interface, ixp1=WAN2 interface, br0 is the combined stats for all switch ports. Firmware version appears propagate the error. No detailed information for the switch ports.


    The router should report stats for the individual ports on the switch - as noted with versions prior to 1.3.2 they combined and only reported snmp stats for "br0". But you can see the stats for all the ports if you use the web interface.. so the data is there! With firmware versions 1.3.2 and later even this combined "br0" information is now gone. Please fix the MIB to include the detailed information for each port!!! Give us the snmp information that is on the web gui.:thumbup:

    Keep in mind since the switch supports VLAN's, we really need stats by individual ports - or by VLAN's as a minimum. Not just the summary for any activity on the switch ports.

    Next, I am seeing ghosting of the stats collected for ixp0 onto ipx1. What I mean by this is that with the WAN2 interface disabled (port management screen). And no cable plugged into WAN2. There is still snmp data being reported for ixp1. The inbound traffic for ixp0 is reported as the outbound for ixp1, and outbound for ixp0 is the inbound for ixp1! However the web GUI correctly reports the inbound/outbound counters as zero!

    Also the snmp stats should include the bad packets for each port. That info is there with the Web GUI interface, but missing in the snmp MIB.

    I know that you really want only bugs for the firmware reported.... but I'd really like Linksys to consider adding some additional info to the web gui (port management or click on port from system summary screen) so when you look at the an individual port status the information is available. The new info should be the MAC address, or (IP address) of the device that is plugged into each port on the switch. This would help when cables get crossed.

    Accurate snmp info, plus an easy way to see which device is plugged into a port - would make it very easy to track down bad network cards and the heavy network users...:biggrin:
  13. TazUk

    TazUk Network Guru Member

    I have an issue setting up a VPN tunnel to two WRV54G's with dynamic IP's. If I put in the current IP address the tunnel comes up fine, but when set to Dynamic IP + Domain Name(FQDN) it won't :angry: I also noticed that on the summary screen it shows the correct FQDN but the IP address underneath is always :unsure: The WRV54G's are running firmware 2.39.2 BTW.
  14. WmArnold1

    WmArnold1 LI Guru Member

    v1.3.3.5 ==> Good, but it still insists on Blocking too many UDP's as SynFlood

    Hello everyone! - v1.3.3.5 resolves everything for me, except my main issue [sigh]

    Background: I'm enjoying P2P software that incorporates a Distributed-Hash-Table (DHT) to efficiently catalog every P2P file in the world.

    The problem; most P2P communications are done via UDP, and, lots of UDP packets are delayed or blocked by the RV082 as a SYN-FLOOD denial-of-service attack - a typical message from my RV082 is:

    ratelimit: 20 messages of type block-synflood reported 1 second(s) ago

    My Firewall-option-page settings are:

    Firewall - enabled
    SPI - disabled
    DOS - disabled <=== !!!
    Block WAN request - disabled
    Remote Mgmt - disabled
    HTTPS - enabled
    Multicast pass-through - disabled
    MTU - Manual - 1500

    (no Web features are restricted)

    Especially note that the RV082 DOS (denial-of-service) feature is supposed to be disabled above - and, it clearly isn't!

    Anyone can easily reproduce my issue by installing http://www.BitComet.com - version 0.70 now - No file transfers required - the Dynamic-Hash-Table network will bring UDP messages that are blocked most of the time - Thank goodness some UDP messages get through, or I wouldn't be able to get my eBook fix from http://www.eBookShare.net ;-)

    Btw; you may have to manually forward a port for bitComet to work properly - their UPnP feature is still not working.

    Can anyone reproduce my SYN_FLOOD issue?

    William Arnold ~ Indianapolis, IN
  15. WmArnold1

    WmArnold1 LI Guru Member

    v1.3.3.5 ==> Good, but it won't VPN with an old BEFSX

    I found another issue: - I can't establish VPN with a BEFSX41 that has been working fine since 2004.

    Background; my RV082 VPN's with other RV's and one lonely BEFSX41 - I think all my BEFVP41's have been retired, but I can scare one up if need be.

    Anyway, my tunnels to other RV's work fine - but I can't VPN with a previously working BEFSX41-V1 ~ firmware version 1.50.18 of 4/30/2004

    I have went over the settings super carefully and confirmed that it should work - my next step will be to upgrade the BEFSR firmware to 1.52.10 of 5/10/06 and Pray that fixes the problem.

    Fortunately; I don't need that particular tunnel this month - so; I can leave the failing configuration alone for Linksys Engineers or any interested party to investigate futher - Drop me a line for more information.

    Happy Holidays, Everyone! ~ William Arnold ~ Indianapolis, IN - USA
  16. TazUk

    TazUk Network Guru Member

    Is it using a static or DDNS ip?
  17. WmArnold1

    WmArnold1 LI Guru Member

    I appreciate your interest, Taz!

    My RV082 is on Cable, with a Dynamic-IP that hasn't changed for a year or more. I'm not using DDNS - I have it disabled - My Local Security Gateway Type is "IP Only" at both ends.

    The BEFSX41 is on DSL, with a Static-IP - That tunnel worked fine before I upgraded my RV082 to version - Unfortunately; I had that tunnel disabled while I was running 1.3.2 and 1.3.4.

    Fyi; my RV082 also VPN's with a RV016 that has a Static-IP - that tunnel works just fine ==> In fact; I've watched the packets on this working connection - My RV does three exchanges ( six packets total ) before shifting into phase 2.

    On-the-other-hand; Only the first and second packet are send between my RV and the SX - it doesn't go any farther no matter which end initiates.

    I hope this gives you a clue and I look forward to your next post.

    Sincerely ~ William Arnold ~ Indianapolis, IN - USA
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice