RVL200 1.1.5 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Jun 20, 2007.

Thread Status:
Not open for further replies.
  1. Toxic

    Toxic Administrator Staff Member

    RVL200 Firmware v1.1.5 Release Note 6/20/2006 (beta testing)

    If you are upgrading the firmware from v1.1.x to v1.1.5, you may find the status window turning into blank in the middle of firmware upgrade. Should that happen, please leave it alone for another 15 minutes and the upgrade will complete without problem. If the upgrade fails and the DIAG LED is blinking, the TFTP utility can be used to push the firmware to the router.

    1. Virtual Passage supports Mac OS X 10.4.x (with Safari), Linux (with Firefox 2) and Windows 2000/XP (with Internet Explorer 6/7, Netscape Communicator 8, and Firefox 2.) Note that JRE is reqiured for Virtual Passage on Linux.
    2. Virtual Passage supports Windows Workgroups (NetBIOS).
    3. Virtual Passage client can now run on Windows 2003 Server.
    4. RADIUS client now supports CHAP, MSCHAP, MSCHAPV2 in addition to PAP for user authentication.
    5. DHCP Server supports multiple subnets that correspond to multiple VLANs. Inter-VLAN routing is supported for the VLANs that are on different subnets.
    6. DHCP Server supports static IP and MAC address binding.
    7. Help page updated to show how to use the MAC Address Filtering feature
    8. Support One-to-One NAT.
    9. Port Mirroring. Admin can specify one of the LAN ports as the target port, and select one or more ports to be mirrored. This feature can be configured on the System Management->Port Mirroring page.
    10. Compliant with the UPnP IGD Certification.
    11. Support more configurable options for logging in the Log->System Log page.
    12. Tagged events with severity level. Logged events can be viewed/filtered according to the selected severity level.
    13. Added Outgoing Log Table and Incoming Log Table into the System Log page.
    14. Support SNMPv3
    15. Support SNMP Traps for LAN port Link-up and Link-down detection.
    16. IPSec: NetBIOS Broadcast
    17. IPSec: Remote Security Group Type supports IP Range
    18. IPSec: Keying Mode supports Manual Mode
    19. IPSec: Gateway-to-gateway tunnel supports IP payload compression.
    20. IPSec: Phase2 Encryption & Authentication supports Null
    21. IPSec Passthrough supports multiple sessions
    22. PPTP Passthrouh supports multiple sessions
    23. The SSH Sentinel VPN Client can establish an IPSec tunnel with RVL200 with the NAT Traversal enabled.
    24. Access Rules and Content Filters support 24-hour format for scheduling.
    25. Support Manual Daylight Saving, where the start and end dates can be manually specified.
    26. Support SIP Application Layer Gateway.
    27. Support IGMP Snooping.
    28. Content Filters can be defined for for groups of computers identified by IP or MAC addresses.
    29. Email Alert supports password authentication, i.e. NTLM authentication on Microsoft Exchange Server.
    30. Support self-generated SSL certificate and allow SSL certificate to be imported.

    Issues Fixed:

    1. Fixed the PPPoE issue where connection will fail to establish when the PPPoE username contains a # sign.
    2. Fixed the issue where the firewall status (SPI/DoS/BlockWANRequest/RemoteManagement) is not shown correctly in the System Summary page when the firewall is disabled.
    3. The IP Range of Virtual Passage was changed to 6, instead of 10.
    4. Removed the reference to Priority in the Help page of Port Management->Port Setup, since the setting is supposed to be configured on the Qos page.
    5. Fixed the issue where the packet will appear coming from the router's LAN IP, when a packet is forwarded to the DMZ Host in the LAN of RVL200.
    6. Fixed an issue with PPTP Passthrough.
    7. Renamed "IGMP Proxy" as "Multicast Passthrough" on the Firewall->General page.
    8. Added Policy Name to the Access Rule configuration page.
    9. Time Zone description and index were modified.

    Known Issues:

    1. Mac OS version 10.4 is known to have a image loss issue with several https servers, including RVL200. Images files transmitted over a SSL tunnel can be lost randomly. Mac OS version 10.4.8 has fixed this issue.
    2. Virtual Passage does not support Windows Vista.
    3. RVL200 does not support QuickVPN. The help page about certificate management has an incorrect reference to QuickVPN.

    **In case users failed to upgrade the firmware via Web UI and the DIAG LED is blinking, users can use a TFTP utility (RVL200_1.0.13.exe available on linksys.com) to recover the device and then use the Web UI to upgrade the firmware to the latest version.

    Get the download here: http://www.linksysinfo.org/forums/downloads.php?do=file&id=59
  2. Toxic

    Toxic Administrator Staff Member

  3. Paul_B

    Paul_B LI Guru Member

    Any news if port-forwarding is now reported as fixed?
  4. Toxic

    Toxic Administrator Staff Member

    i'm port forwading 4 ports that are all working. what was your exact problem? have you tried the new firmware to see if it is working for you or not? what ports were you trying to forward? does your ISP block any ports you are trying to use?
  5. Paul_B

    Paul_B LI Guru Member

    I have a ADSL Modem: AG241V2 as the gateway to the internet and this has a private interface on 172.16.x.x subnet. The RVL200 then has the public interface in the 172.16.x.x subnet and the private interface is on 192.168.1.x.

    I can see stuff coming in on port 25 from the AG241V2 and transversing across to the public interface of the RVL200 but from the logs it would appear that through the RVL it is not going port 25 to port 25 but port 25 to an emphiracal port.
  6. Coopsterman321

    Coopsterman321 LI Guru Member

    Awww. Still no Vista support.

    Hopefully I'll have my Firefox and Port Forwarding.

    Can't wait to test!
  7. Toxic

    Toxic Administrator Staff Member

    have you tried using the access rules incase it is being blocked?
  8. lineof200

    lineof200 LI Guru Member

    So far so good.

    Yes, the 1.1.5 beta supports the 192.168.0 LAN subnet. Upgrade via web browser (after resetting the RVL200 to factory defaults) went very smoothly.

    Under the old (release) firmware, the RVL200 needed to be reset 2 to 3 times each week. Hopefully the 1.1.5 beta will prevent this from happening.
  9. Toxic

    Toxic Administrator Staff Member

    Yeah so far so good.

    uptime 6 Days 10 Hours 34 Minutes 0 Seconds.

    mine is set as the default gateway with a RV042 and WRTSL54GS behind it. I've had no problems so far, except the missing Virtual Passage Client for Vista Support (and XP x64) though it is being worked on.
  10. andrew.ticknor

    andrew.ticknor LI Guru Member

    I just purchased a rvl200 router and it has 1.0.12 in it now, can i go up to this version or do i need one with ver 1.1 on it?
    I need to go up because our network is set up as a workgroup.

  11. radius9999

    radius9999 LI Guru Member

    "System Busy! Please wait a minute to re-login RVL200." But it never gets unbusy. This happened after the current beta upgrade. Any ideas?

  12. lineof200

    lineof200 LI Guru Member

    Regarding: Periodic requirement to restart RVL200

    Okay, after upgrading the RVL200 to 1.1.5 (posted above in this thread), with all being fine for about a week, the RVBL200 has needed to be restarted (login to management page and restart it). It simply stopped handling and network traffic; as it has done periodically since purchase (under 1.0.14 and 1.1.5)

    What does it take to get the RVL200 remaining up for months at a time?

    It is configured very simply (static IP on WAN, no VPN or other features enabled, port forwarding (for SBS2003 server), NAT. The WAN connection (CISCO 828, SHDSL) has remained up and operating for more than a year without ever needing to be touched.

    Next step: arrange replacement RVL200 with Linksys. If that also fails, the step after that will be to argue 'not fit for purpose'.
  13. Phyxis

    Phyxis Guest

    You -should- be able to go directly to 1.1.5, to my knowledge.
  14. radius9999

    radius9999 LI Guru Member

    I too have the same problem. Seems the router just freezes up and needs to be power cycled about every 3 days. Really Frustrating! Makes me think they put this thing out way ahead of it being functional! I guess they needed the $$$. And then to label it Business Class?
  15. radius9999

    radius9999 LI Guru Member

    I'm having 2 very strange problems. The first is we have our server named Server1 with its ip For some reason, when server1 is pinged from any internal system, it gives out our external ip number, which of course means that no one can see the server. I had to put an entry into everyone's host file to correct this problem. I can't see how it got the external IP. We don't even have a static ip, yet it gets that number no matter what it is. Very strange!

    The second problem is that I can access the vpn from some remote workstations, but not others. I get past the certificate, but then just a blank white screen. It never completes loading. I've tried it from several different locations, and either it works or it doesn't. I can't find any common thread (ISP, firewall, etc.) that would account for this. Does anyone have any suggestions on browser settings (I've tried IE, Opera, and Firefox - all with the same results) or something else that might be necessary to get this working consistantly? When it works it works. But I cannot figure out why it won't load the page on some systems.

    Thanks for any suggestions!

    - Ray -
  16. Toxic

    Toxic Administrator Staff Member

    Ray, I would recommend your Server should have static IP (not assigned by the RVL200.

    as to accessing the vpn, do you mean your trying to access the RVL200 via SSL VPN Client? if it goes to a blank screen then it sounds like the browser is not setup correctly. make sure you acarry out the instructions in Appendix C ofthe RVL200 user guide. the other thing is the Virtual Passage client is not x64 OS compatible.
  17. radius9999

    radius9999 LI Guru Member

    The server does have a static ip - as I've said. And the os I've been using is Windows XP. Now I have two RVL200 routers at two different locatioins - my office and a clients. I have no problem logging in to the vpn at my office from anywhere, but I do have a problem logging in to my client's vpn. Same machines, same browser setup. The blank white screen happens only at some location and not others. But I can always get to my office from those locations so I know the browser settings are correct. I'd give you the link to my client's office but I don't want to do that publically so you can test it. Is there any debug routine I can run? I've tried the log files, but they don't tell me anything. - Ray -
  18. Toxic

    Toxic Administrator Staff Member

    when you say some locations, what type of locations are these?
  19. radius9999

    radius9999 LI Guru Member

    The locations are my home and other business offices of my other clients. The problem is that the page never finished loading. The browser is constantly waiting for page info (after saying ok to the certificate warning). It just never gets the info.
  20. Toxic

    Toxic Administrator Staff Member

    what MTU are you using on the RVL200 units and what connection type are they? ADSL or Cable? do you haev a VPN tunnel setup between the two RVL's? is there any packet loss when pinging the LAN IPs? what do you get with you use the pathping command?
  21. Kuta

    Kuta Guest

    How to install it certificate from RVL-200 v1.1.5 to QuickVPN?
  22. vpnuser

    vpnuser LI Guru Member

    I don't think RVL200 supports QuickVPN. It has one IPSec tunnel for G2G tunnel.
  23. radius9999

    radius9999 LI Guru Member

    I haven't gotten around to setting up a VPN tunnel between the two units yet. They are both on ADSL lines, 1492 MTU (tried auto also -same result). There is no packet loss when pinging and pathping is %100. I've tried accessing from both other DSL and Cable lines, and it either works or doesn't. There's no in between. But it always works to my office. Very strange. I'm running out of diagnostic ideas!
  24. lineof200

    lineof200 LI Guru Member

    Any further feedback on RVL200 freezing several times each week (see previous posts)? This is after upgrading to firmware 1.1.5 (beta).

    There seems to be a lack of any feedback from Linksys regarding this.

    I am trying to progress this via Linksys Technical support. I find it worrying that the agents responsible for managing the case are unable to directly email me to progress this issue, and I must rely upon callbacks (not always feasible) and verbal (not written) instructions and assurances.
  25. Toxic

    Toxic Administrator Staff Member

    Chris. Linksys does not publicy make statements on these forums. the forums here are run by staff that are not affiliated with linksys. we are not paid by them, however we do know they read these forums. as an idividual you do need to raise issues officially to highten awareness of problems that users do have.

    if you bought your RVL200 from an official reseller.Linksys VAR, they have access to to Second level Support. This is part of the "Business Class" model. you only get this support from a VAR but not from the likes of amazon and other large independant stores.
  26. lineof200

    lineof200 LI Guru Member

    Many thanks for the clarification Simon, am endeavouring to follow up.
  27. Toxic

    Toxic Administrator Staff Member

    can we please keep this thread on topic. if you want to moan goto linksys.com they have tech support staff there 24/7 to listen to you. this thread is for issues that are relevant to the beta release.
  28. Paul_B

    Paul_B LI Guru Member

    Just to give some feedback. In my previous posts I mentioned my experience with previous firmware's and not being able to port forward. I could see entries in the log but the port seemed to be forwarded to an emphirical port rather than the same port WAN to LAN.

    I have upgraded to v1.1.5 Beta and did a hard reset of the device (holding down the reset button for 10 seconds). After re-setting all my previous configuartion I can report port forwarding now works. I also get Multicast on this firmware version. Overall the firmware seems more responsive and quicker than previously (could be just my imagination). Only thing I haven't tried yet is a SSL VPN.
  29. lineof200

    lineof200 LI Guru Member

    More on RVL200 freezing

    Linksys have arranged an RMA for the RVL200 (see above this thread). This freezes periodically and needs to be restarted: upgrading to 1.1.5 and resetting the unit to factory defaults has not had any apparent effect on this.

    The RVL200 works under a heavy load (it's the router for an office of 20+ architects). I've posted the configuration information here to start building a better profile of why this has been occurring; I've seen approximately five or seven posts relating to this issue (here and elsewhere).

    It stays up for various periods of time: perhaps one or two weeks. However, when it freezes, this often clumps (two or three restarts will be required within a 24 hour period).

    I have a suspicion that the RVL200 is freezing either under specific load conditions; or under some infrequent network occurrence on the WAN or LAN side.

    Serial Number : DN0006800861
    Firmware version : v1.1.5 (Jun 4 2007 11:16:56)
    CPU : Cavium CN225 DRAM : 64MB Flash : 16MB
    System up time : 9 Days 0 Hours 14 Minutes 56 Seconds
    LAN: standard LAN IP address of router:
    WAN: Static IP (provided by Cisco 828) on a subnet
    MTU: Manual (1500). Has also been Auto and Manual: 1492
    Firewall : Enable
    SPI (Stateful Packet Inspection) : Enable
    DoS (Denial of Service) : Enable
    Block WAN Request : Enable
    Remote Management / SSL VPN : Disable
    HTTPS : (greyed out: Disable is checked)
    HTTP : (greyed out: Disable is checked)
    Multicast Pass Through : Disable

    DHCP Server: Disabled
    VLANs and VPNs: Disabled (not used...)
    QoS Bandwidth Management: set to 1000kBit/s on WAN (upstream, downstream)
    UPnP: No

    Port Forwarding: This unit serves as a router to a private network that runs Windows SBS2003. The server is on the private network and provides normal services for the LAN, including email (Exchange, Remote Workplace and Remote Access). As a result, the following is set in Port Forwarding on the RVL200; these all forward to the private IP address of the server:
    FTP TCP 21~21
    SMTP TCP 25~25
    HTTP TCP 80~80
    POP3 TCP 110~110
    NTP TCP 123~123
    IMAP TCP 143~143
    HTTPS TCP 443~443
    WinSharePt TCP 444~444
    IPSec UDP 500~500
    L2TP UDP 1701~1701
    PPTP TCP 1723~1723
    TermServ TCP 3389~3389
    RemWebWkpl TCP 4125~4125
    WIBU TCP 22347~22347
    WIBUUDP UDP 22347~22347
    IMAP3 TCP 220~220
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice