RVL200 1.1.6 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Jul 7, 2007.

  1. Toxic

    Toxic Administrator Staff Member

    For all you guys waiting impatiently for this.......

    This new firmware gives SSL Client support to Vista.
    NOTE: This is Beta Firmware

    RVL200 Firmware v1.1.6 Release Note

    7/06/2006 (beta testing)

    If you are upgrading the firmware from v1.1.x to v1.1.6, you may find the status window turning into blank in the middle of firmware upgrade. Should that happen, please leave it alone for another 15 minutes and the upgrade will complete without problem. If the upgrade fails and the DIAG LED is blinking, the TFTP utility can be used to push the firmware to the router.

    1. Virtual Passage supports Mac OS X 10.4.x (with Safari), Linux (with Firefox 2) and Windows 2000/XP/Vista (with Internet Explorer 6/7, Netscape Communicator 8, and Firefox 2.) Note that JRE is reqiured for Virtual Passage on Linux. Also note that When a user wants to establish the SSL VPN from a Windows Vista for the first time, he needs to run the Internet Explorer as Administrator becuase the Virtual passage installation can only be done with the admin rights.
    2. Virtual Passage supports Windows Workgroups. To resolve NetBIOS names over SSL VPN, the admin has to configure a WINS Server on the DHCP page of RVL200, and the remote user's PC has to configure its TCP/IP Property to point to this WINS Server.
    3. Virtual Passage client can now run on Windows 2003 Server.
    4. RADIUS client now supports CHAP, MSCHAP, MSCHAPV2 in addition to PAP for user authentication.
    5. DHCP Server supports multiple subnets that correspond to multiple VLANs. Inter-VLAN routing is supported for the VLANs that are on different subnets.

    6. DHCP Server supports static IP and MAC address binding.
    7. Help page updated to show how to use the MAC Address Filtering feature
    8. Support One-to-One NAT.
    9. Port Mirroring. Admin can specify one of the LAN ports as the target port, and select one or more ports to be mirrored. This feature can be configured on the System Management->Port Mirroring page.
    10. Compliant with the UPnP IGD Certification.

    11. Support more configurable options for logging in the Log->System Log page.
    12. Tagged events with severity level. Logged events can be viewed/filtered according to the selected severity level.
    13. Added Outgoing Log Table and Incoming Log Table into the System Log page.
    14. Support SNMPv3
    15. Support SNMP Traps for LAN port Link-up and Link-down detection.

    16. IPSec: NetBIOS Broadcast
    17. IPSec: Remote Security Group Type supports IP Range
    18. IPSec: Keying Mode supports Manual Mode
    19. IPSec: Gateway-to-gateway tunnel supports IP payload compression.
    20. IPSec: Phase2 Encryption & Authentication supports Null

    21. IPSec Passthrough supports multiple sessions
    22. PPTP Passthrouh supports multiple sessions
    23. The SSH Sentinel VPN Client can establish an IPSec tunnel with RVL200 with the NAT Traversal enabled.
    24. Access Rules and Content Filters support 24-hour format for scheduling.
    25. Support Manual Daylight Saving, where the start and end dates can be manually specified.

    26. Support SIP Application Layer Gateway, which can be enabled/disabled on the Firewall->General page.
    27. Support IGMP Snooping.
    28. Content Filters can be defined for for groups of computers identified by IP or MAC addresses.
    29. Email Alert supports password authentication, i.e. NTLM authentication on Microsoft Exchange Server.
    30. Support self-generated SSL certificate and allow SSL certificates (in .PEM format) to be imported.

    Issues Fixed:

    1. Fixed the PPPoE issue where connection will fail to establish when the PPPoE username contains a # sign.
    2. Fixed the issue where the firewall status (SPI/DoS/BlockWANRequest/RemoteManagement) is not shown correctly in the System Summary page when the firewall is disabled.
    3. The IP Range of Virtual Passage was changed to 6, instead of 10.
    4. Removed the reference to Priority in the Help page of Port Management->Port Setup, since the setting is supposed to be configured on the Qos page.
    5. Fixed the issue where the packet will appear coming from the router's LAN IP, when a packet is forwarded to the DMZ Host in the LAN of RVL200.

    6. Fixed an issue with PPTP Passthrough.
    7. Renamed "IGMP Proxy" as "Multicast Passthrough" on the Firewall->General page.
    8. Added Policy Name to the Access Rule configuration page.
    9. Time Zone description and index were modified.

    Known Issues:

    1. Mac OS version 10.4 is known to have a image loss issue with several https servers, including RVL200. Images files transmitted over a SSL tunnel can be lost randomly. Mac OS version 10.4.8 has fixed this issue.
    2. Syslog may stop working after the router has been up for a few days.
    3. If the admin password contains brackets, e.g. link[]sys, the router will not function properly after the password is saved.

    **In case users failed to upgrade the firmware via Web UI and the DIAG LED is blinking, users can use a TFTP utility (RVL200_1.0.13.exe available on linksys.com) to recover the device and then use the Web UI to upgrade the firmware to the latest version.

    Download the firmware here: http://www.linksysinfo.org/forums/downloads.php?do=file&id=63

  2. andrew.ticknor

    andrew.ticknor LI Guru Member

    since the red letters tells me to report the problem i will report mine, since my threade is kind of going off track....

    **this is for the users at the office behind the router**
    when i change the internal ip address from 192.168.1.xxx to 192.168.0.xxx you can only remote desktop with the computers ip address. When its back to the default 192.168.1.xxx i can now remote desktop by computer name.
    i have not tried anyother internal ip address i have only used these two. and i can duplicate the problem everytime.

    **This is for the clients on the road outside the office**
    But when connecting though ssl i can still only remote desktop by computer name, server is running the wins service, everycomputer is pointed to the wins server, and "enable netbois over tcp/ip" is checked.
    this fixed this problem and should be a sticky somewhere:
    Step 1 Right click VirtualPassage button and select Properties
    Step 2 Select the Networking page and then Internet Protocol(TCP/IP)
    Step 3 Select Advanced button
    Step 4 Select the WINS page and enter WINS server IP address in the blank
    Step 5 Reconnect the sslvpn tunnel. Now you should be able to do things like Network Neighborhood over SSL VPN.

    oh and network neighborhood only shows my computer though ssl, i think this is normal though.

    and for anyone else, do not map network drive by computer name though ssl it is way to slow. only map with computer ip!!

  3. drewbrew

    drewbrew LI Guru Member

    Some good some bad

    I was extremely glad to see logging, port triggering, and several items working once again. Unfortunately the happiness was short lived when it seemingly broke the SIP application gateway (only allowed inbound calls not outbound) and seemed to break auto negotiation (all showed up as 10Mbps half) immediately after the update...
  4. Toxic

    Toxic Administrator Staff Member

    Thanks for the info Andrew. The changelog has been "officially" updated in regards to the Netbios issue (or not as the case maybe) to explain you have to add a WINS Server

    As to your problem with slowness. WinXP machines will when mapping a drive search for sceduled tasks on that drive. a quick fix maybe at hand.

    Hope this helps.
  5. Toxic

    Toxic Administrator Staff Member

    after the update Drew did you reset the router to factory defaults? I have not experienced any auto negotiation problem.
  6. drewbrew

    drewbrew LI Guru Member

    Yes, I did reset to defaults. While working to try and get SIP issues resolved the device was restarted several times, and I see that it now displays correctly. I think it was likely only a display issue, it showed 10, but I believe all ports on all connected devices lit up as 100 full. Since noticing this, I have tried several times to reproduce it, and it seems to be fine, it may well have been an issue with a specific reboot sequence of various pieces of equipment, since one of my internal routers is connected via a 10 Mbps half-duplex port.

    I haven't delved into the SIP issue in great detail yet (e.g. SIP protocol analysis), but I suspect that since it works in one direction and not the other that it could be an issue of some of the SIP fields not being rewritten correctly through the NAT (e.g. the private IP may remain and therefore the PBX can't communicate back).

    I hope that the SIP issue is resolved soon, besides the SSL VPN its ability to work with my SPA2102 behind it was the feature I mentioned most frequently to interested parties, it's an amazing feature, now if they were to add some SBC functionality to it people would be fighting to get one.

  7. parax

    parax LI Guru Member

    Nice to see the first official vista capable ssl firmware. I have sucessfully upgraded one of our test routers, but it seems that the xtunnel client can't be installed on a x64 vista system. I have tested it on two machines. Can anybody confirm this? :((
  8. Toxic

    Toxic Administrator Staff Member

    it is only 32bit compatible
  9. parax

    parax LI Guru Member

    I have disabled the force for signed drivers only but doesn't work ether. Do you know if a 64bit version is planned? I don't want to switch back to 32bit on my comp notebook.
  10. romatere

    romatere LI Guru Member

    RVL200 sometimes does not respond

    I installed Firmware 1.1.6 and sometimes I experience that the router does not respond when I try to connect to it from the outside. I enabled only https on the router, so all http traffic goes through the router to my local web server, and it works. But when I change http to https, the router sometimes does not respond. It starts to respond again automatically after some period of time, without me doing nothing.

    Roman Terekhov.
  11. Toxic

    Toxic Administrator Staff Member

    i'll try finding out about the 64bit version of the passage drive for you. I cannot however promise a satifactory result for you as yet.
  12. mvictoras

    mvictoras LI Guru Member

    Another BUG:

    Multiple subnetting does NOT work well.

    If I enter as default ip address and I want to add another subnet of the C - class, the web interface does not allow me to do that !

    For example if I want another subnet with router ip address

    PS: Any clue for a stable version ?
  13. samuch

    samuch Guest

    SIP Handling Poor with Asterisk

    We upgraded to this firmware to hopefully solve the bad QoS we were experiencing and one way audio issues.

    With this firmware we can only make outbound calls maybe one out of every 8 tries. Asterisk reports that the external line was busy.

    Yet when we use the latest stable firmware this never happens. This product has been quite a let down as far as QoS.
  14. vpnuser

    vpnuser LI Guru Member

    Do you have the SIP ALG enabled or disabled? You might want to flip the setting and see if it works better.
  15. mvictoras

    mvictoras LI Guru Member

    Here's another bug:

    Router in router mode, on the LAN side and on the WAN side, with default gw the adsl modem (

    Enabled rip v2 on both sides, so the routing tables are propagated.
    The 2 networks are well routed, and all the clients on the LAN side, have access to the inet.

    Because I need the VPN thingy, I forwarded port 443 (on the modem) to the WAN side of the Linksys. I also enabled, the Remote option under the System Settings of the Linksys, but still not working. It seems, that the WAN iface is not responding to the http requests!

    RVL200 is the most buggy router I have EVER used. Regreted and feel very sorry for the money I spent.

    The worst thing is that I am loosing days, for finding workarounds to solve the problems that the router has, loosing from my man-hours I have.
  16. trog27

    trog27 Guest

    Is there any chance we could get a simple but automatic user password changing option implemented in the next version of firmware?

    Thinking along the lines of being able to specify as an administrator SSL VPN user option on the RVL200, a "formula" involving variables such as user-id, day, month, year, hour (which it should know via NTP) so an SSL VPN user has a derived portion (or an entirely derived) password. Not quite two factor but better than the base install and less complex than implementing a separate LDAP server which is too much for a small business.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice