RVL200 1.1.7 Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Aug 14, 2007.

  1. Toxic

    Toxic Administrator Staff Member

    Yes this ones official. Linksys released this a few days ago. channges are listed below:

    RVL200 Firmware v1.1.7 Release Note
    If you are upgrading the firmware from v1.1.x to v1.1.7, you may find the status window turning into blank in the middle of firmware upgrade. Should that happen, please leave it alone for another 15 minutes and the upgrade will complete without problem. If the upgrade fails and the DIAG LED is blinking, a TFTP utility (available on linksys.com) can be used to push the firmware to the router.
    1. Virtual Passage supports Mac OS X 10.4.x (with Safari), Linux (with Firefox 2) and Windows 2000/XP/Vista (with Internet Explorer 6/7, Netscape Communicator 8, and Firefox 2.) Note that JRE is reqiured for Virtual Passage on Linux. Also note that When a user wants to establish the SSL VPN from a Windows Vista for the first time, he needs to run the Internet Explorer as Administrator becuase the Virtual passage installation can only be done with the admin rights.
    2. Virtual Passage supports Windows Workgroups. To resolve NetBIOS names over SSL VPN, the admin has to configure a WINS Server on the DHCP page of RVL200, and the remote user's PC has to configure its TCP/IP Property to point to this WINS Server.
    3. Virtual Passage client can now run on Windows 2003 Server.
    4. RADIUS client now supports CHAP, MSCHAP, MSCHAPV2 in addition to PAP for user authentication.
    5. DHCP Server supports multiple subnets that correspond to multiple VLANs. Inter-VLAN routing is supported for the VLANs that are on different subnets.
    6. DHCP Server supports static IP and MAC address binding.
    7. Help page updated to show how to use the MAC Address Filtering feature
    8. Support One-to-One NAT.
    9. Port Mirroring. Admin can specify one of the LAN ports as the target port, and select one or more ports to be mirrored. This feature can be configured on the System Management->Port Mirroring page.
    10. Compliant with the UPnP IGD Certification.
    11. Support more configurable options for logging in the Log->System Log page.
    12. Tagged events with severity level. Logged events can be viewed/filtered according to the selected severity level.
    13. Added Outgoing Log Table and Incoming Log Table into the System Log page.
    14. Support SNMPv3
    15. Support SNMP Traps for LAN port Link-up and Link-down detection.
    16. IPSec: NetBIOS Broadcast
    17. IPSec: Remote Security Group Type supports IP Range
    18. IPSec: Keying Mode supports Manual Mode
    19. IPSec: Gateway-to-gateway tunnel supports IP payload compression.
    20. IPSec: Phase2 Encryption & Authentication supports Null
    21. IPSec Passthrough supports multiple sessions
    22. PPTP Passthrouh supports multiple sessions
    23. The SSH Sentinel VPN Client can establish an IPSec tunnel with RVL200 with the NAT Traversal enabled.
    24. Access Rules and Content Filters support 24-hour format for scheduling.
    25. Support Manual Daylight Saving, where the start and end dates can be manually specified.
    26. Support SIP Application Layer Gateway, which can be enabled/disabled on the Firewall->General page.
    27. Support IGMP Snooping.
    28. Content Filters can be defined for for groups of computers identified by IP or MAC addresses.
    29. Email Alert supports password authentication, i.e. NTLM authentication on Microsoft Exchange Server.
    30. Support self-generated SSL certificate and allow SSL certificates (in .PEM format) to be imported.

    Issues Fixed:
    1. Fixed the PPPoE issue where connection will fail to establish when the PPPoE username contains a # sign.
    2. Fixed the issue where the firewall status (SPI/DoS/BlockWANRequest/RemoteManagement) is not shown correctly in the System Summary page when the firewall is disabled.
    3. The IP Range of Virtual Passage was changed to 6, instead of 10.
    4. Removed the reference to Priority in the Help page of Port Management->Port Setup, since the setting is supposed to be configured on the Qos page.
    5. Fixed the issue where the packet will appear coming from the router's LAN IP, when a packet is forwarded to the DMZ Host in the LAN of RVL200.
    6. Fixed an issue with PPTP Passthrough.
    7. Renamed "IGMP Proxy" as "Multicast Passthrough" on the Firewall->General page.
    8. Added Policy Name to the Access Rule configuration page.
    9. Time Zone description and index were modified.
    Known Issues:
    1. Mac OS version 10.4 is known to have a image loss issue with several https servers, including RVL200. Images files transmitted over a SSL tunnel can be lost randomly. Mac OS version 10.4.8 has fixed this issue.
    2. Syslog may stop working after the router has been up for a few days. Rebooting the router can temporarily fix the problem.

    TFTP Utility and firmware
  2. rickwagenaar

    rickwagenaar Guest

    This is great! I've loaded the new firmware yesterday, and till so far it works absolutely perfect!

    Windows Vista vpn works great.
  3. Toxic

    Toxic Administrator Staff Member

    Please report any problems with this firmware on this thread including how to replicate the issue if possible and you type of WAN connection and any other relevant information.
  4. Space Ghost

    Space Ghost Guest

    SSL VPN with NT Domain Authentication

    I'm running into an issue with the SSL VPN with NT Domain Authentication.

    When I set the SSL VPN authentication to NT Domain, and point it to my Win2k domain controller, the router will let anyone log in using any and all user IDs and passwords. I can even gain access by using IDs that don't exist in the Domain. In other words, it doesn't appear to validate the user at all. It just lets anyone in.

    Any ideas?
  5. ara_esq

    ara_esq Network Guru Member

    Biggest bug not fixed...443 forwarding useless

    Not sure if this has been discussed here in a while, but it is essentially impossible to forward port 443 and have Remote Managment/SSL VPN enabled. There are people on my network who I need to just be able to get to the server via SSL (443), e.g., Outlook Web Access (OWA), and others I need to have full vpn tunnels. Unfortunately, if you enable the SSL VPN / SSL Remote Management (which are, for some reason, interrelated settings) anything that comes in on the default SSL port (443) goes to the RVL's login page, and not to the server that the port forwarding is set to. This SEEMS like an easy fix...allow the user to change the SSL VPN / Remote Management port, ideally to anything, but at a minimum to 8443.

    Before anyone tells me that I should change the port for OWA, let me just say that we use SBS 2003, which has many preconfigured intranet websites and settings, and changing that particular default breaks A LOT of links, which I could fix, but it would take MANY MANY hours, and I would still likely miss something.

    PLEASE tell me this is doable. If I had the first clue on how to do it, I would jump into the GPL code and try to tweak it myself.

    PS - Anyone else having NetBIOS over TCP/IP issues? I can access everything, but only via IP address.
  6. Toxic

    Toxic Administrator Staff Member

    the netbios issue, is this over the virtual passage?

    the changelog show you need to add WINS. I take it you did do this yes? though afaik this is only supported by the looks of it in a Workgroup and not a domain.

    2. Virtual Passage supports Windows Workgroups. To resolve NetBIOS names over SSL VPN, the admin has to configure a WINS Server on the DHCP page of RVL200, and the remote user's PC has to configure its TCP/IP Property to point to this WINS Server.
  7. ara_esq

    ara_esq Network Guru Member

    Thanks Toxic. It was over the Virtual Passage, but I actually got that part worked out by following the DNS settings notes elsewhere in the forum.

    As the resident expert on this business, do you have any thoughts on the other (443 forwarding) issue?
  8. Toxic

    Toxic Administrator Staff Member

    well the workaround that I know of is to change the OWA https port but as you say this is not your solution you want. I cannot say if Linksys is planning to use SSL using a different port or not. I'll ask but I wont be holding my breath just yet.
  9. therealmatey

    therealmatey Guest

    The SSL certificates page seems to be broken for generating and importing certificates. Does Linksys know this?

    The export functions work. The RVL200 uses the PEM file type that is Base64 encoded. The Admin Export function writes the private keys and certificate to the file, while the Client Export function only writes the certificate.

    The Windows Certificates MMC add-in will not export the private keys with the certificate into the Base64 format; it will only export with the private keys to the PKCS #12 (.PFX) format. Anyone know how to convert these PFX (binary) files to the Base64 Encoded format (PEM) and thus importing into the RVL200 when the page is fixed?
  10. Toxic

    Toxic Administrator Staff Member

    As far I know you can only import linksys router generated certificates.
  11. ara_esq

    ara_esq Network Guru Member

    Toxic, Any chance this is an easy fix? I notice there is GPL code available...any chance someone with coding skills could just go in and change 443 to 8443 in the right line? I know it's probably beyond wishful thinking (aka a dream from La La Land), but I figured it was worth a shot.

    Thanks again.
  12. romatere

    romatere LI Guru Member

    Error: The modem (or other connecting device) has reported an error.

    I try to connect to VPN with Virtual Passage and get the following error:
    "Error: The modem (or other connecting device) has reported an error."
    Before it was possible to connect from the same network (with the firmware followed with the router). Could it be caused by firewall?
  13. vpnuser

    vpnuser LI Guru Member

    Seen this error before. Was able to surpass it after removing the XTunnelCtrl.class and WebCacheCleaner.class under c:\windows\downloaded program files\.
  14. romatere

    romatere LI Guru Member

    Did not help in my case :-(

    One more error message during VirtualPassagw installation (on Windows Server 2003 Standard Edition SP2 with all WindowsUpdates)
    "Error: A connection to the remote computer could not be established because the modem was not found or was busy. For further assistance, click More Info or search Help and Support"


    Does anybody know about some SSL VPN Router that just works? I have too much trouble with this one.
  15. drewbrew

    drewbrew LI Guru Member

    I seem to have never posted my (repetitive from other beta and release firmware) bug report... The SIP application layer gateway does not work on this release. My ATA (Linksysy SPA2102) registers with my VoIP provider's Asterisk server, and I receive calls, but I cannot place calls.

    I'd be glad to provide anyone details on replicating this issue, but it's pretty straightforward really.

  16. Toxic

    Toxic Administrator Staff Member

    you have enabled SIP ALG in the firewall option yes?
  17. sybil0105

    sybil0105 LI Guru Member

    You can uninstall the Virtual Passage from Device Management ==> Network adapters ==> Virtual Passage SSLDrv Adapter or PC reboot and redial ssl tunnel try again test .
  18. Toxic

    Toxic Administrator Staff Member

    Are you running the x86 or x64 bit W2K3?
  19. romatere

    romatere LI Guru Member

    Windows Firewall

    I am running x86.

    I think I found one of the problems.
    VirtualPassage fail to install when Windows Firewall is ON. But is installs OK when the firewall is OFF. After the installation the firewall can be switched ON again.

    If the installation has failed because of the firewall it is not enough to switch it OFF and try again, but you need to restart the system.
  20. drewbrew

    drewbrew LI Guru Member

    Indeed I have. I tried disabling it and re-enabling it to no avail. It worked in 1.1.2 but I have tried 3 firmwares since in which outbound calls don't work.

    I'd love to provide any information or data needed to get this resolved, but I can't seem to get any interest ;-)

  21. netgeek

    netgeek LI Guru Member

    does the RVL200 allow you to specify an external port say 8443 to be forwarded to an internal port say 443 in the router config? I have been able to do this with other routers but I have no experience with the RVL200.

  22. NicNicMtl

    NicNicMtl LI Guru Member

    I'm using Cisco VPN Client to connect at work, since i updated my RVL200 to 1.1.7 every 5-6 connections i need to reboot the router to be able to communicate on the VPN, in the Cisco VPN Client I see bytes sent but nothing received. I reboot the router and everything works great. I was not experiencing this problem with the 1.0.14 firmware.
  23. Toxic

    Toxic Administrator Staff Member

    did you try 1.18RC1 Beta?
  24. NicNicMtl

    NicNicMtl LI Guru Member

    Yes i did, but got the same issue.
  25. vpnuser

    vpnuser LI Guru Member

    Yes. Checkout the Setup>UPnP page, which allows you port-forwarding a service, deifined by a pair of external/internal ports, to a private IP address.
  26. BRUSLX

    BRUSLX Guest

    have uploaded firmware 1.1.7 on the RVL200.
    I'm now able to install virtual passage on a vista PC, but the rdp connection to a W2003 Terminal server is very slow, U have to wait 2 or 3 seconds between mouse click.
    If I run the same access on a Windows XP machine the speed is OK.

    any idea where to check.


  27. mfeferman

    mfeferman Guest

    RVL 200 v1.1.7 DDNS broken

    When I try and setup the DDNS configuration, it never successfully updates. I enable 'DynDns.org' and then fill in the fields with the values and select 'Save Settings'. The page does a postback and then fills in the hostname part of the three-part hostname with 'END', leaving the second and third part of the hostname blank. If you do a 'view source' on this particular web page for the router, you can see in the source code where the word 'END' is hardcoded in that field. Is anyone else experiencing this issue?

    Thanks in advance,
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice