RVL200 Port 22

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by coherentsys, Jul 2, 2007.

  1. coherentsys

    coherentsys LI Guru Member

    Ok, I have not been lucky enough to open port 22 to configure a specific IP to work properly. I have tried every option I could think of. I have been able to set up a port forwarding port 22 to work on a much simpler system (not linksys) but with the RVL200 it has proven difficult.

    Using Static IP.
    Gateway and DNS servers established.
    The router is configured for the ISPs information.
    The DHCP client is up to allow all users to obtain an IP automatically.
    The internet works fine and the majority of the other router features seem to work fine.
    I have set up port forwardig for the IP address and port 22.
    I have told the firewall that the IP and the port (service management) should be LAN/WAN. tried many different configurations.

    Anyway, I have tried multiple configurations to open port 22 but no luck not mentioned in this initial thread. Ask me and I will tell you if I did that or not. I do not want a DMZ opened for security reasons so this is not an option at this time.

    Contacted tech support twice and it was escalated to a higher tech level. I have yet to receive a return call or actually speak with an advanced tech.

    Please provide some insight thanks.
  2. deathscythebjorn

    deathscythebjorn Network Guru Member

    My RLV200 works with SSH (port 22). All you need to do is forward the port 22 to the IP address of the server. You can go to Setup>Forwarding.
  3. coherentsys

    coherentsys LI Guru Member

    Well, that was what I thought but my router is not allowing the port forwarding to happen. What I did was create a service management SSH TCP 22/22 and a SSH UDP 22/22 and added the IP address of the server but the router does not open the port.

    Thanks for the info.
  4. Paul_B

    Paul_B LI Guru Member

    Can you see what is happening from the logs? I have a similar problem with forwarding port 25. It seems from the logs that the port is being forwarded to an emphirical port on the internal LAN rather than the same port.

    Be interested to know if you are having the same issue
  5. coherentsys

    coherentsys LI Guru Member

    I will look into it but I think I may have figured out the problem. I have to test it first but can not shut down the server until later tonight to try. What I was thinking is that I am connecting my server to a switch which is connected to the RVL200 router. I am not certain if it will fix the problem but if I plug the server directly into the RVL200 it may work. Maybe it is a stab in the dark but worth a try.
  6. deathscythebjorn

    deathscythebjorn Network Guru Member

    To isolate the problem, try if you can SSH to the server from within the LAN. You may also try to forward TCP 22 only. Some routers are having a problem openning a port if you specify both TCP and UDP with the same port number.

    By the way I am using fw 1.1.5
  7. coherentsys

    coherentsys LI Guru Member


    Yes we can login within our LAN on SSH. I run a putty terminal and VNC serer on an XP machine to login to the Linux machine we want on port 22 to be open.
  8. coherentsys

    coherentsys LI Guru Member

    RVL200 Port 22 issues

    I tried a number of things suggested and no luck. As a test I tried a firmware version 1.1.5 and port 22 work perfect. The only problem is that I do not trust the firmware and reverted back to the 1.0.14. I have not made the time t review the code of 1.1.5 to confirm if it is secure enough to use. I generally prefer to use released version from the manufacturer.

    What I have determinined is that the 1.0.14 released version has an issue with port forwarding. As soon as I installed the 1.1.5 it worked fine, but when reverted back to 1.0.14 it did not work.
  9. deathscythebjorn

    deathscythebjorn Network Guru Member

    If you dont trust the firmware posted here, I suggest you contact Linksys and ask for the released version from the manufacturer that will fix your problem.
  10. Toxic

    Toxic Administrator Staff Member

    The official release is 1.0.14. the beta release is 1.1.6. Both are released by Linksys but only Official firmwares are hosted on the Linksys Download site. if you want the beta firmware then download it here, or goto Linksys Tech support and ask for it. both Linksys Beta and our hosted Beta are the same.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice