RVL200 - What a nightmare this device

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by weston, Jul 10, 2007.

  1. weston

    weston LI Guru Member

    I have been using linksys routers for a long time. I decided to get this unit thinking the SSL VPN would be a great idea for me to access files from work. It has been nothing but a nightmare to get this thing up and running.

    While I realize I am running beta firmware, I have used beta firmare in the past for other linksys devices such as the WRT54G and never had any problems.

    It came flashed with 1.0.14 and I have now tried 1.1.15 and presently 1.1.16. The unit is buggy as hell requiring numerous restarts. The VPN virtual passage client disconnects me randomly and the so called NETBIOS support for virtual passage is non-existent, even with the new firmware. I do not feel like having to edit lmhost files or create DNS entries manually on my server. This isn't some high end feature and this is supposed to be a business class product according to linksys for cyring out loud! I am very dissapointed with the device so far...

    Does anybody have Netbios support even with the new firmware without the lame workarounds? Just wondering if I am the only one. I am getting pretty close to pissing on this unit and returning it...
  2. Toxic

    Toxic Administrator Staff Member

    I have had none of the problems that you have described in your post. have you reset to factory defaults when you upgraded to the beta firmware? what type of WAN connection do you have? what MTU setting do you have? are you running any torrent of p2p sharing software that is maxing out the amount of connections perhaps and forcing a reboot?

    Before you piss on the RVL200, have you contacted Linksys Support? Did you bought the unit from a Linksys VAR,because if you did, the "business unit" entitles you to 2nd level support. Have you contacted linksys themselves at all? you have not said so in your post. have you tried enabling "Netbios over TCP/IP" in your TCP/IP properties of your PCs?


    I also doubt that "pissing" on the device will solve the problems that you have encounted, unless you have some underlying fetish you wish to discuss, but please find a forum that is on topic for that type of action :wink:
  3. weston

    weston LI Guru Member

    In answer to your questions:

    1.- Your suggestion to enable netbios over TCP/IP is an often misunderstood approach taken by most users not familiar with networking. First of all, unless your have configured your connection manually OR have specifically directed your DHCP server to dsiable netbios over TCP/IP, netbios over TCP/IP (also known as NetBT) is ALWAYS enabled regardless of what options you see in windows. It is also only necessrary when you are dealing with broadcast traffic. In other words, enabling this when that it is already enabled makes no difference whatsoever.

    2.- Second Tier support is a joke when it comes to these low end devices. I will most likely get someone in Mumbai who will either not have a clue, not care, or give me some BS about running non-supported beta firmware; so, I rather not waste my time with tech support and attempt to research the problem myself and get to chat with you fine people as an added bonus :wink:

    3.- I did perform a hard reset on the device after flashing, my MTU is set to 1500.

    4.- I am not running any bandwidth intensive applications and the router configuration is pretty basic with 2 allocated SSL tunnels. That's it.

    5.- No fetishes of that kind, although I am aware of such "Toxic" forums (no pun intended)

    I guess I was expecting too much from this unit by expecting it to perform its most basic advertised function.
  4. Toxic

    Toxic Administrator Staff Member

    I take it you have a Cablemodem connection for the MTU to be set at 1500 yes? have you tried setting the MTU to a slightly lower value to try and fix you disconnection issues?
  5. Toxic

    Toxic Administrator Staff Member

    The other thing to remember is your expecting everything to work on a beta firmware. Netbios afaik was not supported in the official firmware. so any additional features could contain some issues. "expecting" them to work is expecting to much perhaps?
  6. weston

    weston LI Guru Member

    A fair statement to a certain extent. What I meant is that basic features such as NETBIOS support is to be expected out-of-the-box. Specially if you are going to advertise this as a 'business unit'.

    Don't get me wrong, I do not mind tinkering with it to improve certain functionality aspects. In fact, I have DDWRT running on two other WRT54G units and they work wonderfully, but to have to tinker with this unit so much in order to gain the basic functionality one would expect from a VPN solution is ludicrous IMO. That is my beef with it I guess.

    At any rate, the MTU was set to auto before which one would expect to work itself out and I have set it to 1500 because that is how other WRT54G units I've had were set as well. I will try your suggestion and lower the MTU to see if that helps. I was actually considering it to be a problem with the activex control perhaps, but we'll see.

    My main reason for using beta firmware was the desire to gain netbios functionality. Other than that, I could have easily waited for an official/production release. I am truly puzzle by the fact that it does not work after reading how the beta firmware is supposed to make it work.

    Bizzare to say the least...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice