RVS4000 Firmware updated and frozen - cannot get into it!

Discussion in 'Networking Issues' started by orientdude, Dec 4, 2008.

  1. orientdude

    orientdude Addicted to LI Member

    Thanks to all for all the useful information posted on this forum. I had the router functioning for months until last weekend which it decided to give up. Update the firmware from 1.1.14 to the latest 1.2 using the firmware utility, then the router froze up and cannot access it, with the DIAG led constantly on.

    I would appreciate from you experts on here, as a near intermediate (still learning) needs advice how I can recuperate access to the router, obtain the older firmware versions, reload and retry?

    Thanks to all for reading.
  2. erratio

    erratio Addicted to LI Member

    Have you tried a hard reset and see whether that changes at least the status of the diag light?
  3. Toxic

    Toxic Administrator Staff Member

    try downloading the Firmware rescue utility on linksys.com dont know if it will help but worth a try.

    RVS4000 Firmware Rescue Utility v1.2


    The utility should be used when the normal firmware upgrade mechanism through the Web Admin interface fails and the DIAG LED is blinking. The utility uses a layer-2 protocol to upload the firmware to RVS4000, thus there is no need to set a static IP address on the computer running this utility. However, it is required to disconnect all other network cables to the router including WAN and LAN ports.

    This version removed the firmware version checking mechanism, so it can always be used when the DIAG LED of RVS4000 is blinking, regardless which firmware version the device has. The utility will install RVS4000 firmware v1.1.11. Later version of firmware may be available at Linksys.com.

    Hope this helps.
  4. orientdude

    orientdude Addicted to LI Member

    Thanks for the replies.
    Unfortunately, I used the the utility to upgrade/downgrade the router which resulted with a constant DIAG red LED. Before the using the utility I tried upgrading to the latest firmware, which resulted with a non-compatible firmware version and did not complete the upgrade. Only then I decided to try a hard reset only to find it does not work after 10sec, 20secs and 30 sec attempts, the red LED still remains constantly lit. I think I have either crashed it or totally destroyed the router and it may need to be binned.

    Any advice is appreciated. Thanks!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice