RVS4000 - FTP issue

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by halakar, Mar 9, 2007.

  1. halakar

    halakar LI Guru Member

    Hey guys, how is everyone?

    I am taking care of a network for a small church here in the valley. Recently setup a VPN for them, and purchased this router. VPN is working perfectly, but there is an employee there who needs to upload FTP files for their website, and since the new router was put in, she can access the FTP site hosting their website, but can't upload or download files. What's going on here? I looked around in the settings under Firewall - > IP Based ACL. It said "Enable "All Service" for LAN and WAN, from ANY source or destination, from ANY time. Seems the router should pass the FTP traffic. Would Stateful Packet Inspection have anything to do with the problem? Does anyone here have any ideas? If you need any more information from me, let me know please. Thanks gang!

  2. bctrainers

    bctrainers LI Guru Member

    Heya, i've had the same issue also... before i upgraded my firmware to the latest version i would be able to get peak speeds. However, once i upgraded, my FTP upload and download speeds cannot get above 2kb/sec. It seems like a minor bug to me. :(
  3. halakar

    halakar LI Guru Member

    Beautiful response, dude. We are running the stupid beta firmware on the router. No idea why. Will downgrade if possible. So, how to do so, and where is the firmware file? Thanks!
  4. tony4d

    tony4d LI Guru Member

    Just a thought, untested and not sure if it will help you at all ...

    Try disabling IPS and see what speeds you get. Others reported dramatic wan throughput increases when they disabled IPS with the latest firmware.
  5. halakar

    halakar LI Guru Member

    Disabling IPS, or SPI?
  6. tony4d

    tony4d LI Guru Member

    In other cases just disabling IPS did it. Might as well try both I guess though.
  7. bctrainers

    bctrainers LI Guru Member

    I've tried disabling one or the other and both, neither worked for me. Just really really slow. Be nice to have another firmware upgrade to fix these little annoying bugs. In addition a fix to the static ip adding / routing under the Setup - lan section. It's all foobar'd in Firefox. :(
  8. halakar

    halakar LI Guru Member

    Still having the problem. What's the fix, gang?
  9. vpnuser

    vpnuser LI Guru Member

    I would suggest you contact Linksys Support and log the case number here so the guy who manages RVS4000 know the issue. Make sense?
  10. Bartjuh

    Bartjuh LI Guru Member

    I got exactly the same problem, and i'm getting quite frustrated from the router. I'm 100% sure the problem lies with the router (different FTP servers, passive/active, different computers etc).

    I tried 3 different firmwares (fromt the initial one, to 1.1.09, to 1.1.13 beta). Tried turning off the firewall, turning off spi, fixing the MTU on 1500 (someone on a other forum said it worked for him on a other linksys router), but to no avail.

    I can find a lot of poeple with FTP upload problems on the internet, with all kind of linksys routers, but usually they don't find any solution, or find a very strange one.

    Can anyone help me? Or did you find a solution halakar?
  11. tony4d

    tony4d LI Guru Member

    If you're running windows, copy and paste what happens ...

    Click Start -> Run
    Type "cmd" and click OK
    Type "telnet your.known.working.ftp.host 21" and hit eneter

    When typing do not include quotes.
  12. Speed Demon

    Speed Demon LI Guru Member

    Re: Download speed drop

    I've found that its possible for the RVS4000 to end up with a bad firmware load without any warning of any type. Upon completion of the the firmware load and reset back to factory defaults, shut down your web browser and restart it. Return back to the IPS page and disable the IPS. Shut down the web browser again and restart it. If your web browser loads it's default page, that usually means that the firmware upload has been successful. If the web browser appears to hang and fails to load the default page, that is usually indicative of a bad firmware load. Reload the firmware and go through the same routine to determine if the firmware load has been successful.

    Regarding the speed drop, I've found that since the upgrade from Versions 1.0.xx, my download speed with IPS enabled dropped from about 14Mbs to 8 Mbps, and has improved up to 10 Mpbs with versions 1.1.11 and 1.1.13. With IPS disabled I usually run downloads at slightly above 20 Mpbs. Running a direct connection without the router yields a download rate slightly above 20 Mbps. This is on a 25 Mbps service.
  13. jlbcrp

    jlbcrp LI Guru Member

    If you have flow control (QoS) enabled make sure it is setup to give enough bandwidth to your special activity in this case FTP upload...
  14. rtk9k

    rtk9k Guest

    Speed Demon - I tried your procedure to reload the firmware on my RVS4000 that is having the FTP connectivity issues, but unfortunately it did not solve the issue. I repeated the process five times, using a combination of different workstations and cables for the firmware upgrade. Each time after the upgrade and reset to factory defaults, I observe the browser hang-up behavior after I disable IPS. Any ideas how I can get past this? Are there any alternate methods of flashing this device that I can try?

    Also, I noticed that during the firmware upgrade, the RVS4000 reboots when the progress bar is 52% complete. Has anyone else noticed that this is the case with their device?

    Thanks; everything else about this product works perfectly in our environment but the FTP problem is driving us nuts!
  15. Speed Demon

    Speed Demon LI Guru Member

    I've found that a reload with the same firmware file usually solves the bad load problem. If you keep coming up with the same result I would suspect that the firmware file that your trying to load has some sort of problem. Try downloading another copy of the file and overwrite or delete the first firmware file. I suspect that this won't solve the FTP problem, but it should get you to a point where the upgrade runs to a successful completion.
  16. Bartjuh

    Bartjuh LI Guru Member

    I resolved the issue... by buying a d-link dgl4100 router. I was totally irritated by the fact that something so basic as FTP did'nt work.

    But i have'nt tried Speed Demons method....
    someone interested in my almost new but with FTP problems RVS4000 for 50 euros? ;)
  17. miediev

    miediev LI Guru Member

  18. cmajewsk

    cmajewsk LI Guru Member

    Ftp Sux

    It is the router - I've replaced this one with my Netgear RVS318 and FTP works fine. When I am FTP'ing locally it works great but when I am outside on the internet - it simply drops down to such a slow speed making FTP worthless.... So I know it's something with the WAN connection that does not transmit data very well thru this thing. Who knows, not even Linksys as I have contacted them and it's been a complete waste of time. Do ANY of these beta releases address this problem? :thumbdown:
  19. bctrainers

    bctrainers LI Guru Member

    I'm on 1.1.14 and I do not have any FTP issues. Try reloading your firmware to a newer one. :)
  20. cmajewsk

    cmajewsk LI Guru Member

    hmmm...did you ever have an FTP issue? Even with the 1.09 version?
  21. bctrainers

    bctrainers LI Guru Member

    In v1.09 my FTP speeds never went over 2KB oddly enough. :frown:
  22. cmajewsk

    cmajewsk LI Guru Member

    And with v1.14 your experiencing no FTP issues?
  23. bctrainers

    bctrainers LI Guru Member

    Sorry for late reply, yeah, speeds went back to normal for me. LAN and WAN sides. :)
  24. cmajewsk

    cmajewsk LI Guru Member

    I'll give it a whirl and see - thanks!
  25. cmajewsk

    cmajewsk LI Guru Member

    FTP w/ RVS4000 SUX!

    Oh well - the same results with 1.1.14 as with 1.1.09 - trying to FTP from, or to anywhere is a joke with this router:thumbdown:. Not even using my FTP server - it still doesn't work worth a damn!:mad:

    Here is a screen shot of me downloading (via FTP) a 1.5MB BIOS update from IBM directly connected to the internet via the RVS400 - when I switch to download the file via http it works fine, and actually downloads the file.


    Here is me doing it from the same laptop - however I am VPN'd in (via Cisco VPN Client v5.00) to my office, using their Internet connection. (still thru my router of course):


    Tried it with turning off the firewall, IPS, etc - still no FTP. Even created an FTP rule that allows FTP and that didn't effect this - I would say lousy, but really there is no performance at all! I give up - I'll use it as a dumb switch and go out an buy something NON-LINKSYS - probably, dare I say it - NETGEAR - never had an issue w/ a NETGEAR product they just didn't have GIG switch with one of their routers when I bought this one...good luck with this hunk of junk router everyone....have fun wasting your time!
  26. Steve46

    Steve46 LI Guru Member

    Having similar FTP issues...

    Ok. My first post here.

    I am having seemingly similar issues with FTP with my RVS4000 to any FTP servers outside of my local
    network. I have tried various versions of firmware including 1.1.09 and 1.1.11 as well as older (I
    don't recall which). I've even RMA'ed my device and am using the replacement that LinkSys sent,
    but to no avail. The current Firmware version on that device is 1.1.09. The symptoms are as follows:

    1. I can successfully connect to the external FTP site and log in, but attempting to transfer any
    amount of data fails early in the process. For example, after a successful login, when I execute a
    DIR command, I only get a partial (about half) directory listing returned and the listing "hangs"
    and then ultimately fails. It's worth noting that my home directory consists of about 85
    subdirectories and about 10 files.

    2. A normal file transfer attempt fails similarly very early in the process as well.

    3. Changing the MTU setting in the Router (per suggestion from LinkSys support staff) from 1500 to
    1300 had only one effect: It caused the size of the directory listing to shrink and fail slightly
    earlier in the process.

    4. Enabling/Disabling the firewall has no effect.

    5. Turning on port triggering for ports 20/21 has no effect.

    6. Using different FTP clients and/or changing between Active/Passive has no effect.

    7. Disabling IPS has one notable effect: No PCs on my network can connect externally until it is
    reenabled. (This, by itself, seems fundamentally wrong to me and indicative of other router


    BUT... making my pc a DMZ host allows FTP to WORK FINE and if I bypass the router entirely and just
    plug into my cable modem, FTP works just fine as well. (These are both obviously unacceptable long
    term solutions for any number of reasons.)


    I have a site-to-site VPN connection to our hosting locations and all FTP connections across the
    VPN work just fine. (Presumably because it's all 'internal' traffic to the router.)

    These issues are specific to the RVS4000 as I've used both an RT41P2 and BEFSX41 in the past with
    no FTP issues at all.

    It is my sense that the RVS4000 router is simply not translating the normal exchange of FTP PORT commands properly for the NATed devices inside my network and that is the problem. Diagnosing that problem, however, is well above my level of expertise.

    I am not a networking expert, but I can almost always work my way through problems after reading a
    few posts. This one has me frustrated, exhasperated and stumped! I would greatly appreciate any
    insights as to the problem if anyone has them.

  27. cmajewsk

    cmajewsk LI Guru Member

    Steve46 - I don't think the FTP problem with the router is something we are going to be able to fix ourselves - so I would not waste anymore time on it. At this point it's up to Linksys to listen up and create a firmware that will address it. Otherwise I think we are SOL.
  28. cmajewsk

    cmajewsk LI Guru Member

  29. Steve46

    Steve46 LI Guru Member


    Solved. FTP finally working! I had been suffering with this damn FTP issue for almost a year and happened upon a post on another site with a very simple suggestion: "Turn off MAC address cloning". I gave it a shot by disabling it in the admin, rebooted my cable modem and the router, and my FTP started functioning normally immediately. I am currently still using firmware version 1.1.09.

    It's worth noting that a business colleague of mine has MAC address cloning enabled on his RVS4000 (firmware 1.1.14) and his FTP has always worked successfully, though the "cloned" address is from an old pc he no longer has active on his network.

    I hope others find this information helpful.

  30. Steve46

    Steve46 LI Guru Member

    Oh. And one other thing... after disabling MAC address cloning, disabling IPS no longer causes the router to quit working.
  31. Toxic

    Toxic Administrator Staff Member

    I suggest you look at the new firmware rather than waking up an old thread :)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice