RVS4000 issues

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by pitbull7270, Feb 13, 2009.

  1. pitbull7270

    pitbull7270 Guest

    Trying to setup 2 Linksys RVS4000s and having problems.

    I am helping a friend out who needs to setup a remote workplace. He was told to purchase the Linksys RVS4000s, so he did. He then asked for them to configure them and they didn't have anyone who did such things, so he asked me for help. I have never used one of these products before, but have done both network and Linux work in the past.

    Was trying to test these with a Linux box acting as a router to ensure they were working before install. The remote location is very far away.

    The problem that I am running into is that from the workstation I can't ping the other workstation. Also trying to ping anything on the other side of the Linux router from a workstation fails. I am also unable to ping the workstations from the Linux box, but I can ping the RVS4000s. Logged into the switch I can ping the other switch through the diagnostics page. The VPN says UP, but I can't do anything. They will be using a Mac and VOIP phone on the remote side.

    All IP addresses have been changed to protect the innocent

    This is how the Linux server is setup:
    This would be the office
    eth1 is setup as,

    This would be the remote
    eth2 is setup as,

    I have turned on ipv4 forwarding using the echo "1" > /proc/sys/net/ipv4/ip_forward.
    I tried installing and using firestarter but that didn't work either. I have also tried some archaic iptables forwarding and that actually made the VPN tunnel go down. I currently have iptables and selinux off to try and test this. Other settings I have tried:
    echo "1" > /proc/sys/net/ipv4/conf/default/rp_filter
    echo "1" > /proc/sys/net/ipv4/ip_dynaddr
    echo "1" > /proc/sys/net/ipv4/tcp_syncookies
    echo "1" > /proc/sys/net/ipv4/tcp_sack
    echo "1" > /proc/sys/net/ipv4/tcp_timestamps
    echo "1" > /proc/sys/net/ipv4/tcp_window_scaling
    echo "1" > /proc/sys/net/ipv4/ip_forward

    The Linksys are setup as follows:
    wan ip= nm= gw=
    lan ip= nm=
    workstation ip= nm= gw=

    remote:(will be dhcp later, assigned static to test)
    wan ip= nm= gw=
    lan ip= nm=
    workstation ip= nm= gw=

    On the RVS4000s I have turned off the firewall, DoS Protection, and Block WAN Request. I have also disabled the IPS as well. Once I can ping the other workstation IP I will turn everything back on, I was just banging my head on the desk and wanted to make sure nothing was blocking the packets.

    From the workstations I can ssh into the Linux server eth port of their lan segment. So I can get into the Linux box from the workstation, just can't see the workstation from the Linux box.

    Any help would be greatly appreciated. Or guidance, are the RVS4000s compatible together? Do the RVS4000s by default kill ICMP requests going through them? I need to either get this working or tell them they bought incompatible hardware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice