RVS4000 stops working

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by itishere, Nov 9, 2007.

  1. itishere

    itishere Guest

    I've been using RVS4000 for many small business projects as it has a good feature set for a basic networking solutions. Unfortunately I had to replace at least 4 units (and counting) due to unpredictable "stopped working" situations. For router/VPN/DDNS solution they were replaced with RV042 but with the loss of gigabit switching. Unfortunately, there is nothing else in the product line with gigabit+router.

    I have experimented (at my office) with two of the RVS4000 and have suffered the consequences. This device has a MTBF of 3-4 hours. I've tried resetting, using limited features and FW1.1.14 but nothing stops the units (I've tested 2 so far) from hanging. When it does hang then the only recourse is to power off/on and it always comes back to life.

    Has anyone else has similar experience and/or a solution?
  2. tony4d

    tony4d LI Guru Member

    Yup. It happens to me on a home network that isn't very busy.

    With beta 1.1.14 it has happened 4 times in just over 2 weeks. It really is ridiculous!
  3. rayyar

    rayyar LI Guru Member

    RVS4000 hang and found "hit KRIS_DDOS_TYPE=18" in the log

    Same problem using 1.1.14; it just hang suddenly, reboot is the only option. I guess just to reboot it every day until they have a good fix. Will call Linksys support line tomorrow to see if they have any ETA, or even acknowledge this problem exists.

    I have switched on SYSLOG since I used the rotuer and captured the system log, I noticed the following entry every time when the router was dead:

    007-11-14 16:27:11 Kernel.Warning Nov 14 16:27:39 hit KRIS_DDOS_TYPE=18

    and observed that the router hanged after the timestamp. Once the router reboot the follow entry was found:

    2007-11-14 20:10:23 Kernel.Info Jan 1 00:00:32 Kris Linux Driver:Version=v1.59(Sep 26 2007:16:46:00)
    2007-11-14 20:10:31 Kernel.Warning Jan 1 00:00:40 Kris is unlocked
    2007-11-14 20:10:31 Kernel.Warning Jan 1 00:00:40 Reset IDP Engine!!!

    I am not a Linksys engineer and I do not know if it is related to the problem; but on the surface, it seems like the "hang" is related to this couple of lines.

    If any Linksys engineer reading this post, hope this will help you to fix the problem as this is a very good rotuer if it works.
  4. rayyar

    rayyar LI Guru Member

    the problem may be related to the WAN interface

    I have more update on the RVS4000. Two days ago, the RVS4000 stop working again, after rebooted it many times, it still did not work. So I switched back to my old router but encountered the same problem. I then called the Cable company and ran some diagnostic, finally, they told me it was related to the single strength from of the cable wire. I unplug the cable from the wall, the splitter and reduce the number of splitters. The old router is back to life, then I tried the RVS4000 and it is working fine for the last two days since.

    I did Google and learn that I can login to the cable modem to monitor the signal strength ( the userid and password will depends on the model brand name, Google it and you will find it).

    I suspect the DDOS hit encountered before was related to the cable signal strength, since packet was dropped, RVS4000 logged it as attack. It could be the RVS4000 WAN interface driver/software is much more sensitive then the other router and therefore hang much more than other old models.

    I hope my RVS4000 will be stable from now on, otherwise it leave me no choice but to return it.

    Any Linksys engineer (or Manager who decide what shall be the next job for the engineer to work on) still alive out there, please help the user to fix the RVS4000.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice