RVS4000 v1.1.09 Benchmark tests

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by jppowers14075, Feb 13, 2007.

  1. jppowers14075

    jppowers14075 LI Guru Member

    Has anyone benchmarked this FW for TCP throughput w/ the FW on/off and IDS on/off ???

    Joe P
  2. Macsmasher

    Macsmasher LI Guru Member

    I just had Verizon's fiber optics installed last week. The plan that I subscribe to is 15 MB downstream and 2 MB upstream. The problem that I found with my RVS4000 router is that it caps the download speed at around 12 MB. When using the ActionTec router supplied by Verizon, I get a consistent 15 MB downstream.

    I've contacted Linksys about this issue, was finally transferred to level 2 support, and after doing everything we could possibly do was told by the technician that there is nothing that can be done at this point. He has since submitted it to their firmware department. And yes, my firmware is current.

    Upload speeds seem to be fine. It's only download speeds that are affected. At this point in time, my RVS4000 is sitting on the shelf gathering dust...

    I have not tried it with the firewall off.
  3. jppowers14075

    jppowers14075 LI Guru Member

    Could you try the latest beta firmware that is available??? See the sticky post at the very top of the forum. I also have had to take the RVS4000 out of my network due to it limiting the 20/5 Fios at 12-13Mbps. I purchased a Zyxel Zywall5 that I have not gotten yet, but I want to use that at work(also 50/5 Fios) and the RVS at home for a VPN end to end solution.

    Joe Powers
  4. Macsmasher

    Macsmasher LI Guru Member

    Okay I've updated the firmware to v1.1.09 beta, using the file provided on this forum. Prior to upgrading, I benchmarked my speeds using speakeasy.net out of Seattle using my ActionTec router. Here are the speeds it posted:

    15916 / 1843
    15944 / 1842
    15932 / 1838

    Then I released my IP address, took the ActionTec router out completely, hooked up the Linksys RVS4000, flashed it, reset to factory defaults. These are the numbers it posted:

    9416 / 851
    10411 / 856
    9604 / 869

    I then changed the MTU to manual with a setting of 1500. These are the numbers it posted:

    10494 / 1793
    11468 / 1830
    11660 / 1836

    I then tried disabling all firewall and security features. I got pretty much the same numbers, maybe even a little slower.

    I must say, I'm not a happy camper...
  5. tony4d

    tony4d LI Guru Member

    This is pretty troublesome. For me it is not a problem, only have 7m/512k right now, and the fastest my cable company offers is 12mb/1mb (no fiber available here yet).

    Anyway, this sucks, and I really hope they address it in the next official firmware. This new beta firmware added a lot of stuff and has a few bug fixes, but it would be really nice if they could address this issue.
  6. jppowers14075

    jppowers14075 LI Guru Member

    Thanks for the effort and post Macsmasher. I guess I am looking for another Zyxel. This RVS4000 is for sale.

    Joe Powers
  7. Macsmasher

    Macsmasher LI Guru Member

    When I bought the RVS4000, I assumed I was getting a business class router. After all, that's how they present it. But, maybe most businesses don't require a fast Internet connection. What was I thinking??? :)

    In addition to the aforementioned speed problems, this router takes forever to reboot.

    On a positive note, the VPN function did work quite well. I could access my networked drives or operate any of my computers on my networked with Remote Desktop. I'll hold onto it for a month or so to see if they resolve this issue. If they don't, I have a client I can sell it to that has standard cable broadband. It would be fine for him.
  8. sunil3112000

    sunil3112000 LI Guru Member

    Hi Guys,

    I have bought a new RVS4000, i also downloaded the new RVS4000 1109 firmware.

    I was just trying to learn IxChariot software so i thought to test RVS4000 Performance with IxChariot.

    I have two PC's with ixChariot Installed, One PC is connected to a LAN Port of RVS4000 and the other one connected to the WAN Port of RVS4000.

    Iam using the IxChariot Script "High Performance ThroughPut.scr" on IxChariot to test the Performance.

    Iam testing the performance in two different configurations

    1. IPS Enabled
    2. IPS Disabled

    Following are my observations/results
    1. Throughput When IPS Enabled = 10.287 Mbps
    2. Throughput When IPS Disabled = 209.074 Mbps

    Here when IPS is disabled thruput i assumed to be 1Gbps, but i did same testing on other routers from other vendors with similiar capabilities had same numbers, now i think it got to be my test setup because here iam using PC's with Celeron processor and 512 Mb RAM. I assume if i use PC's with pentium and 1 GB RAM, may be the performance numbers would improve.

    The results screenshots are attached to this post, pls feel free to
    view my screenshots.


    Attached Files:

  9. DocLarge

    DocLarge Super Moderator Staff Member Member

    Thanks for your submission. If possible, could you describe the steps in configuring "Ixia" to include how you conducted your testing? This is something that could definitely be of use to others as a sticky...

  10. Toxic

    Toxic Administrator Staff Member

    when testing were you using TCP or UDP? TCP uses acknowledgments which slow down your test results. did you also have QoS enabled? this is another feature that will slow down your results
  11. reb0

    reb0 LI Guru Member

    This is pure TCP, correct?

    Do you have the extensions for IxChariot to perform the same test with PPPOE?
  12. sunil3112000

    sunil3112000 LI Guru Member

    Yes the IxChariot " High Performance Thruput.scr" is pure tcp script.
    i dont have any info on PPPoE support on IxChariot, if any of u guys have any info on that or any performance tools which can support PPPoE please let me know.

  13. jppowers14075

    jppowers14075 LI Guru Member

    I highly doubt the accuracy of the above number.

    Joe P
  14. tony4d

    tony4d LI Guru Member

    Macsmasher, with the beta firware installed, you should try:

    1) Reset router to factory defaults
    2) Disable IPS
    3) Test speeds again and see what you get
  15. Macsmasher

    Macsmasher LI Guru Member

    Linksys tech support called me back and addressed this issue. (I'm very impressed actually.) They recommend exactly what Tony says, which is to disable IPS. That completely fixed the issue of slow connectivity, and I'm now running at full speed without issues.

    Thank you everybody for your input on this issue. Have a great 2007!
  16. tony4d

    tony4d LI Guru Member

    Hey, great news macsmasher! Thanks for posting again with your results :D
  17. MavDude

    MavDude LI Guru Member

    Sigh, this seems to be the exact problem I have. But turning IPS off does not help at all.
    I have a 24Mbit connection, with a zyxel modem/router. But I bought this RVS4000 to have a gigabit network at home. When I connect directly to the modem it's almost full speed, around 23Mbit. But when I connect through the linksys router, everything is slow. Around 8Mbit in tests. And a 100mb file from my ISP's ftp comes in at around 600Kb/s, which is not even 8Mbit. The same 100mb file comes flying in at 2Mb/s when connected directly to the modem. I've tested with the latest firmware (1.1.09) and with the beta firmware I received in januari (1.1.15).

    Ridiculous, all I can say. I've spent 3 weeks in dec/jan to help tech support fix and test the cable modem hostname issue. And now that I've moved to faster dsl there are again problems with this thing. This router is advertised as a broadband router with internet speeds going over 20mbit, so why is this not working?!

    The rvs4000 datasheet:
    But it seems it's just another bottleneck router. :/

    My ISP uses "ENET ENCAP" as encapsulation by the way, instead of PPPeO. The linksys router does not have that option, so I can't use my modem in bridgemode and the linksys router connected to it? Or is there a substitute for ENET ENCAP on the rvs4000? Right now I'm using automatic config(dhcp), with the modem in router mode.
  18. Eldorage

    Eldorage LI Guru Member


    I bought the RVS4000 on whim (installed a NAS box and wanted my home network all at gigabit ethernet). Stumbled on this thread and it had me a bit worried, so I checked out my speeds at speedtest.net, and I get

    19.3x Mb/s down
    2.7x Mb/s up

    very consistently (the 'x' varies slightly between runs). Phew.

    I have Comcast "business level" service (extra $10/month) and on the RVS4000 I have IPS turned off.

    Another thing I have done is set the MTU on the ports to 9216, and turned on jumbo frames on my PCs. :dog: Unfortunately my NAS box (DNS-323) does not have a knob for this (yet).
  19. datdamnmachine

    datdamnmachine LI Guru Member

    Any updates as to possible fixes to this problem or is the following all Linksys offers:

    1) Reset router to factory defaults
    2) Disable IPS
    3) Test speeds again and see what you get

    Has the latest beta firmware fixed any of these issues?

    Also, Eldorage, is that MTU nmber correct? Can you elaborate on that some more? I'm currently researching...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice