RVS4000 v1.1.13 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Aug 31, 2007.

  1. Toxic

    Toxic Administrator Staff Member

    RVS4000 Firmware v1.1.13 Release Note

    * Please reset the router to factory default settings after firmware upgrade. *

    8/25/2007 (beta testing)

    1. Bandwidth Management (Rate Control) under the QoS tab supports IP Range.
    2. Fixed the interop issue with QuickVPN Client v1.2.5 running on Windows Vista.
    3. Fixed some compatibility issues between the Web Admin Interface and the Firefox browser.
    4. Fixed an issue with VLAN configuration - the previous firmware only supports VLAN ID up to 4.
    5. Updated the Help info about Trunk mode in the VLAN Port Settings page.
    6. Updated the Help info about the SIP ALG in the Firewall->Basic Settings page.

    Known Issues:

    1. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client not being able to establish a tunnel with the remote QuickVPN Server successfully. Microsoft has released a patch to fix this issue. Once you install the patch, the issue should be resolved.

    2. There is a known issue with SIP ALG, which may block the incoming VoIP calls. Outbound calls from VoIP phones in the LAN can be made without problems.

    Download is available here: http://www.linksysinfo.org/forums/downloads.php?do=file&id=66

    Please report any problems with this firmware in this thread. Please make sure you can replicate the issue and give as much info as possible to others to test the issue as well. Thanks.
  2. ZeGhostbear

    ZeGhostbear LI Guru Member

    Thanks for posting the download.

    Now let's cross our fingers and hope this firmware revision performs minor miracles.
  3. quickvpn

    quickvpn LI Guru Member

    I'm not able to get QuickVPN working.
    Error: 'Remote Gateway is not respondig'
    Can anybody try this else?

    XP Firewall is off, Router was resetet after firmware Upgrade.
    I installed kb 889527 patch from Microsoft. Remote Gateway (RVS4000) is
    in another subnet as indicated in the router menu (
    IPS is off
  4. Toxic

    Toxic Administrator Staff Member

    The Linksys KB points to this as the problem

    This prompt will appear when the IPSec tunnel can be established, but the remote router cannot be reached. Check that you are not using the same subnet as the remote network (i.e., if your local network is on a 10.252.240.x subnet, the remote network cannot use the same 10.252.240.x subnet). Then, restart the client computer and try establishing a connection again.

    It might also be that the remote router is not responding. try rebooting the remote router as well and double checking the remote router has the correct VPN Client details.
  5. quickvpn

    quickvpn LI Guru Member

    Hi Toxic,

    okay, here are some details about the Network situation:

    Station1: RVS4000 <>
    Station2: Speedport <> (Firewall out, DMZ on)

    Username&Password: double checked
    Routers are rebootet
    Patch is installed

    What the hell should i do?
  6. Toxic

    Toxic Administrator Staff Member

    Are both RVS4000 units are the gateway routers with the internet between? or are they behind any other router/firewall?
  7. quickvpn

    quickvpn LI Guru Member


    just one RVS4000, the other Router is a Speedport W500V from T-Com.

    Both Router are directly connected to the internet.
  8. tony4d

    tony4d LI Guru Member

    Thanks Toxic for posting this :D

    The bug I had in firefox adding statis ip maps has been fixed (http://www.linksysinfo.org/forums/showpost.php?p=304121&postcount=12) :)

    Also, since they made a note about firefox improvements I went ahead and checked every single page in the router's admin section, not a one has layout problems in firefox anymore! Now, I didn't check the javascript functionality of everything, but overall it's much better and I really appreciate linksys taking care of us firefox users!

    I'm still having problems with saving settings in places. Both static ip map updating and single port forward updating kill my connection to the router (and the internet) for several minutes. It's really strange and may be normal considering the router is changing configuration and updating DHCP leases and whatnot, but it's very frustrating and would be nice to have a notification on screen about what is happening, or is going to be happening. Most of the time I have to release and renew my network adapters settings.

    As far as speed, looks like things went a little downhill. With IPS disabled I'm only getting around 9 mbps (on a 12 mbps connection). With IPS and the firewall disabled I'm getting my full connection. See results below:


    This is very troubling. I understand this isn't an enterprise cisco pix, so I can deal with not using IPS. But now the SPI firewall is gonna kill my speed? This really needs to be addressed.

  9. tony4d

    tony4d LI Guru Member

    Well, ok, maybe the speed test was an anomaly. I just re-enabled the firewall and I got even better speed.


    I realize these internet speed tests have a lot of factors that can affect them, so I guess it was just bad timing on the first test.

    OK, so one more issue, somewhat related to what I mentioned about static ip map and single port forward updating. When I re-enabled the firewall just now, after I clicked "save settings" the browser spun for only about 5 seconds, and the settings were saved. Then, I tried to go somewhere else in the admin and the browser just spun. I opened a new tab in my browser and realized I had no internet connectivity either. Checked another computer, same thing. After about 3 - 5 minutes, router administration and the internet was back. Weird that it takes so long, and with no warning that it's "doing something".
  10. david803sc

    david803sc LI Guru Member

    I noticed with 1.1.13 my download speed seem to be decreased, but it is hard to say since there are many variables, on these speed tests but the speed test from my provider went from a consistent 6.2 down to about 5.7 down after 1.1.13, could just be a coincidence, I don't see any change/degradation in upload speeds though.

  11. Toxic

    Toxic Administrator Staff Member

    With faster and faster home internet connections being given out by the ISPs there is no way you can guarantee the full speeds now since there are so many variables in the equation. rrouters are one small part. websites are not all on 100Mbs connections, a lot are on 10Mbps and if the site is busy then speed to these sites are slower, same with ftp sites.

    best way if you have free webspace on your site is to put up a large file (100Mb+) on to the website and try downloading it.

    When testing please make sure your anti virus program is also disabled. more and more anti virus packages also check data coming in and will therefore slow down any data incoming.

    have you all raised the size of your RWIN if using Windows and tweaked the TCP settings? http://www.linksysinfo.org/forums/downloads.php?do=file&id=10
  12. tony4d

    tony4d LI Guru Member

    Oh yea, forgot to mention, port 5190 is still open in 1.1.13!
  13. bctrainers

    bctrainers LI Guru Member

    Agreed. :confused:
  14. jlbcrp

    jlbcrp LI Guru Member

    Hi, Toxic,

    I have downloaded and will let you know what I think. Any way to get my hands on the GPL code :)
  15. Toxic

    Toxic Administrator Staff Member

    AFAIK the GPL code is only released by linksys when "official" firmware has been released. since this is Beta firmware its classed as "test" firmware and therefore they do not have to release the src code. thats my guess anyway.
  16. umox

    umox LI Guru Member

    Since firmware 1111, Telnet port 23 also reports as being closed, but not stealthed like everything else. Same as others experiencing the AIM port being open. I don't have any AOL software installed so I am not seeing this as being open for myself. I'm currently running Vista Business. I did have Telnet enabled at one point when I was testing Cisco ASA5505, but have since uninstalled through add/remove components. Not sure if this is a Vista thing, or some kind of stuck reminenant on Linksys. I have hardware reset atleast 3 times since then. *Sighs - Wish I held out for the Cisco ASA5505's instead. Since day one, nothing but issues with the Linksys RVS. :/ Fingers crossed though.

    My only other issue with this firmware is I am now having some kind of wierd DNS issue, every couple days internet seems to go out. I can ping websites, access the RVS admin site, all things seem AOK. But I cannot access any websites via a browser. Logs show no errors. Software reset through admin site fixes issue - only for a couple days.
  17. klazzik

    klazzik LI Guru Member

    I downloaded and 1.1.13 firmware and tested it. A port scan reveals that not only is 5190 open and 23 closed but port range 201 to 298 are closed in this firmware instead of being filtered.

    I tried to revert to version 1.109 but the router will not let me. It says the firmware is not meant for this router. I could only revert to 1.1.11 but which also has port 5190 open.

    I think the work you guys are doing is great but how do we help linksys test for new firmware if it means openning our doors for hackers? Can this be looked at asap?
  18. vpnuser

    vpnuser LI Guru Member

    Did you try the RVS4000 firmware rescue utility v1.2 posted on linksys.com?
  19. wilsonvpn

    wilsonvpn LI Guru Member

    Which version of QuickVPN can work with this firmware ? I download the latest 1.2.5 but failed to connect.

    (Which port does the RVS4000 listen for incoming QuickVPN connects ?)
  20. klazzik

    klazzik LI Guru Member

    Yes, I did. The rescue utility v1.2 contains version 1.1.11 of the firmware.
  21. quickvpn

    quickvpn LI Guru Member

    No one
  22. wilsonvpn

    wilsonvpn LI Guru Member

    So what can I do with this "VPN?" router ?? Can quickvpnplus help ??
  23. frostytech

    frostytech LI Guru Member

    1.1.13 & Port Triggering

    Bug in 1.1.13:
    Port Triggering will lock up the RVS4000 with 1.1.13.
    Does not matter if IPS is disabled or enabled.

    This is the same port triggering rule I've used in SR41s, SR81s, and SRX200s with no problem for years. So, yeah, it's a bug, or broken feature...

    Plus side of 1.1.13:
    Setting upstream and downstream WAN QoS works fine.
    Solid 24/7 PPPoE connection under heavy load for days.

    That's all I know for now.

    I do have one question..
    Anybody tried using a Wii with the RVS4000?
    I personally have not..

    Yet I know a couple people that cannot get the Wii to work with the RVS4000 (1.1.09) and they say the Wii works fine with other Linksys routers, such as the WRT54g with oem firmware. Any ideas?
  24. jlbcrp

    jlbcrp LI Guru Member

    wii, xbox, ps3 all should work fine.... I have not yet done it with the new beta firmware but I have done it with standard fimrware. I just simply use port forwarding or a DMZ zone for the xbox...etc....etc

    Should have no problems though
  25. klazzik

    klazzik LI Guru Member


    I have been able to revert back to firmware 1.1.09 and after doing a portscan, all the ports seems to be filtered as expected. I think I will stay away from beta testing and wat for the final release.

  26. tony4d

    tony4d LI Guru Member

    Well, if nothing else, Linksys should fix all these port inconsistencies in the next production release of the firmware.
  27. bctrainers

    bctrainers LI Guru Member

    Seems to be an odd issue i found in the latest firmware: Under high load of connections from lan to wan, or wan to lan traffic... the routers admin page will not load, but rather time out. :confused:

    EDIT: Also forgot to mention, during high load the syslog will seem to not send any data for a few seconds than about a few more seconds later, it will flood the syslog client with a ton of messages. :|
  28. wilsonvpn

    wilsonvpn LI Guru Member

    Anyone know what combination of QuickVPN client version and Firmware version can work together ??

    I brought this RVS4000 primary for vpn access but now it become an Giga HUB !!!

    Please help help !! Thanks a lot . :)
  29. vpnuser

    vpnuser LI Guru Member

    RVS4000 1.1.13 works well with QuickVPN Client 1.2.5 on Vista.
    If your Vista has QuickVPN Client 1.0.39 installed, you will need to manually clean up the registry on Vista in order to get Client 1.2.5 successfully installed. Life is not always easy with the free Client.
  30. wilsonvpn

    wilsonvpn LI Guru Member

    Can you give me some hints on vpn setup ? After added a vpn user in the router admin page -> save or even reboot. The port 443 and 60443 is not listening to any connection (even using "telnet hostname 443") what else is required to configure ??

    I am using Windows XP SP2 with the firewall turned off. Any cue ? :wink:
  31. david803sc

    david803sc LI Guru Member

    1.1.13 Bug if you disable IPS and select reboot router from the admin tab it will reboot the lights will be normal but the router will not respond, I tried this on two different RVS4000's with 1.1.13 and it seems to happen everytime.

    Work around, plug in the router while holding down the reset button on the back for 10 seconds, you will retain your settings and the router will boot ok with IPS disabled.

    If IPS is enabled it will reboot normaly no reset neccessary.

  32. bctrainers

    bctrainers LI Guru Member

    Have had the EXACT same issue myself, only fix was to power cycle the router. :)
  33. tony4d

    tony4d LI Guru Member

    Maybe that's the same issue I was experiencing. Posted about it earlier in this thread.
  34. tony4d

    tony4d LI Guru Member

    OK, this firmware is very unstable. In the last week, twice now I've lost my internet connection, and it wasn't my ISP or cable modem.

    This morning when it happened I went into the router and rebooted it. The reboot page timed out, and then I didn't have internet nor could I get back into router administration for about 5 minutes. Finally, everything came back.

    I'm gonna leave this installed cause I don't really want to go through downgrading firmware and setting all my stuff up again. Please report as soon as a new beta firmware is available though. :( Thanks!

    Imagine that, right when I tried to post this message the internet dropped out again, grrrrrrr. Maybe I'll have to downgrade after all!
  35. david803sc

    david803sc LI Guru Member

    I used the v.2 recovery method on the linksys website to go back to 1.1.11 and it bricked my RVS4000, I had to exchange it, now the replacement also has become bricked with 1.1.13 I treid the recovery utility and no dice, I am calling my Linksys contact to swap this one out, my advice to stay away from 1.1.13 but if you do have it, do not try to go back to a lower version it seems to brick it every time.

  36. micrisc

    micrisc LI Guru Member

    It's very sad that linksys realeased this router and has never had a stable firmware for it. I wish I could get a refund after waiting a year for them to make something that works right. I am still using my BFSR11 and for many years it has been solid. Seriously, If anyone from linksys is reading this, I want either a refund or a FULLY working firmware. I don't think that is too much to ask for.
  37. int3grate

    int3grate LI Guru Member

    Open PORTS!

    5190 still open, and telnet port still in closed state.
  38. likster

    likster LI Guru Member

    Just to report in: stability is still an issue with this release.

    The router just seems to lock up , not forwarding any traffic and no admin page. Unplug to reset.
    I havent found any one thing that causes it. It doesnt even seem to be high bandwidth.
  39. tony4d

    tony4d LI Guru Member

    Yea, my router crashes every couple of days with this firmware. Have to unplug it and plug back in to get it going again, and even then it takes several minutes before it works.

    Now I'm afraid to downgrade to :(
  40. david803sc

    david803sc LI Guru Member

    if you attempt a downgrade follow this procedure:

    1) Restore to factory defaults

    2) try to load 1.1.11 through the admin utility

    3) restore again to facotry defaults

    you may be ok, however before you do all of this, download the v2 Recovery Utility from the linksys website just in case. Like I said earlier two of mine RVS4000's were bricked after trying to downgrade from 1.1.13 so i would only do this if there is no other option. We can hope since this seems to be a serious issue that they will send out another upgrade ASAP to address this locking up issue.

  41. tony4d

    tony4d LI Guru Member

    Thanks for the post david. Here's what I just did:

    (I started on 1.1.13)

    1) reset to factory defaults

    2) upgraded firmware to 1.1.11 (standalone firmware find it here)

    3) reset to factory defaults

    Works like a charm. Erm, well, it's still buggy, but I had 1.1.11 before this and never had random dropouts like I did with 1.1.13. Hopefully I'm good now until they release another beta.
  42. Solinga

    Solinga LI Guru Member

    Number of VLANs

    Don't know if this bug is reported already.

    RVS4000 (1.1.13 beta) does not let you configure more than 3 VLANs beside VLAN 1. Thought it should be 4. VLAN counter includes default VLAN in count.
  43. sinux

    sinux LI Guru Member

  44. rtallmansu

    rtallmansu Guest

    How long to close ports

    I have been using Linksys products for many years now and have never had to come into these forums to get answers and/or to send a "WTF" to Linksys but the RVS4000 has changed that. I have two RVS4000 routers in two separate locations that are hampered severely by code. Beta version 1.1.13 sounds like it is soooooooooo close to meeting our needs other than the open ports in the firewall which really mean that the code is worthless to anyone that actually bought the router for a working firewall. My whole point for writing this was really not to ramble on but to ask, how long can it really take to close an open port or two in a firewall so that code which may have other issues is at least SAFE for people to use!?!? So here it is, that WTF Linksys, please at least make a quick update to close ports that are open and that you have or should have known about for weeks so that those of use with something to protect on the other side of your equipment can take advantage of all your labors.

    Thanks in advance
  45. tlamonia

    tlamonia LI Guru Member

    QuickVPN still doesn't work correctly

    Even with the beta code, QuickVPN 1.2.5 does not work correctly. It still hangs at "verifying network." I'm running Windows XP Pro SP2. I disabled firewalls on all devices and installed the MS ICMP patch, still no dice. But, eventhough the client hangs on "verifying network" I can still connect to the LAN on the other side through the VPN while it's hanging. So that's my workaround for now. I sent an email to Linksys tech support and probably will never hear back from them, but if I do, I'll let you know if there is another beta that fixes the problem once and for all.
  46. tlamonia

    tlamonia LI Guru Member

    No Dice

    Linksys does not accept emailed support inquiries anymore. I don't feel like sitting on hold for hours, so I'll just patiently wait for a fix.
  47. Solinga

    Solinga LI Guru Member

    RVS4000 VLAN - DHCP bug

    Seems to be a bug (1.1.13 beta).

    4 VLANs set up (VLANID 1, 10, 20, 40).
    Wireless Access Point attached to VLAN 20 (
    PC connected wireless as DHCP client gets IP from VLAN 40 (
  48. tlamonia

    tlamonia LI Guru Member

    Got it to work finally. Thanks to Linksys. For Windows XP users, go to Linksys support site and download and install QuickVPN version 1.1.0. You can find it under RVS4000 technical support.
    For Vista Users, download and install QuickVPN version 1.2.6.
  49. mleining

    mleining Network Guru Member

    limiting connections

    I've noticed having the web browser set to check every time or with a very small cache (which forces it to repeatedly download the images) will cause the router to overload with too many connections remaining opened (this shows on the IP conntrack page, http://<router>/ip_conntrack.htm). If you access the web admin pages using a browser set up to only check for newer pages occassionally and with a large enough cache, the browser does not keep as many connections opened and things work better. This is not new to this firmware, and was the same with the .09 version.

  50. mleining

    mleining Network Guru Member

    I upgraded to 1.1.13 from .09 and now my ACL's are logging to the syslog. I'm trying to get this set up so that I can submit my access logs (or more accurately my inbound "Deny" logs) get submitted to ISC/Dshield as I did with my WRT54GS/HyperWRT). It does not appear to me that the RVS4000 firewall and IPS are logging to the syslog, and even when I turn off the IPS and firewall, I do not get any inbound "Deny" entries in the syslog. I've tried various options from having everything turned on to only the inbound logging with no success at logging inbound connection attempts. I can see that the IPS is logging things locally, but nothing to the syslog - has anyone else noticed this behavior?
  51. mleining

    mleining Network Guru Member

    ACL logging to syslog?

    ... I neglected to mention that I did specifically add an ACL entry to log everything, but it appears to only log LAN packets and allowed WAN packets. Denied WAN packets do not get logged. If I add an ACL to deny LAN packets, the Deny entries for the LAN appear in the log.

    Allow and Log All Protocol ANY ANY ANY Any Time Every Day
    Enable Allow All Service LAN ANY ANY Any Time Every Day
    Enable Allow All Service WAN ANY ANY Any Time Every Day

  52. bctrainers

    bctrainers LI Guru Member

    You'll need to have those ports forwarded for the firewall to send syslog any port scan notices. I can accomplish this by setting DMZ to on to a blank IP on the lan. :)
  53. umerok

    umerok LI Guru Member

    I have 1.1.13 on my rvs4000 and quickvpn 1.2.6 on vista business. No luck, same problem (stuck on "Verifying network...").

    edit: tried to connect with an xp sp2 machine using quickvpn 1.1.0 and I got through, so I'm thinking its definately a vista issue. Tried again with the vista firewall on and it still didn't work.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice