RVS4000 v1.2.06 Beta Firmware released.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Jul 20, 2008.

  1. Toxic

    Toxic Administrator Staff Member

    Changelog is limited and may include more than just the following:

    Firmware 1.2.06 fixed the following issues.
    - "Deny All" ACL Rule blocks internet access.
    - RVS4000 supports Vista (SP1 and non-SP1) QVPN 1.2.8 (with public ip and with private ip)


    if you find any other fixes or featire please let us know.
  2. Lovaduck

    Lovaduck Addicted to LI Member

    Great, maybe this release will fix my problems with this product. Where do I find QVPN 1.2.8? I've found a download for QVPN 1.2.11, should I try and see if that newer version works with this?

    Best regards!

    Lord Lovaduck

  3. Toxic

    Toxic Administrator Staff Member

  4. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

    What I experienced:
    *Port range forwarding is not possible anymore. Enable buttons simply don't work.
    *New menu item: "Protect Link" (you have to purchase something for anti-spam)
    *enabling Firewall blocks all internet access
    *enabling/disabling QoS
    *one more single port forward rule ?
    *auto jump to next field when entering MAC/IP

    Besides this I don't see any new features (but I have not tested everything).

    This is total crap, I am reverting back.
  5. samuel613

    samuel613 LI Guru Member

    This is great! I haven't had a chance to have the full staff use it, but in my limited trial, it worked great, and I have successfully connected to the RVS4000 VPN from a Vista X64 machine using the latest QuickVPN.

    Note, though, that the QuickVPN software may claim it can't connect you because you must have entered an incorrect password, etc. Say OK to the prompt, and ping the router's LAN side IP. You should be in. If not, try closing QuickVPN and trying again. Ping again. The only downside is that I need to access the router's VPN config page to disconnect my computer from the VPN, as QuickVPN doesn't recognize that the connection was successful.

    But it does work, and I was able to browse the network over the VPN by IP address in Vista over an Intel Wireless network adapter.
  6. samuel613

    samuel613 LI Guru Member

    I wonder if this firmware will allow FTP uploads - did not, unless you reset the router, after which it allowed FTP uploads for about a minute or two, and then blocked them, again. FTP was NOT blocked in the router, in case anyone is wondering, nor did I have any port forwarding enabled.
  7. tony4d

    tony4d LI Guru Member

    Guys, make sure to reset to factory defaults after you update the firmware. That should be the first thing you do after it has been updated.

    So far so good for me, but the real test is how long the router will go without needing a reset. Currently I have to reset my router once every week, sometimes more.

    If someone has a syslog server I'd be curious to see if they cleaned up the constant errors from the router. My syslog server is offline now.
  8. bctrainers

    bctrainers LI Guru Member

    Works decently here.

    Syslog debug spam crap is all gone (yay!).

    Port forwarding is completely broke, including range, single port and that last section.

    IPS seems to lock up router if all features are enabled over a prolonged time.

    Massive increase [went from 384k to 1mbit] in my DSL upload speed with this new firmware.

    bug: remote management can be enabled with default password of admin on non-standard port (not 8080).
    bug: syslog will be spammed with THIS IS NOT A LINKSYS DEVICE!!!! on bootup sometimes.
    feature: you can click on the image ports on the main page of the router to get information now. Very nifty.

    That's all i can see for now.
  9. tony4d

    tony4d LI Guru Member

    I've already gone back to 1.1.14. This beta firmware was drpping my internet connection on a daily basis. At least my router only locks up about once per week with 1.1.14 :rolleyes:
  10. Puffnstuff

    Puffnstuff Network Guru Member

    I think the worst part of this firmware update is the fact they want you to pay for some protection that was already part of previous versions. I do like the reduced false intrusion detections. I don't have any problems maintaining my internet connection nor does it have any problems with my hp procurve switch.
  11. cmajewsk

    cmajewsk LI Guru Member

    Did this fix FTP?
  12. Puffnstuff

    Puffnstuff Network Guru Member

    No it did not. Plus on the unit I had disabling ips made it slow down to like a 2400 baud dialup session.
  13. Toxic

    Toxic Administrator Staff Member

    tonyd please check your messages....
  14. donathome

    donathome LI Guru Member

    can anyone provide any more details on FTP and the upgrade to 1.2.06? I have 1.1.14 now and want to know if it is worth the effort to upgrade?
  15. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

    Do not update at the moment, 1.1.14 is the best you can get! The new firmware is really a beta and buggy as hell.
  16. Lovaduck

    Lovaduck Addicted to LI Member

    Does anybody have a working link to the 1.1.4 firmware (the last officially released version)? I am trying to download it from the Linksys website but the link fails to download it :mad:. Tried getting into Linksys FTP directly but can't find it there either. So does the link to the userguide.


    NEVER MIND AS SOON AS I POSTED LINK STARTED TO WORK!!!! And I've tried several times last week. Reverse Murphy's law at it's best! :biggrin:
  17. Stray_Bullet

    Stray_Bullet Network Guru Member

    Too all the others about FTP. I had the same problem. I searched everywhere. People saying disable the firewall... disable this & That... To solve this & get FTP working with Firmware 1.1.14, ALL I had to do is disable MAC Address Cloning!

  18. tony4d

    tony4d LI Guru Member

    Guys, today as I tried this firmware again I noticed something weird. After what seemed like exactly 12 hours of uptime my internet connection dropped. To clarify:

    1) This morning at about 10:30 am I had to reboot the router.
    2) At about 10:30 pm this evening I was using the internet and all of a sudden I couldn't load any websites.
    3) I checked and the router was still up and the admin interface was accessible
    4) Also, I verified that my cable modem was connected to the internet and working fine. Essentially, it was only the router that was not able to use the internet, or, at least clients connected to the router weren't able to.

    The interesting thing here is the exact 12 hours of uptime. The only reason I mention it is because when I first tried this firmware I remember about the same timing then, 12 hours and my internet was gone.

    If anyone has the time and patience I'd appreciate if someone could reproduce my issue.
  19. tony4d

    tony4d LI Guru Member

    If that is truly the solution then it explains why I've never experienced the ftp issue.

    I use ftp on a weekly basis, sometimes every day. I've been using this router for 18 months or so and have actually had the hardware replaced once. So, that's two different RVS4000 routers I've been using and I've have never experienced the ftp issue that others constantly complain about.
  20. Puffnstuff

    Puffnstuff Network Guru Member

    Sad that you have to undo features to get around their broken functionality. I'm glad that I went ahead and took mine back for the refund.
  21. cmajewsk

    cmajewsk LI Guru Member

    Very interesting. I do have that enabled and have tried pretty much everything else to get FTP to work. But if I disable that I don't think my ISP will assign me an IP address..
  22. Toxic

    Toxic Administrator Staff Member

    so can you guys confirm that ftp is broken when mac address cloning? or is it broken all the time?

    what WAN connection do you guys have?

    is IPS enabled?
  23. nitehawke

    nitehawke LI Guru Member

    Ran 1.2.06 on my RVS4000 for about 3 days now.

    1) It still chokes if anyone runs P2P or makes several connections
    2) Even without P2P traffic, router performance degrades and eventually requires a hard reset with in 24 hours.

    I'm not running FTP, so I haven't tested (or experienced) any of FTP issues that plagued prevoius firmware releases.

    I haven't even bothered to test the VPN functionality because the first two items above are deal breakers.

    Yes it is beta firmware....but seriously...I'm not holding my breath that the final release will be any better.

    Bottom line is: RVS4000 = crap. Poorly designed at the hardware level; even half decent firmware probably couldn't save it's life. :angry:

    Back to my BEFVP41 v2 until I can afford to purchase a real VPN solution.
  24. tony4d

    tony4d LI Guru Member

    I've abandoned this router.

    Linksys, if you're reading this, seriously, I'm not writing here to bash you. This router has never been a stable product, ever. Sure, I used it for over a year and I got a lot accomplished with it, but not without hard resetting it every week, at least once. Not to mention, when I wanted to change a static ip map or single port forward, it would take 3 minutes to complete, then it might crash.

    So yea, I don't feel like I deserve all my money back, but I do feel slightly robbed, especially considering this is dubbed "a business product". Honestly, you guys should just leave that to the real Cisco line. I finally purchased a Cisco 871 and now I'm gonna try to get $50 for my rvs4000 using the linksys to cisco trade up program. $50 in my pocket and no longer having to deal with or look at the rvs4000 will be justice.

    For everyone else here, go spend $400 - $600 on a Cisco 800 series router and a good Cisco book from O'Reilly. You will not regret it :D
  25. Ingram

    Ingram LI Guru Member

    Why don't you guys try going back a few versions? I use V1.1.09 and it has currently been running 14 days, 3:39:2 (I copied this right from the webpage).

    I guarentee that includes lots of heavy (peer-to-peer, etc.) traffic, but I'm not going to check. I do run the IPS feature as well, it just does not check HTTP and FTP. I have an ftps server going and it works fine. I do not use the VPN feature of the router as I don't trust it and since it doesn't just run as a service (I use OpenVPN, it doesn't add work for the user). The router updates a DDNS name, runs the firewall (guessing its SPI), port range forwarding (single port forwarding doesn't work), a pppoe internet connection, time updates from NTP, and syslog. I think thats all, but I can't say I remember. I also do not plug anything extra into the router. There is currently 2 cables going to this router. One is for my internet connection and the other connects it to my switch.

    Hope this helps...
  26. uffez

    uffez Network Guru Member

    I unfortunately bought this router this week. Spent a few evenings trying to make standard set-up work, but I had to give up. Tried both 1.1.14 and 1.2.06 - but they both had their own tricks making it impossible...

    As far as I have understood from reading on this forum and others it seems it is no use even trying to get it work? Personally I have never ever dealt with such an unstable product - ever...

    So, is this a dead product from Linksys? It is still for sale - quite remarkable. But, can one ever expect to be able to use it as a gateway, which was my intention. Reading the Linksys docs indicates it to be a "business grade" product.... Strange....
  27. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

    Return it as long as you can!

    Since its release some years ago the RVS4000 is buggy and Linksys doesn't do anything to fix it. New firmwares makes it worse instead of better...

    If you want a fast and stable router get something else. Preferably not from Linksys.
  28. Corby

    Corby Guest

    Dropped connections


    I have been following the threads on several forums looking for an answer to my issues which is that my RVS4000 Firmware Version: V1.1.14 (from new) drops the WAN connection at the same time everyday (4.12am ish New Zealand time). This is running PPPoE authentication to ISP. A reboot fixes it.

    I was wondering whether the router hangs due to some malformed packet or DDoS although I cant find anything in the logs ??

    Any ideas,

    PS. I have the latest firmaware but havent upgraded yet.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice