Save Settings problems when Flashed to Satori 4.0g

Discussion in 'Cisco/Linksys Wireless Routers' started by Proteus_3k, Oct 12, 2004.

  1. Proteus_3k

    Proteus_3k Network Guru Member

    Hi. I've just bought my WRT54G and read about the Sveasoft firmware upgrades, and I liked the idea of using both DHCP and fixed IP's for certain machines, so I went ahead and updated the firmware to Satori 4.0G. It updated fine, and my pc obtained an IP from the DHCP server, so I thought it had worked.

    The problem is, whenever I change any settings and click Save Settings, it loads the page to say it's successful, but when I click Continue to go back to the config page, it can never reach that page, or any other config page. The only way I can get it working again is to pull out the power cable and reboot the router that way.

    I managed to downgrade the firmware back to some stock linksys firmware (had problems with this too, since the flash utility program would not update the firmware, kept giving an error about invalid something, can't remember exactly, presume it didn't recognise the new firmware), and I'm currently running on that stock firmware.

    Has anyone else had these kind of problems?

    I hate a WRT54G Ver. 2 and am now running on WRT54GV2_2.04.4_US_code firmware

    I would really appreciate any help with this, since while it's good enough on it's own with DHCP, I really would like to fix at least 1 of my machines IP addresses and have the recent dynamically assigned

  2. Toxic

    Toxic Administrator Staff Member

    when you upgraded to satori did you do a full reset?
  3. Proteus_3k

    Proteus_3k Network Guru Member

    Yes, I followed the procedure I found saying to hold down the reset button for 8 - 10 seconds, then install the new firmware. When it's finished the diagnostics, do another reset to load the defaults for the new firmware, then start using it. It then worked fine, until I came to save some settings.
  4. dds

    dds Guest

    Static IP

    I've found a few things with the linksys access point that don't function as they should, the web url blocking being one of them.
    A work around for your problem is to give your PC a static IP address in the upper range of the DHCP's your Linksys is passing out. For example, if your DHCP range is apply statics starting at because DHCP passes them out starting at I tested this on my network and it worked.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice